Jump to content
PaulOBrien

4 Apr Ir13 (IMM76D / 4.0.4 / CDMA + GSM): MoDaCo Custom ROM for the Galaxy Nexus

Recommended Posts

I'm having a problem with the included Dev Tools app. When I select the "Development Settings" item, I get the following security exception in logcat:

I/ActivityManager(  230): START {act=android.intent.action.MAIN cat=[android.intent.category.TEST] flg=0x10000000 cmp=com.android.development/.DevelopmentSettings} from pid 1970

W/ServiceManager(  141): Permission failure: android.permission.HARDWARE_TEST from uid=10013 pid=1970

D/PermissionCache(  141): checking android.permission.HARDWARE_TEST for uid=10013 => denied (610 us)

E/SurfaceFlinger(  141): Permission Denial: can't access SurfaceFlinger pid=1970, uid=10013

D/AndroidRuntime( 1970): Shutting down VM

W/dalvikvm( 1970): threadid=1: thread exiting with uncaught exception (group=0x40a521f8)

E/AndroidRuntime( 1970): FATAL EXCEPTION: main

E/AndroidRuntime( 1970): java.lang.RuntimeException: Unable to resume activity {com.android.development/com.android.development.DevelopmentSettings}: java.lang.SecurityException

E/AndroidRuntime( 1970): 	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2443)

E/AndroidRuntime( 1970): 	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2471)

E/AndroidRuntime( 1970): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1985)

E/AndroidRuntime( 1970): 	at android.app.ActivityThread.access$600(ActivityThread.java:122)

E/AndroidRuntime( 1970): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1146)

E/AndroidRuntime( 1970): 	at android.os.Handler.dispatchMessage(Handler.java:99)

E/AndroidRuntime( 1970): 	at android.os.Looper.loop(Looper.java:137)

E/AndroidRuntime( 1970): 	at android.app.ActivityThread.main(ActivityThread.java:4340)

E/AndroidRuntime( 1970): 	at java.lang.reflect.Method.invokeNative(Native Method)

E/AndroidRuntime( 1970): 	at java.lang.reflect.Method.invoke(Method.java:511)

E/AndroidRuntime( 1970): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)

E/AndroidRuntime( 1970): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)

E/AndroidRuntime( 1970): 	at dalvik.system.NativeStart.main(Native Method)

E/AndroidRuntime( 1970): Caused by: java.lang.SecurityException

E/AndroidRuntime( 1970): 	at android.os.BinderProxy.transact(Native Method)

E/AndroidRuntime( 1970): 	at com.android.development.DevelopmentSettings.updateFlingerOptions(DevelopmentSettings.java:337)

E/AndroidRuntime( 1970): 	at com.android.development.DevelopmentSettings.onResume(DevelopmentSettings.java:207)

E/AndroidRuntime( 1970): 	at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1154)

E/AndroidRuntime( 1970): 	at android.app.Activity.performResume(Activity.java:4539)

E/AndroidRuntime( 1970): 	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2433)

E/AndroidRuntime( 1970): 	... 12 more

Share this post


Link to post
Share on other sites

@Paul having flashed a fresh bake, using the uv kernel again, but changing to the XXKK6 RADIO (might not be related) but no more random rebooting using setCPU at the following values:

1200: 1150mv

920: 1050mv

700: 950mv

350: 750mv

All good now, many thanks Paul :-) Update: back to random rebooting this morning! So, all uv settings back to default and setCPU disabled :-(

Edited by FatherD

Share this post


Link to post
Share on other sites

I too confirm franco kernel + latest Ir9 = disabled NFC (you cannot enable NFC anymore)

at least on my phone.

It works fine with Modaco custom kernel but immediately disables itself after flashing franco kernel (#12).

Edited by alanhsu

Share this post


Link to post
Share on other sites

I've also noticed that the CRT on/off effect isn't working? The screen just goes black..

What settings do you have for Window animation scale and Transitions animation scale? If set at x0.5 CRT will not work

Edited by masterpfa

Share this post


Link to post
Share on other sites

I wish Google would release a full GNex ROM for 4.0.3 and then we can move forwards and not have these compatibility issues with being half 4.0.2 and half 4.0.3.

I am enjoying MCK. What is it in Franco's or other people's Kernels that people are favouring over MCK? Just asking as maybe some of these could be ported to MCK given nearly all Kernel developers publish their coding.

@Paul - I looked for Volume enhanced ROMs and found a few but none seem to publish their source coding (unlike Kernels) - would pointing you towards ROMs help or is it a bit of a needle in a haystack issue if you don't know what files they've edited. Plus they all seem to be ASOP compiled ROMs.

Eg Manhattan - http://forum.xda-developers.com/showthread.php?t=1432696 "Speaker Volume Enhancement"

Edited by siedkins

Share this post


Link to post
Share on other sites

Im getting bootloops with IR9 and custom kernel r8 with uv only

D/setcpu ( 1562): Applying saved voltages on startup

D/dalvikvm( 1467): GC_CONCURRENT freed 466K, 5% free 14463K/15111K, paused 10ms+2ms

D/dalvikvm( 1562): Trying to load lib /data/data/com.mhuang.overclocking/lib/libsetcpu-native.so 0x41819510

D/dalvikvm( 1562): Added shared lib /data/data/com.mhuang.overclocking/lib/libsetcpu-native.so 0x41819510

D/dalvikvm( 1562): No JNI_OnLoad found in /data/data/com.mhuang.overclocking/lib/libsetcpu-native.so 0x41819510, skipping init

Rebooted 5 times, - my UV figures from setCPU are

1200 Mhz - 1175 mV

920 Mhz - 1050 mV

700 Mhz - 900 mV

350 Mhz - 687 mV

Do these look OK?

Cheers

Edited by gavinlew

Share this post


Link to post
Share on other sites

Hi Paul, and thank you for this excellent rom :)

It's almost perfect for me, but I do have one strange issue. I can't sync the calendar with my work-server running Zimbra (Exchange compatible open source). Mail and contacts sync just fine, but even though the calendar also seems to sync OK when i check the accounts setup on the phone, the phone calendar app will tell me there are no available calendars to sync from this account. This problem has persisted through all your builds (that I've tried). I have never experienced the problem with other roms. Any ideas? Are there any log files I could provide to help you figure out what's going on?

Edited by nyogtha

Share this post


Link to post
Share on other sites

can you include a basic 1% battery in all UI options ?

I would like to change the Percentage Battery but i don't like the UI with both menu button and search...

Share this post


Link to post
Share on other sites

So I did a full wipe, and installed ir9-dev, but I'm getting extremely high Android OS usage in the battery stats. It's not killing my battery (I've only lost about 4% in 2 hours) - yet, but I'm concerned that it's something that shouldn't be happening.

Does anyone know what causes this?

Share this post


Link to post
Share on other sites

Im getting bootloops with IR9 and custom kernel r8 with uv only

D/setcpu ( 1562): Applying saved voltages on startup

D/dalvikvm( 1467): GC_CONCURRENT freed 466K, 5% free 14463K/15111K, paused 10ms+2ms

D/dalvikvm( 1562): Trying to load lib /data/data/com.mhuang.overclocking/lib/libsetcpu-native.so 0x41819510

D/dalvikvm( 1562): Added shared lib /data/data/com.mhuang.overclocking/lib/libsetcpu-native.so 0x41819510

D/dalvikvm( 1562): No JNI_OnLoad found in /data/data/com.mhuang.overclocking/lib/libsetcpu-native.so 0x41819510, skipping init

Rebooted 5 times, - my UV figures from setCPU are

1200 Mhz - 1175 mV

920 Mhz - 1050 mV

700 Mhz - 900 mV

350 Mhz - 687 mV

Do these look OK?

Cheers

I would suggest you try to run the phone without any UV to make sure that is the cause... Looking at your figures I would say the last one looks quite low, but only way to be sure is to run stock voltages initially, if no reboots then try and lower them in increments and see what happens...

FYI - I run 1150, 1050, 950 & 750...

So I did a full wipe, and installed ir9-dev, but I'm getting extremely high Android OS usage in the battery stats. It's not killing my battery (I've only lost about 4% in 2 hours) - yet, but I'm concerned that it's something that shouldn't be happening.

Does anyone know what causes this?

Android OS indicates a rogue app, or it is at least app related... Check your awake times etc... And if you dont have it, grab betterbatterystats from XDA...

Share this post


Link to post
Share on other sites

Android OS indicates a rogue app, or it is at least app related... Check your awake times etc... And if you dont have it, grab betterbatterystats from XDA...

I checked the stock battery app, and no apps had a wake time >1 min. I downloaded/installed the betterbatterystats, and the process that was up at the top was kworker 1-7.

I have advanced task killer frequently kill most processes every 30 minutes. Which might explain why the awake time in Android OS is only at 1.5 hours. I can't seem to find out what is causing it though. The last thing that I installed was Handcent SMS..but I Google'd to see if there was any battery drain issues, but couldn't find anything.

Edited by Unicornasaurus

Share this post


Link to post
Share on other sites

First off let me say thanks to Paul and the others on all their hard work bringing us this ROM, its much appreciated!

I Had a quick search through the thread for the keyword 'drop' and only found one other person mentioning suffering network drops. I'm definitely getting them on IR8. Typically I will have a phone call last 10... maybe 15 minutes before it will drop. I've been chalking it up to possible crappiness of the three network at home. But today I was in three distinct parts of central and north London and had it occur. Throughout these calls I've been sat in one place, not moving around or anything. I've also noticed when sitting at home that the signal bar will fairly regularly (seemingly every 10/15 mintues) go gray, loose the little 3 or H then 10/15 seconds later return to normal.

Is it worth jumping up to ir9? Back down to an earlier version (can I even do that). Is anyone else experiencing this?

Share this post


Link to post
Share on other sites

Post Froyo, task killers are unnecessary and may actually contribute to higher battery usage in Android (please correct me if I am wrong, but that is what I've been led to believe).

Is there a reason in particular why you have one running?

Share this post


Link to post
Share on other sites

Investigating the NFC issue, looks like a compatability pack issue, watch this space.

Fixes for the button patches and the browser searching online shortly.

P

Share this post


Link to post
Share on other sites

GPS isn't working :/ When i turn it on, the icon doesnt appear at the top. Also Co-pilot reports a 'GPS Error' and exits

Share this post


Link to post
Share on other sites

GPS isn't working :/ When i turn it on, the icon doesnt appear at the top. Also Co-pilot reports a 'GPS Error' and exits

works fine for me.

paul rom with franco 12 kernel

Share this post


Link to post
Share on other sites

works fine for me.

paul rom with franco 12 kernel

Going to reflash with another bake. I was using one a couple of fixes ago (but still ir9)... lets see what happens!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.