Jump to content

[FAQ] Rooting for beginners. [UPDATED 24-02-13]

Recommended Posts

Question about making a backup of stock: in part 3 of this guide it states:

"If you make a backup from here, you didn’t make a complete stock backup. You made a backup of everything except the stock recovery partition."

..so is it necessary to make a "complete stock backup", ie. is the stock recovery partition required for a warranty return..? if so how do i make such a backup?


..so i finally found the answer following a link to some info on C3CO's slovakian (?) site.

In case anyone else is a nervous first-timer looking to make a backup of EVERYTHING stock => i used ADB to boot CWM rather than flash it, which loads CWM into memory and allows you to perform the backup without overwriting the stock recovery. in my head i likened it to using a Linux LiveCD.

so now i have a full orange UK monte carlo recovery backup. even tried flashing the stock one back in after installing a custom rom, works fine :) this would be a useful addition to the guide IMHO.

anyway - all sorted and running CM7 for now. on with the show!

Share this post

Link to post
Share on other sites

Thank You!!

Got the ColdFusionX ROM!

Gotta learn much more about rooting and ROMs!

Hopefully wont perm brick it!

Edited by oscar-mark

Share this post

Link to post
Share on other sites

Hey all, I unlocked my phone 2 months ago and everything was working as it should until I couldnt connect to my 3G access for a day then my phone would not get past the orange logo.

Ive searched high and low for solutions and I obviously cant chang my phone to USB debug mode, therefore Windows 7 is not recognising an android device to allow me to update using the google driver ....I can get Handset Mass storage USB device but thats it.

I tried using TPT transfering the image via a card reader but the Root directory is absent on my SD card.

Can anyone help, thank you :)

Edited by MASHleyUK

Share this post

Link to post
Share on other sites

Root directory is just the part of the sd without any folders

Share this post

Link to post
Share on other sites

Thanks, deleted everything on my sd card and added image folder but still no luck. Any other solutions? cheers

Share this post

Link to post
Share on other sites

Thanks, deleted everything on my sd card and added image folder but still no luck. Any other solutions? cheers

You didn't have to remove everything on your phone. You just had to make an image folder in your sd-card. The root is the "main" directory of your storage drive, for example F:. It should look like this: F:\Image. Remember to press volume up and menu when you turn on the phone to go in TPT-modus.

Share this post

Link to post
Share on other sites

I can't find a Guide for using the TPT helper for ZTE Blade!

Shouldn't that work the same, why do you have to use the ADB and all that on the Blade when this is so much simpler?

Share this post

Link to post
Share on other sites

If I want a smaller partition, how do I change? I have the one you said, Skatev2a or whatever it was, 200mb, and I only need 150mb for AtomicMod and I want more space for apps, how do I change the TPT partition?

Can I just install a smaller partition over the 200mb one?

Share this post

Link to post
Share on other sites

i'm @ step 4a but my computer fails to recognize the "android_winusb.inf"


I tried to root for a few days in a row, so I finally decided to try the TPT way and it's so much easier!

You just download an app and then intsall one thing in it and it automatically reboots into CWM!

Share this post

Link to post
Share on other sites

Hello Experts,

I am a beginner in Android phones. I have a ZTE Skate - and I tried installing CWM Things didnt go well and so I am quite stuck now. I did the following :

1. Downloaded TPT helper > All in One > downloaded and placed Skate_v2a.zip under sdcard. Confirmed by looking at it by connecting to windows

2. Start TPT > Install from sdcard > selected zip file from sdcard > ok.

3. Logs came up as -- Installing update... Installation aborted..

Now, when I restart only the green bot comes up. Power key + menu + volume up - brings back to the CWM installation screen.

Please advice next steps on what I could do to complete the installation of CWM.

Cheers, D

Share this post

Link to post
Share on other sites

Can someone please help me with this?

I'm trying to install the Google USB driver, however when I select the .inf file ("let me pick", select android_winusb.inf), it gives me three choices. Which do I pick?


EDIT: Never mind, installed the ADB interface and it worked perfectly. Thanks!

Edited by omegavesko

Share this post

Link to post
Share on other sites

Hi guys, I'm trying to root my dads Monte Carlo and I'm following the instructions in part 4 but in device manager its refusing to install the drivers as its saying "device driver is already up to date" or something to that effect, so assuming that the adb files were correct I double clicked the root for 2.3.5 which is the right version.

Upon the phone restarting the computer says "installing device drivers" then "device drivers not installed" and the phone stays at the green android dude and the window stays at <waiting for device> forcing me to pull the battery to restart the phone, please can anyone tell me what to do as my dad really needs his phone rooting so he can get rid of the orange bloatware currently taking up unnecessary space as well as some games that arent "app2sd" compatible.

Can someone please tell me what I'm doing wrong?

Edited by Uppy

Share this post

Link to post
Share on other sites

TPT is much easier!

Just install the app and follow the instructions in the app or guide.

Get the "Skate_v2a"

Edited by oscar-mark

Share this post

Link to post
Share on other sites

Hold it. You don't know if he wants his phone to be totally wiped.

  • Upvote 1

Share this post

Link to post
Share on other sites


While "waiting for device" open windows device manager, look for device having yellow asterisk, rightclick choose to update driver choose to pick driver manually select "Adb interface" you get the list of available adb interfaces, choose zte composite adb interface, confirm (even if it gives warning about incompatibility)

  • Upvote 1

Share this post

Link to post
Share on other sites


I hope someone can help me, as I think I may have just wrecked my phone.

I've had an Orange Monte Carlo phone for a while, but haven't used it because I didn't like the Orange branding or apps. Having read through the instructions on page one of this thread, I decided to go for the easy "all in one" option. I downloaded and installed TFT Helper, and used it to downloaded the skate-v2a.zip file onto the SD card.

I then followed all the necessary steps, and when my phone restarted I was presented with the CWM-based Recovery v4.0.1.4 menu. I performed the "wipe data/factory reset" and "wipe cache partition" and "wipe Dalvik cache" as described in the instructions, then choose to install zip from sd card, and choose to install the skate-v2a.zip file.

The following messages are then displayed on the screen:

....installing: /sdcard/Skate-v2a.zip

Finding update package....

Opening update package.....

Installing update....

Installation aborted.....

I removed the SD card from the phone and checked the zip file using my PC, and it looks find. I then tried the installation again, but didn't get any further. I then downloaded a new copy of the skate zip file onto the card and tried again, but still no joy.

Whenever I power up the phone, I go straight to the CWM menu, without having to hold any combination of keys.

This is what the recovery log states:

Starting recovery on Fri Aug 3 07:37:49 2012

framebuffer: fd 4 (480 x 800)

CWM-based Recovery v4.0.1.4

recovery filesystem table


0 /tmp ramdisk (null) (null)

1 /boot mtd boot (null)

2 /cache yaffs2 cache (null)

3 /data yaffs2 userdata (null)

4 /misc mtd misc (null)

5 /recovery mtd recovery (null)

6 /sdcard vfat /dev/block/mmcblk0p1 /dev/block/mmcblk0

7 /system yaffs2 system (null)

8 /sd-ext ext3 /dev/block/mmcblk0p2 (null)

I:Completed outputting fstab.

I:Processing arguments.

mtd: successfully wrote block at c2a4800000000

I:Set boot command "boot-recovery"

I:Checking arguments.


Command: "/sbin/recovery"











ro.build.date=Tue Jul 19 20:33:41 CST 2011






ro.product.model=Orange Monte Carlo












ro.build.description=P743T_OUK-user 2.3.4 OUK_B05 eng.zhangchun.20110719.202630 release-keys



rild.libargs=-d /dev/smd0























































I:Checking for extendedcommand...

I:Skipping execution of extendedcommand, file not found...

mtd: successfully wrote block at c2a4800000000

I:Set boot command ""

I would be so grateful if someone could help me with this, but please go gentle with me as I'm new to it all.



Share this post

Link to post
Share on other sites

Think you have tried to flash the tpt. Download a rom such as Skatie or MoKee OS and follow installation instructions on the first or second post to have a new rom

Share this post

Link to post
Share on other sites

Thanks for getting back to me.

I don't really understand what you mean by saying that I must have tried to flash the TPT. I just followed these instructions:

"All in One" This option does all these things for you: Checking if the download isnt corrupted, unpacking the downloaded ZIP file, checking if the unpacked files aren't corrupt and checking if the files still match the original.

If you want to do a "All in One" TPT you can check what partition layout you want to use under "Download a TPT". For example you think "Skate v1b" would suit your needs you can go back to "All in One" and select that option.

When this is downloaded and verified you can start the TPT several ways "Start TPT" to start the TPT. Or power off, remove the battery, put it back in and start the phone with "Power + menu + volum up" all held at once. Or if you are at stock ROM under settings "about phone > update from SD card"

When your TPT is complete, it will reboot into Clockworkmod from here you can install a ROM. (Part 6) Once your ROM is installed delete the "image" folder from your SD so you dont acidentally flash it afterwards.

Anyway, as the only thing that I can load up on my phone now is ClockworkMod, I've downloaded the file from the link in Option 2 on this page:


The zip file has the following files/folders in it:




Do I have to do anything with the checksum that is mentioned on the above page? I can't find a .md5 file within the zip file, but then again, I don't know if there should be one or not.


Share this post

Link to post
Share on other sites

Don't extract the ZIP. Just put in on the SD and use "install zip from SD card", choose ZIP, confirm, reboot

Share this post

Link to post
Share on other sites

Thought I had it working, and I have, apart from one small problem - I can't get on the Internet.

I've checked the settings for the network provider and they are fine. Would the Kitchen update fix this problem?


Share this post

Link to post
Share on other sites

Provide more details please. Wifi or mobile data? What settings exactly?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.