Jump to content
pier11

[ROM] CyanogenMod 7.2 | Kernel 2.6.32 | Camera works

Recommended Posts

one should probably take into account cpu speed. Good practice I'd guess to use stock frequency for tests 528 i.e. No overclock.

Sure. I was running CM6-clean as it comes out of the box. Don't think there's overclock in it by default.

But even if there was, 22 fps is not that slow. I would have expected <10. I don't think people can feel the difference between 22 and 29.

edit: wait - @rulerofkaos: what was you CPU speed? Did you use overclocked .32?

Edited by dr.flo

Share this post


Link to post
Share on other sites

one should probably take into account cpu speed. Good practice I'd guess to use stock frequency for tests 528 i.e. No overclock.

I ran on 528 and 614 MHz, both times the same result.

Share this post


Link to post
Share on other sites

I ran on 528 and 614 MHz, both times the same result.

Hm, then I would tend not to believe that test.

Or is the GPU clocked independently of main CPU - does anyone know?

rulerofkaos, could you try underclocking to s.th. very small like ~300 MHz see what fps you'll get then?

Share this post


Link to post
Share on other sites

Hm, then I would tend not to believe that test.

Or is the GPU clocked independently of main CPU - does anyone know?

rulerofkaos, could you try underclocking to s.th. very small like ~300 MHz see what fps you'll get then?

I think that cpu and gpu are clocked differently... Not sure if our overclock affects gpu.

My though was that if we are experience poor 2D performance, than hardware acceleration is not in use, thus cpu performance comes to first place, thus thought on overclocking effects.

Share this post


Link to post
Share on other sites

I think that cpu and gpu are clocked differently... Not sure if our overclock affects gpu.

My though was that if we are experience poor 2D performance, than hardware acceleration is not in use, thus cpu performance comes to first place, thus thought on overclocking effects.

Exactly. That's why I would have expected different scores for different CPU clock rates, if the benchmark was valid.

On the other hand, in case the benchmark can be trusted, having the same fps for different CPU clocks would indicate that it was rendered using the GPU (hardware acceleration maybe not broken?)

I'd have hoped it turns out to be broken - then there would be something to fix. If it's not broken, then what could we do about 2d performance....

Edited by dr.flo

Share this post


Link to post
Share on other sites

Hm, then I would tend not to believe that test.

Or is the GPU clocked independently of main CPU - does anyone know?

rulerofkaos, could you try underclocking to s.th. very small like ~300 MHz see what fps you'll get then?

just for comparing

tested at (min and max set to the same value)

320MHz - 20fps

528MHz - 29fps

614MHz - 29fps

691MHz - 29fps

Share this post


Link to post
Share on other sites

delete

1) In /system/bin folder

- a2sd

- apps2sd.hlp

- busybox.a2sd

- chka2sd

- dtinstall

- jita2sd

- launcha2sd

- starta2sd

2) In /system/xbin folder

- a2sd

- apps2sd

3) In /etc/init.d folder

- 00banner

- 02firstboot

- 04apps2sd

Edited by zoki.m1
  • Upvote 1

Share this post


Link to post
Share on other sites

how do you do #1 uninstall a2sd?

internal space 500mb+ feels good :-)

edit:

what the good card can be - class 6, class 10? Is stock Pulse 2Gb card good enough - 10 reads 6 writes...

Uninstalling DT A2SD from the rom can be done by looking at the install script in the rom and removing each line that references the DT files. Then remove those files. At least that's how I did it once. YMMV.

Otherwise, you can disable DT A2SD with "a2sd remove". Make sure you don't have too many apps installed already, because this tries to move them back to internal storage.

Edit: Ah, Zoki was posting at the same time. See above.

Edited by twrock

Share this post


Link to post
Share on other sites

I ran on 528 and 614 MHz, both times the same result.

fps2D:

710MHz: avg=24

528MHz: avg=22

320MHz: avg=19

Share this post


Link to post
Share on other sites

just for comparing

tested at (min and max set to the same value)

320MHz - 20fps

528MHz - 29fps

614MHz - 29fps

691MHz - 29fps

this is a lot different than pier11 and rulerofkaos.... what ROM did you use?

Share this post


Link to post
Share on other sites

this is a lot different than pier11 and rulerofkaos.... what ROM did you use?

tested on U8230

the one from pier11 #1 post cm7.2_u8220_20120127.

Mostly on 528, 614 and 691MHZ it gives me 28fps during test but avg is 29fps

Edited by lloco73

Share this post


Link to post
Share on other sites

i use stock Pulse 2Gb card but class 4 and class 6 are good , class 10 not recommended

Eh? My 8gb Class 10 card has never been a problem for me. Why do you say "not recommended"?

Share this post


Link to post
Share on other sites

I know that link2sd can move data and dalvik cache to sd on an individual (per app) base. But I already stated my opinion that the rom should not include such stuff by default. Most complaints about s.th. not working in the ROM was about a2sd stuff. Many people simply do not know how to handle it. For those, simply installing link2sd from the market would possibly be an easier solution.

Just a note, in my alteration of CM6.1 I have rather included Link2SD, you have no problems regarding these mentioned issues.

Choose what to relocate (also with corresponding lib data) and check which apps should remain on internal memory, such as alternate dialer or sms app, etc. This way you can "tweak" slower loading apps to perfection.

Share this post


Link to post
Share on other sites

tested on U8230

the one from pier11 #1 post cm7.2_u8220_20120127.

Mostly on 528, 614 and 691MHZ it gives me 28fps during test but avg is 29fps

and application was Fps2D, not Neocore? :)

(as to me it looks like more Neocore results)

Edited by pier11

Share this post


Link to post
Share on other sites

does adb works on oc rom? I'm not getting it to work.

yes, install new drivers. (It shows up as a generic Qualcomm device)

Share this post


Link to post
Share on other sites

here is a data2ext for this rom flash through recovery

1 uninstall a2sd

2 flash the file

3 in terminal emulator write data2ext --enable

4 restart

done

this only work on ext2 partition

how did you get 500mb on internal storage? is this on a U8220? or someother phone?

I can only get 90.25 Mb internal storage.

cheers

Share this post


Link to post
Share on other sites

how did you get 500mb on internal storage? is this on a U8220? or someother phone?

I can only get 90.25 Mb internal storage.

cheers

it started to recognize ext2 partition on sd card as a part of its internal storage. After installing data2ext. That's my understanding.

Share this post


Link to post
Share on other sites

and application was Fps2D, not Neocore? :)

(as to me it looks like more Neocore results)

yes app was Fps2d

Share this post


Link to post
Share on other sites

you make ext2 partition on your sd card of 512 Mb or max 2Gb .Then flash os 7.2 after it finish instaling you delete a2sd files and flesh data2ext ,reboot and in terminal type su, data2ext --enable. reboot

Share this post


Link to post
Share on other sites

yes, install new drivers. (It shows up as a generic Qualcomm device)

problem was broken driver on windows. reinstalled and now is ok

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.