Jump to content

Recommended Posts

I bought the commtiva n700 for my mom and now she is very frustrated since the device will no longer turn on. I believe she turned it off to save some battery then when she turned it back on there was just a vibration coming from the unit as if it was already about to turn on but to no avail it wouldn’t power up. My mom assumed it was just drained so she charged it in the main supply for several hours now say running 8 hours but still it wouldn’t turn on. I mean normally this unit would turn on even if it is charging. we can only see a red light in the led indicator and by the way we’ve been trying several main power supplies hoping it would help but we are of no luck! please please help this is my mother’s first tablet. I didn’t imagine it would give up just after 2 days usage. I am wondering if there is anybody here who can help me please it's really very frustrating.

Thanks xx

Share this post


Link to post
Share on other sites

I bought the commtiva n700 for my mom and now she is very frustrated since the device will no longer turn on. I believe she turned it off to save some battery then when she turned it back on there was just a vibration coming from the unit as if it was already about to turn on but to no avail it wouldn’t power up. My mom assumed it was just drained so she charged it in the main supply for several hours now say running 8 hours but still it wouldn’t turn on. I mean normally this unit would turn on even if it is charging. we can only see a red light in the led indicator and by the way we’ve been trying several main power supplies hoping it would help but we are of no luck! please please help this is my mother’s first tablet. I didn’t imagine it would give up just after 2 days usage. I am wondering if there is anybody here who can help me please it's really very frustrating.

Thanks xx

Hi

Even if the battery is dead the unit should turn on when plugged into the mains.

Have you tried the re-set, use a pin and it is on the bottom next to the mic input.

Hope you get it working.

Douglas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.