Jump to content
Sign in to follow this  


Recommended Posts

Hi! Yesterday I decided to buy Desire from a guy which he told me is broken. When his wife wanted to update it something happened and it stack on the HTC logo. I thought that it is just for reflashing.

I got it and start flashing. Tried official 2.2 Froyo. And for the hell he stuck on the 35% Updating Radio. I wait around 15 minutes and unplug the usb. After that when the HTC restarted it showed htc logo and four ! and triangles in the 4 corners. When I want to go to the bootloader it showed a little different. I cant do anything. Just shown HBOOT version, RADIO and etc.

I also tried to flash with the official 2.3 from htcdev. Nothing.. It goes to 18% MID/CID and stuck.

Can someone help me? It is S-ON, not rooted, and the HBOOT upgraded itself to 1.02 when i tried 2.3 from htcdev.

I will be very happy if I succeed.

Share this post

Link to post
Share on other sites


from this download


rename in PB99IMG.zip

put in SD card

boot up phone in bootlouder instal PB99IMG. then tray ruu flashing

Share this post

Link to post
Share on other sites

i have exactly the same problem and searched everywhere on the web, but wasnt able to get it working

- like toncata, i'm seeing a black screen + htc logo + 4 exclamation marks

- i can't boot into bootloader with vol-down + power (so the PB99IMG on sccard won't help, right? i put it there anyway)

- when i connect via usb to my pc and disconnect again, i can see hboot info, radio, date and on the bottom "RUU" (look at the photo)

- i seem to be able to send fastboot commands, at least rebooting works, but flashing is not possible...signature fails, not allowed and such things.

guess this is because of S-ON? (i'm not familiar with htc phones, since i only had to deal with samsung and sony ericsson devices)


after i found 2 matching RUUs (vodafone uk froyo OR htc ginger upgrade):

- RUU recognizes the phone and starts flashing, but ends up with fails on partition updates

- i extracted the img.zip of both RUUs and tried to flash via fastboot, which also ends up with "remote 51:partition updated fail" (screenshot below)



Edited by Saintscar

Share this post

Link to post
Share on other sites

I have the same problem and reports the Saintscar toncata I do?

Sorry my English because I am Brazilian and I do not speak English.

Share this post

Link to post
Share on other sites

bravo pvt1 ship s-on



touch panel-synt0101


aug 10 2010.17:52:18

My desire is so, what to do?

Share this post

Link to post
Share on other sites

HTC is becoming more and more popular nowadays in young generation. It has launched many smart phones at a many range to compete with Nokia and Samsung. It has a valuable reputation in the market. It is not like that you don't have to worry. It's all phones are better.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.