Jump to content

Problem with sim card

Recommended Posts

Hi all

I write to tell you a problem my friend have with our Acer liquid metal.

His phone doesn't recognized any sim card ! The problem appeared sometimes with stock rom but now i flashed for him the performance rom the problem seems to be permanent and we can't find a solution... i tried to mount several sim card on his phone but the phone tells there's no sim and only emergency calls are possible. I tried to re-flash the rom but nothing changed! So i think is an hardware problem! Is there something i could do before send it to Acer?

Edited by Mesme

Share this post

Link to post
Share on other sites

if changin the software won't work with any sd it probably mean his card reader inside the phone is broken...it's an hardware problem in my opinion, he should refer to the assistance

Share this post

Link to post
Share on other sites

ok i' m trying to build the original firmware but i have some problems...

after a while i could start the phone in sd download mode and i start the acer download tool but the procedure stopped telling me "sd image download procedure... failed!MD5_1_MISSMATCH, Are you a hacker ??

what i can do now ?!?

edit: after many attempts we could re-install the original firmware. we' ll sent it to acer assistance hoping in good news !

thanks everyone !!! :)

Edited by Mesme

Share this post

Link to post
Share on other sites

I have the same problem. Is the phone fixed now? How do I get it repaired?

Try inserting a piece of paper above the SIM Card

Share this post

Link to post
Share on other sites


I have a similar problem.

I changed my provider, so I got a new sim card.

The sim card work fine on a htc tattoo (older phone) but no on my acer liquid metal.

The phone was blocked on SFR network (but now I believe it's unlocked with the latest update), but that not the problem since my sim card is SFR too! (french network).

I tried another SFR sim, and same problem, it don't work on the acer liquid metal.

I tried two custom rom, lewa os (september version witch was working perfectly with my old sim) and the latest lewa os (february version) and I got a "no service" when I power the phone, and I don't get prompted to enter the sim code...

I tried another custom rom (holo-cm7) but same problem.

So I decided to flash the stock rom, and with the stock rom it work!

But I want a custom rom, so I tried to flash again a custom rom with full wipe, it doesn't work.

Then I flashed a custom without any wipe, with the hope that my sim card will be seen, but no luck again.

I tried that with the 3 custom rom I mentionned above (so it took my all the afternoon for nothing xD).

After I tried *#*#4636#*#* and changed all the network settings that I can (cdma, gsm, gsm prl, gsm cdma prl auto, and I don't remember the others lol).

But I never get promped to enter the sim code.

I'm really desespered, so I hope someone will know what this problem is related to, because now I became crazy!

Thanks for the help, and sorry for this long message, but I wanted to explain all the problem.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.