Jump to content
Sign in to follow this  

Help: my Optimus 2X is almost dead!

Recommended Posts


My O2X is almost dead. I can't power him up and I can't access the S/W Upgrade Mode (Vol down and plug in USB, with or without battery) to use Smartflash or KDZ Updater.

The only way I can get some life signs it's in the APX mode (Vol up, Vol down and plug in USB, no battery). However, when I try to use NVFlash to restore it with Paul O'Brien's release of stock firmware, I'm getting stucked at "waiting for bootloader to initialize".

This happens every time. I'm using the official USB cable and had tried all the three USB ports on my laptop (OS Win7 64 bit). I have tried the same procedure in a desktop at my job (OS Win7 32 bit) and the result it's the same.

I'm getting desperate. Does anyone have a shot for a solution?

Thanks, in advance.

Share this post

Link to post
Share on other sites

(for those who need more info to help me)

I have doubts of how the problem started. But, there were two main problems. I'm going to write it down in cronologycal order:

- In the afternoon, I did a backtoEXT3 (I was using CM 7.2 RC) and a flash of the Modaco ROM. Everything worked perfectly;

- In the evening, my O2X suffered a considerable fall, hitting hard on the floor. But, it continued to work;

- Little later on, I noticed that the phone became a little laggy. Then I decided to turn it off and than on again (since Modaco doesn't have reboot). In the power on process, the phone stood stucked for several minutes in the first "LG" screen. I decided to remove the battery and tried a new boot. That's when the phone went "half dead".

My purpose with this post it's to known if I can try something different or if I should go directy to the LG assistance.

I'd appreciate any help you guys can give me.

Share this post

Link to post
Share on other sites

Wow, seems youre in trouble, if your hardware are broken, then your phone aint living anymore. You could try to push in cmw. Searh at xda for trym hansens guide to root 2.3.4 stock. which also guides how to install cmw. I find it weird that you cant get into sw upgrade. Regarding usb ports. At your works desktop, did you use ports in front? If yes, try the one directly from the motherboard. I can only wish you good luck. By the way, if you now Ferrum Master you could ask him gently to fix it for you. He does that for a living.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.