Jump to content
Sign in to follow this  

Huawei u8800+ with only blue screen, pink screen and update failed ... please help

Recommended Posts

Please help ...

I know things like this are asked many many times, but I couldn't find a way to get it working :-(

I've got a Huawei u8800+ from merimobiles yesterday. The first time I tried to get into recovery mode the phone was going for a firmware update and got stuck at step 1/2 "update failed", so I had to pull out the battery. So from ths point on, everytime I boot my phone (without an sd card) it keeps on updating (and failing). So I tried to get the pink screen and connected the phone to my pc. I then accidentally formatted the image dir on the phone instead of the sd card eek.gif

Here are the problems I'm facing

1. Without an sd card the phone always tries to update.

2. With a sd card and a dload folder I get a blue screen (normal boot, boot with volume +)

3. With a sd card and volume + and - I get the pink screen. So I can still access the phone ... but I have no idea what to do next.

It looks like somehow it doesn't matter what's on the sd card ... it just won't update what's on it (tried several sd cards .... all FAT 32 and a dload with an UPDATE.app in it)

When you put a dload folder with an UPDATE.app on your sd card and you press the power on with volume + and - , you shouldn't see a pink screen but the update should start automatically?

I've already created a image dir with recovery.img boot.img etc ... but without any luck ...

So...is it still possible to flash any firmware?And ... does anybody know which kind of firmware version comes with a Huawei u8800+ from Mermobiles (I haven't heard from them yet).

If someone would be so kind to post the image dir somewhere that would be highly appreciated

Many many thanks in advance


Share this post

Link to post
Share on other sites

I had almost the same problem. I figured out that theres a difference if you try to update with/without battery.

try to download some factory default rom - put it on your SD card "dload" - pull out battery - connect your device to computer and hold down volume down button - this should do the trick


Share this post

Link to post
Share on other sites

I had a very similar problem. I believe it was because I tried to format the sd card to NTFS xD silly me...

I think that what I did was:

1. put CWM recovery in that image directory, but I had previously rooted my phone so I don't know if this will work for you (i'm a hopeless noob)

2. then I think I managed to boot into CWM recovery but if it doesn't work for you, disregard the following :/

3. do all the wipes and flash a stock/custom ROM from the sd card like usual (by usual I mean, like it says on every custom ROM thread)

worked fine afterwards, hope yours will too ;)

EDIT: also, I only posted this for possible future reference for noobs like me that might come along

Edited by antoniolordelo

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.