Jump to content
Sign in to follow this  


Recommended Posts

I have a ZTE Blade Gen 1 with no android installed and clockwork mod recovery I can't flash ROMs and downgrading Clockwork Mod has not worked.

Here is the story:

I was trying to install Cold Fusion's ICS ROM but it didn't work so I installed CM7 and that worked but I did not have the G-Apps installed so I had to manually had to install Clockwork Mod Recovery. It worked but it will not install new ROMs as it will just sit at the boot screen but with a weird android logo (see attached photo). I tried installing/flashing an old Clockwork .img using the power button, the menu button and the volume up button but it just stayed on the same version. Have I bricked my phone or is it just being awkward.

I have enough money to but a new better phone (Under £180) if you know of any good ones please tell me.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.