Jump to content
PaulOBrien

XMOD: Region / Device / Root patched Google Wallet

Recommended Posts

Tried running the fix at the top of this page but get the following :-

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd C:\Program Files (x86)\Android\android-sdk\platform-tools

C:\Program Files (x86)\Android\android-sdk\platform-tools>adb devices

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

List of devices attached

4df101d957514f9f device

C:\Program Files (x86)\Android\android-sdk\platform-tools>./adb shell am broadca

st -a android.intent.action.MASTER_CLEAR_NOTIFICATION

'.' is not recognized as an internal or external command,

operable program or batch file.

C:\Program Files (x86)\Android\android-sdk\platform-tools>

Anyone explain what I'm doing wrong.

Remove the "./" from the beginning of the command if you're running it in Windows.

Share this post


Link to post
Share on other sites

Remove the "./" from the beginning of the command if you're running it in Windows.

Remove the "./" from the beginning of the command if you're running it in Windows.

Thanks for the quick reply, ran the fix but unfortunately still getting the Activating account message.

Share this post


Link to post
Share on other sites

Fix for stuck on "Activating Account" problem:

Reset Google Wallet through the settings page (this might take a minute or two).

Connect your phone to your computer and issue the following command through ADB:

./adb shell am broadcast -a android.intent.action.MASTER_CLEAR_NOTIFICATION[/CODE]

[/background][/font][/color]

[font=Roboto, helvetica, arial, sans-serif][color=#282828]That's it - this completely clears the secure element in the phone, which frankly is something that the app should do anyway when it resets itself. [/color][/font]

[color=#282828][font=Roboto, helvetica, arial, sans-serif][Note - you can't do this to activated numerous Google accounts to get multiple free $10 credits, so not worth the effort of potentially knackering the secure element in your phone. The free $10 is tied to the secure element ID, so this is why if you buy a second hand phone you might not always get the $10 credit.][/font][/color]

This has worked for me, i am now able to get past activating/initalizing and i am actually in the app! Now im stuck at adding card :)

Share this post


Link to post
Share on other sites

I too am stuck at Adding Card.Tried so many times and it always fails.

One thought , I'm not sure if I read that it sets up a vpn to do the card part, and my provider (virgin media) blocks vpn. ( mobile and wifi)

Could this be it ?

Any other reasons why it would fail?

Share this post


Link to post
Share on other sites

Looks like Google Wallet on the S3 is locked down to certain carriers according to Googles twitter post just now

http://twitpic.com/a35rh4

Share this post


Link to post
Share on other sites

This has worked for me, i am now able to get past activating/initalizing and i am actually in the app! Now im stuck at adding card :)

for those of you that got this to work .. what carrier and phone.. i tried on AT&T i747 (gs iii) and even after running the command still hangs at activating account..

thanks

Share this post


Link to post
Share on other sites

for those of you that got this to work .. what carrier and phone.. i tried on AT&T i747 (gs iii) and even after running the command still hangs at activating account..

thanks

Successfully added the last version to an HTC One X, complete with adding the prepaid card and my citi card. Took a few tries on the citi. Im on ATT, but is an international Tegra phone.

Share this post


Link to post
Share on other sites

Hey Guys,

I'm using Paul's latest modded Wallet, which seems to be working properly as far as I can tell. Opened fine, added pre paid card fine, but is failing at adding my actual Citi card. Anybody have a clue as to what I could do, or is this expected? I'm on the HTC Evo 4G LTE on Sprint, which has unfortunately been blocked. I hope to get this resolved soon!

Thanks in advance, and of course, thanks Paul!

Share this post


Link to post
Share on other sites

Successfully added the last version to an HTC One X, complete with adding the prepaid card and my citi card. Took a few tries on the citi. Im on ATT, but is an international Tegra phone.

Well looks like i have to try adding my card a few times. lol i just read your post, which should answer my question.

Share this post


Link to post
Share on other sites
Hey Guys,

I'm using Paul's latest modded Wallet, which seems to be working properly as far as I can tell. Opened fine, added pre paid card fine, but is failing at adding my actual Citi card. Anybody have a clue as to what I could do, or is this expected? I'm on the HTC Evo 4G LTE on Sprint, which has unfortunately been blocked. I hope to get this resolved soon!

Thanks in advance, and of course, thanks Paul!

Actually, it's been a known issue for the Sprint phones. That's what Citi told me when I called them over the issue. They have a direct line for issues with Wallet, try giving them a call?

Share this post


Link to post
Share on other sites

Actually, it's been a known issue for the Sprint phones. That's what Citi told me when I called them over the issue. They have a direct line for issues with Wallet, try giving them a call?

Yea, Sprint has this app blocked, rumored to be due to the fact that they're making there own NFC payment app. I ended up calling Citi, and briefly explained it was added and working, got blocked, then there was an "update" and everything work's except my Citi card. She said It's been linked to my account, but if I did reset wallet, (which I did) that they'd have to remove my wallet account and card connection, and re-pair them around/after 24 hours. Hoping it works out. Going on a mini get away next week, and this would be cool to show off.

Share this post


Link to post
Share on other sites

Hey there guys,

So i wiped my old galaxy nexus before sending it back, Forgot to wipe google wallet before wiping the phone.

Installed old google wallet, got stuck on initializing, When i went to Settings > more (to see if nfc was on) it crashed settings while old wallet was installed.

So i uninstalled and found this one, Rooted my phone no problem, Pushed this to System/app and gave it all the permissions i could.

Now it gets to activation, And hangs on "activating account" after i hit agree to the terms. TRIED The ADB clear notifications, it completes "Broadcast completed: Result=0"

After clearing notifications it hangs all over again at "Activating Acccount"

GAR! I was getting used to using wallet EVERYWHERE! And now they taketh it away! GAR!

Any help would be greatly appreciated!

Share this post


Link to post
Share on other sites

Will this one works with stock ICS htc rooted phone , which needs corresponding .odex file ? Because when i try to copy to system/app and reboot GW file is not there and no app in drawer set correct permission

rw-r--r-

Share this post


Link to post
Share on other sites

I have moved the app into the correct place with the correct permissions but now I am stuck. I have tried about 5 times now to add the Google Prepaid card but I just can't. I have also used wifi but that doesn't work either. I am on an Orange UK HTC One X rooted on stock rom.

Share this post


Link to post
Share on other sites

OK My bad I think, I dont' remember pressing Freeze in Titanium, but there was a Defrost button. That worked. Though for ages I was getting permission denied to /data/system/packages.xml :S anywy I have my prepaid back, thanks Paul for the Wallet :)

Using Modaco JB ROM too, it was frozen on mine too, thanks to your post I just got mine back!

cheers!

Share this post


Link to post
Share on other sites

Will this one works with stock ICS htc rooted phone , which needs corresponding .odex file ? Because when i try to copy to system/app and reboot GW file is not there and no app in drawer set correct permission

rw-r--r-

Delete the .odex file.

P

Share this post


Link to post
Share on other sites

Delete the .odex file.

P

You mean delete all the corresponding .odex file in system/app folder for all the apps ?

Coz i think it gets rebuild after reboot.

Coz issue is just with GW, coz after reboot No GW.apk in system/app folder and no GW in app Drawer, so is that the issue related to stock rom needs .odex file.

Edited by chris1104

Share this post


Link to post
Share on other sites

You mean delete all the corresponding .odex file in system/app folder for all the apps ?

Coz i think it gets rebuild after reboot.

Coz issue is just with GW, coz after reboot No GW.apk in system/app folder and no GW in app Drawer, so is that the issue related to stock rom needs .odex file.

No, just for Wallet, and no, it does not. Your probably mistaken with the caches. You can run deodexed filles on odex systems, as long as the specific deodexed files doesn't have an additional .odex file...

Share this post


Link to post
Share on other sites

No, just for Wallet, and no, it does not. Your probably mistaken with the caches. You can run deodexed filles on odex systems, as long as the specific deodexed files doesn't have an additional .odex file...

Thanks for the reply rydah805, manage to install by flashing custom rom, and adding to system/app but stuck on adding google prepaid card. :( . Have we found any fix for this yet ?

Edited by chris1104

Share this post


Link to post
Share on other sites

Still not working for me on a UK S3 on stock firmware (ALF6). Tried the android.intent.action.MASTER_CLEAR_NOTIFICATION but it's still stuck on 'Activating account'.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.