Jump to content
Sign in to follow this  

Wi-Fi continuously scanning, turning off and on, scanning again, turning off and on loop

Recommended Posts

Hi guys,

Last Wednesday evening I received my Samsung Galaxy S III white :) and turned it on for the first time. Because I just received my brand new (at that time still inactivated) micro SIM, I had to configure the first time setup wizard using Wi-Fi. But my excitement turned soon into frustration; I was unable to get a stable Wi-Fi connection.

After enabling Wi-Fi, the my Samsung Galaxy S III starts to scan, pause for a few seconds, starts scanning again then automatically turns off and immediately on again then scanning again, and so on in a continuous loop.

I was successful in entering a WPA2 passkey for my Wi-Fi access point and the Samsung Galaxy S III connects, receives an IP-address and for a few brief seconds, there is a Wi-Fi Internet connection. But then it starts scanning again then automatically turns off and immediately on again, connects automatically to my access point, starts scanning, etc, etc.

Things tried without success:

-Connecting to both my wireless access points at home and a third one at work (Netgear WNDR3700v2, Thomson - -Speedtouch WL-780 and KPN Experia Box).

-Setting wireless access point to 802.11G only

-Disabling security the wireless access point

-Experimented with wireless access point security options WEP/WPA-PSK [TKIP]/ WPA2-PSK [AES]/ WPA-PSK [TKIP] + WPA2-PSK [AES]

-Forgetting the wireless network, turn device off, remove battery 30 seconds, turn on and retry connecting to a wireless network

-Reset the device without backing up data, account or apps

-Tried a micro-SIM from a colleague who’s using a different Telco provider

My colleagues use the latest Android 4 on their Galaxy Note and Galaxy S II and have no issues whatsoever with wireless connections.

There are some accounts of other Android user who have upgraded to the latest 4.0.x version and have similar issues. The suggestion to solve it is to use “WiFix” from XDA developers to fix some regional issue, but that requires you to root the device. I find it hard to believe to have to go that route to fix this (hugely frustrating) Wi-Fi issue. Also, the Samsung Galaxy S III is a brand new latest and greatest 600 euro top-end phone from Samsung, only a few days old. To root the device, if even possible and voiding warranty is too much right now.

I’ve spoken to Samsung service representative and she said not being aware of any issues and not knowing much about this brand new phone. Just to bring it to a Samsung service point, or return the device for repair which can take two to four weeks :( And if there is a regional Wi-Fi bug in Android 4.0.4 as XDA developers seem to suggest, Samsung won’t be able to repair it anyway and I’ll just have to wait for an update, someday…

So before I return my brand new, 2 day old Samsung Galaxy S III, I want to explore each and every option in an attempt to fix the Wi-Fi problem, even when I suspect I grasping at straws here…

Any suggestion is welcome…

Share this post

Link to post
Share on other sites

Sorry can't offer much more than that I haven't experienced any such similar problem with mine, i have synced it to 3 different modems now all have worked fine. Sorry to hear your having issues.

Share this post

Link to post
Share on other sites

If it really is a regional problem then change the channel used by your access point to channel 6 whichis legal in all regions. I don't think it will be though as you've tried several different access points, it is unlikely that all three will be using the upper channels which are illegal in some areas. It sounds more like a software or hardware bug affecting the WiFi reception, if there are no reports of major faults from lots of different users I'd guess at a hardware fault on your phone.

Share this post

Link to post
Share on other sites

Today I received a brand new Samsung Galaxy S III from the shop :)

During the first-time enrollment there was no issue connecting to a wireless access point at home. It's also possible to connect the other wireless access point in my home without problems.

The phone is still continuously scanning Wi-Fi networks every couple of seconds, but no more automatically turning off/on. Speedtest.net is showing > 10Mbps speeds over Wifi and HD YouTube video's seem to stream nicely.

Thanks for your suggestions and the thanks to the shop (Typhone in .nl) for the short turnaround time...

  • Upvote 1

Share this post

Link to post
Share on other sites

I just got my i9300 a few days ago, but I had this problem with my Wifi always scanning and switching back to data all the time them I found this "solution" by looking around and try differents things.

Finally I saw something (can't remember where) about WIFI Power save mode so I found the dial code to acces it and dissabling it solve all my problems, but it has to be done after every reboot, so if someone nows how to make it stick that'll be great.

Here' what I do in order to "temporarily" dissable it after each reboot just dial *#0011# that will bring you to ServiceMode page, then hit menu and you'll be in the Wifi information page where you can see the Wifi Power Save Mode option that you can enable oe disable. Disable it and hit back to quit and your wifi should be back on and stay.

Hope this can help someone.

Sorry for my english.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.