Jump to content
KonstaT

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

Recommended Posts

snapback.pngrikfru, on 01 September 2012 - 08:36 PM, said:

just reporting audio streaming is not working on tuneradio says its the internal decoder error.

KonstaT: Did this work in earlier builds? I've messing with codecs lately trying different things with video.

I only tested on that one sorry

do you mean tunein radio? Works OK for me. Perhaps its the stream your using. Have you tried unticking the don't use weak WiFi signal in settings? Hope this of some help :)

Share this post


Link to post
Share on other sites
Has anyone else noticed that the notification sound isn't played? Even in sound settings I can't hear any notification sound.
All seems to be working on my blade. Can hear them in settings and also when a notification is delivered.

Share this post


Link to post
Share on other sites

From what i know about percieved "smoothness" it's entirely subjective, some will tell you that it's smooth as butter (i'm one of them) and others will say that it's less smooth. When it's more mature there will probably be no doubt about it but at this point it seems to be a bit of a hit and miss.

You're going to have to try it for yourself, either use my script and make a loop install of it or just backup your current rom, wipe and install it, if you don't like it you can just restore. It's not like you risk losing anything but maybe half an hour of your time.

thanks for answering! :) i think i'll give it a try then.

Share this post


Link to post
Share on other sites

do you mean tunein radio? Works OK for me. Perhaps its the stream your using. Have you tried unticking the don't use weak WiFi signal in settings? Hope this of some help :)

after reading this I unistall the app and re install and its working , thank you

And sorry to waste your time KonstaT

Share this post


Link to post
Share on other sites

I confess I am a bit of a newbie here, I am glad I got so far. Could anyone tell me the commands needed to revert that change? I know I could do a git checkout in that part of the android source tree and manually remove those 9 characters from that file, but that's cheating.

I thought that Konstat's github stuff was all pulled in after I created the .repo/local_manifest.xml file. Am I right? Then I had to apply the patches. No one in this thread has ever said how, nor in the cm9 compiling thread, like it was supposed to be obvious. Took me a short while so I'll say what I did.

i actually manually edited the revert, i'm not a big fan of the mess git reverts make of your tree, unless you make a branch it can be really awkward to get back to the correct HEAD, as you say its just removing the -0 .arsc

i could write a "compiling cm10" thread, but konstat has explained most of it in the first post, and other than the 2 framework patches, these patches are not actually required, they're just to make the build small enough to fit in a 160mb /system

yes konstat's patches are in his github, but they're not applied to what you download, as they're are outside the device/vendor/kernel trees - part of the main cm10 code, not the zte blade specific bits. i personally prefer this method to the coldfusionx method of maintaining a bunch of other trees, it keeps it more of a pure cm10 and is easier.

here's my notes for how i apply my patches (including the two from konstat) and what directory you must apply them from - assuming you have a cm10 directory and all the patches in your $HOME:

# vendor patch (no bootanimation, no rommanager, no wallpapers, old audio, compress resources):

cd ~/cm10/vendor/cm/

git apply ~/vendor.patch


# device patch (less fonts):

cd ~/cm10/device/zte/blade/

git apply ~/device.patch


# framework native patch (konstat):

cd ~/cm10/frameworks/native/

git apply ~/fw_native.patch


# framework av patch (konstat):

cd ~/cm10/frameworks/av/

git apply ~/fw_av.patch


# framework base patch (old audio):

cd ~/cm10/frameworks/base/

git apply ~/fw_base.patch


# build patch (no tts, no wallpapers, no videoeditor):

cd ~/cm10/build/

git apply ~/build.patch


# trebuchet patch (less wallpapers):

cd ~/cm10/packages/apps/Trebuchet/

git apply ~/trebuchet.patch

  • Upvote 1

Share this post


Link to post
Share on other sites

I tested one of previous versions of supercharger script. Didn't saw nothing good of it. Many words from developers, a lot of headache for users and nohting with good results

Share this post


Link to post
Share on other sites

I tested one of previous versions of supercharger script. Didn't saw nothing good of it. Many words from developers, a lot of headache for users and nohting with good results

they are generally bullshit, usually just a few sysctl settings that are already set in cyanogenmod

Share this post


Link to post
Share on other sites

Did anyone try this on the V880? Does it work well? Still stuck on GB as ICS was a pain on this phone :(

I have tested it.

But it is very much unstable as ics just because of lesser ram however swap can help a bit.

you can go ahead and give it a try..I must say you should taste jb once. :)

  • Upvote 1

Share this post


Link to post
Share on other sites

Hey ppl i don't know if i missed something, guess not but when i decided to give a try on jelly bean (i tested first version) today something went wrong.

Phone does not detect the sim card, at least it don't ask for the pin.

Did i missed something?

thanks.

Solved: Installed CM9-KonstaKang Gen3

thanks anyway

Edited by guelas

Share this post


Link to post
Share on other sites

Ok status report on my compiling efforts.

My very first build installs and runs ok, didn't try to do very much with it. Then I applied the pdroid source patches and compiled again. That one works fine too.

Now I have a working Konstat cm10 with pdroid running fine. I am chuffed.

The pdroid autopatcher will be updated soon, though if anyone is in a hurry I could send a flashable zip of the necessary files.

Share this post


Link to post
Share on other sites

Hi all,

I still have the MMS problem, can't download it! :(

No one else have the same problem with MMS? Don't know what to do more.

Thanks for you help!

Try to

1- activate airplane mode

2- desactivate airplane mode

3- reboot

this works for me :)

Share this post


Link to post
Share on other sites

Try to

1- activate airplane mode

2- desactivate airplane mode

3- reboot

this works for me :)

Thanks for your support, but sill no luck. But since ICS i couldn't receive / send MMS.

Share this post


Link to post
Share on other sites

Has anyone else noticed that the notification sound isn't played? Even in sound settings I can't hear any notification sound.

i have this problem too

i've checked sdcard and the notifications, media folders were empty. i decided to copy the files there, but it still have no sound and now i see duplicate names in sound notification settings.

Share this post


Link to post
Share on other sites

Any idea, how close to working are those still missing USB- and WiFi-tethering and camcording in this "generation" of this ROM-"family"?

Or can those achieved with some extra apps?

Would be nice to use USB-tethering while charging mobs battery.

Share this post


Link to post
Share on other sites
Guest

Any idea, how close to working are those still missing USB- and WiFi-tethering and camcording in this "generation" of this ROM-"family"?

Or can those achieved with some extra apps?

Would be nice to use USB-tethering while charging mobs battery.

Would also be nice (of you) to read at least the first and last two pages of the topic before posting ;)

External apps can be used for this, and it looks like USB tethering was locked (or at least not released) by Google in JB (athough this was only an assumption from KonstaT)

Edited by Guest

Share this post


Link to post
Share on other sites

I've got a bit of a weird problem! Whenever I go to Google Play, I can browse the store fine, but as soon as I click "install", the 3G connection goes down - sometimes it takes 5 minutes or so to come back, and even then the status bar remains grey (i.e. no connection to google) - a reboot solves.

Hi all,

I still have the MMS problem, can't download it! :(

No one else have the same problem with MMS? Don't know what to do more.

Thanks for you help!

I had the same issue - found that my APNs for mobile data and mms were virtually the same, so I've merged them into one (i.e. added the MMSC, MMS proxy MMS port,APN type, etc to the main 3g apn, and deleted the mms apn), now it works fine. Also note that some providers, you have to send an MMS in order to receive them, apparently! That's what my provider told me (Virgin UK).

Share this post


Link to post
Share on other sites

Just a quick question for the mo. The size of the output. Decompressing the output zip gives something much bigger than KonstaT's build, even after trimming away the tts folder and most of the multimedia. Looking a bit closer reveals that the apps folder is nearly twice the size of his, and is full of surprises, the biggest being Trebuchet.apk. His weighs in at just 594K and mine weighs in at 12M. Wow.

Yeah, I've done quite a bit of trimming. I haven't bothered to upload the trimming patches for CM10 to my github, but similar patches to my CM9 build are available (same place - ics branch).

Install pngcrush or optipng to your build machine and revert the 'compress .arsc' commit - those two have the most effect on apk size. I've removed wallpapers (yeah, almost worth 12mb :P) from Trebuchet, that explains it.

I confess I am a bit of a newbie here, I am glad I got so far. Could anyone tell me the commands needed to revert that change? I know I could do a git checkout in that part of the android source tree and manually remove those 9 characters from that file, but that's cheating.

You can revert commits with 'git revert commit-sha'. For example for the .arsc compression commit it would be:


cd cm10-workdir/vendor/cm
git revert bb56531b18d89296e8328394f3126e4602b2714e
[/CODE] I personally like to keep commits like that on a separate branch, where they are applied on top upstream head after repo sync. E.g.
[CODE]
cd cm10-workdir
repo start branchname ./vendor/cm

and then apply patches or reverts (as above) or commit whatever changes to this branch.

i personally prefer this method to the coldfusionx method of maintaining a bunch of other trees, it keeps it more of a pure cm10 and is easier.

Yeah, the code might be more readable if it was applied to a tree and uploaded to github vs. being in patch form. On the negative side, it would require constant attention from the maintainer of that github and merging/pushing branches. Otherwise parts of your build could be days/weeks old compared to the actual cm10 upstream. It would never work for me as I like to cherry-pick work in progress gerrit patches etc. It's better to keep stuff like that on top of upstream head instead of buried somewhere between bunch of other commits.

Like already said, I'm just trying to maintain the device specific parts (and couple of patches that are needed) so that people can build cm10 for Blade by themselves. Objective is not that everyone will compile the exact same build as I'm posting here (it's not that 'pure' cm10 - it's trimmed with some extras ;)).

Ok status report on my compiling efforts.

My very first build installs and runs ok, didn't try to do very much with it. Then I applied the pdroid source patches and compiled again. That one works fine too.

Now I have a working Konstat cm10 with pdroid running fine. I am chuffed.

Congrats and welcome to the world of self-compiling ROMs. :)

External apps can be used for this, and it looks like USB tethering was locked (or at least not released) by Google in JB (athough this was only an assumption from KonstaT)

Well, not so much as locked but they've probably changed how network interface routines are handled.

  • Upvote 1

Share this post


Link to post
Share on other sites

Well, not so much as locked but they've probably changed how network interface routines are handled.

Usb tethering on burstlam's jb build! So maybe not?

Edited by emajar

Share this post


Link to post
Share on other sites

Usb tethering on burstlam's jb build! So maybe not?

What build are you talking about? Native usb tethering is listed as non working in burstlam's thread. It works with third party apps here too.

Share this post


Link to post
Share on other sites

CD

What build are you talking about? Native usb tethering is listed as non working in burstlam's thread. It works with third party apps here too.

Check 6.8.0 ics thread someone gave a link to Chinese forum. It's 26082012 build jb. only English and Chinese language. But very stable too.

https://www.dropbox.com/s/2dawqvlc7vwum1a/cm-10-20120826-blade-Burst-JB-KANG.zip

Sorry meant sdcard tethering..

Edited by emajar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.