Jump to content
KonstaT

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

Recommended Posts

Hello,

Firstly I'd like to say thanks for all those working to develop nice ROMs the blade.

I have attempted to migrate from ICS (burstlam ROM 6.8) to JB (Konsta 20121017 ROM).

This post is to report the bugs I noted.

Device info: Blade with System partition around 175MB

Flashed with CWM. Everything went fine.

Main issue:

Alarm does not sound. when selecting a ringtone, no sound comes out of the phone. Tried reboot. Tried all kinds of sound settings. Reflashed from 20121015 ROM to 20121017 ROM.

At first, this also happened for SMS notification sounds but a reboot did fix it. I have not been able to find a fix for this alarm sound bug. I almost missed waking up the first morning ;) so I flashed back since.

One other comment (rather a 'nice to have'): on the lockscreen 'targets' to choose from, I could not find how to pick 'sound toggle' to switch between different sound modes. Did I miss something ?

thanks again. I'll stay tuned and will try future updates.

Regards,

Xavier

Alarm is working fine since the second build :-) Did you wiped the dalvik cache before/after installing this rom? You should do a full wipe after migrating to JB from ICS.

You can toggle sound modes easily trough the power widget of nitification bar. You dont have to unlock your screen to use it.

Share this post


Link to post
Share on other sites

XeSOr - Thanks for quick & helpful reply.

So should I just install this over current 'hack' version ? Or uninstall then install.......

If you're able to, you can simple install it over the modified version. But uninstalling and then install it will work too. You only have to setup everything again in the s2e settings before you restart your phone!

Main issue:

Alarm does not sound. when selecting a ringtone, no sound comes out of the phone. Tried reboot. Tried all kinds of sound settings. Reflashed from 20121015 ROM to 20121017 ROM.

Alarm is working fine since the second build :-) Did you wiped the dalvik cache before/after installing this rom? You should do a full wipe after migrating to JB from ICS.

You can toggle sound modes easily trough the power widget of nitification bar. You dont have to unlock your screen to use it.

My girlfriend had the same problem this morning and i think i didn't made any mistake. At first i thought she did something wrong but now it seems like a problem. I will investigate it after getting home from work.

Edited by XeS0r

Share this post


Link to post
Share on other sites

If you're able to, you can simple install it over the modified version. But uninstalling and then install it will work too. You only have to setup everything again in the s2e settings before you restart your phone!

My girlfriend had the same problem this morning and i think i didn't made any mistake. At first i thought she did something wrong but now it seems like a problem. I will investigate it after getting home from work.

I had the same issue. Playing with the profiles did not work at first. Finally got my sound back by using the profile setting from long pressing the power button and changing silent to normal (while the rest of the Phone settings showed me already a normal profile. MP3 worked Always ...Thanks for the ROM !

Edited by wimmme

Share this post


Link to post
Share on other sites

Not working:

  • USB-tethering (use an external app)

Will this be supported natively (it is because nobody adapted it for JB or native support is removed since ICS ?) ?

("usb" or "tethering" search in this topic give me 0 results ..)

I'm currently running ICS (ColdFusionX 9-20120531) which is almost stable, what about JB/this version ? Smooth/same battery life ? Any pros/cons ?

Does it still require to "disconnect" from data (connecting to wifi) to fetch mms ?

Share this post


Link to post
Share on other sites

Hello

A happy JB user here, with a "feature" request, if possible.

I have spotted that every time I get a call with wifi turned on, the same time the phone wakes to ring, it does try to connect to my AP, too. So, while talking on the phone, it communicates with the AP and the cellular network at the same time. I think that's a battery waste and nonsense 2.4GHz signals for my brain, added to the cellular network's radio communication.

Could it be possible that wifi communications are turned off automatically during phone calls, with a setting on the menu for those who don't bother by that, so that everybody could be happy?

Thanks

Share this post


Link to post
Share on other sites

Hello again and thanks for the quick reply.

I did do a full wipe (data/factory reset, dalvik cache etc...)

If others confirm that switching modes back & forth from power menu has solved the alarm issue, I'll try again.

I'm just unconfortable not being sure I can rely on the alarm ;)

regarding the toggle switch, I know this can be done through power menu or notification bar. It's just that I liked the lockscreen swipe but again, it's just a nice to have.

Thanks !

Share this post


Link to post
Share on other sites

The Picture Gallery (Gallery2.apk) still does not sync with Google Picasa. Is there any reason why you don't include different version that can sync with your Google account?

Picasa sync doesn´t work since Google merged Gallery & Camera app in one app for JB -> Gallery2.apk.

I read from some working hacks but with issues - sharing does not work and so on...

I install old googlegallery.apk and it works for me - but i have now two galleries ;)

Old googlegallery.apk : http://www.sendspace.com/file/zdkkyw

Edited by Nummer5
  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Konstant,

Any possibility to support amr-audio in the future ?

CallRecorder by Skvalex works fine in CM10, but only vaw audio can be used. :(

Edited by 陰莖:)

Share this post


Link to post
Share on other sites

hi there

it is possible in next rom working camcorder???

It is all on KonstaT, when he get camcorder working he will add it, there's no specific date of its working it will be fixed with time but from now if you want camcorder then use CM9 or CM7.

Edited by HDuser

Share this post


Link to post
Share on other sites

Hi Konstant,

Any possibility to support amr-audio in the future ?

CallRecorder by Skvalex works fine in CM10, but only vaw audio can be used. :(

AMR-audio, 3gp and some others support would be very nice. :wub:

Edited by semenfun82

Share this post


Link to post
Share on other sites

Kostat and i did the same hack to get the previous version of s2e working on cm10. But this is not modified, it's the version from the play market and don't need any modifications for cm10.

You can simply flash the file or extract the s2e.apk from the zip and install it directly. If you install the s2e.apk without flashing, it will reside on the "/data/app" folder otherwise it will be in "/system/app" and use space of your system partition. If you're not sure if you have enough free space you should extract the s2e.apk and install it(or download it from the market).

I've set up my girlfriends phone yesterday and it worked like a charm. If you have any trouble setting up s2e you can write me an pm.

Changelog:

3.0.2

- Better compatibility with cm7

3.0.1

- Fix "script not instaled" on cm7

3.0.0

- Support CM10

- View and share boot log from application

- Performance and stability improvements

- Autodetect ext partition

- Light theme

- Added Indonesian translation

Added simple2ext-v8-jb.zip which includes v3.0.2 of s2e.

Hi,

I just tried this new version and after select to move applications and reboot, S2E still says: "Moving from /data to /sd-ext Reboot is required!

The /data/app and /sd-ext/app has the same files. No matter how many times I reboot it keeps saying the same.

My phone is a ZTE V880 (Brazilian, more like a chinese blade I think)

Whats is wrong?

Thanks in advance!

----------------------

According to s2e log the FS is in use, so I think thats why the process is not completed. Anyway, this post will continue on new topic created by XeS0r.

Edited by oscarafv

Share this post


Link to post
Share on other sites

I just installed XeS0r's simple2ext-v8-jb.zip and now the camera says "SD card is full". Lotsa space available on all partitions now.

I rebooted to recovery and tried Fix Permissions to no avail. Anyone else?

Share this post


Link to post
Share on other sites

I'd like to say thanks for all those working to develop this nice ROM. Even using Brazilian (or China Blade) I think it works very well.

KonstaT, I tested bluetooth (as you asked before). I started using v10.10 and it worked just fine, just take a long time to activate. After upgrading to v17.10 it sometimes activate after turning Flight Mode off/on but still takes a long time.

Thank in advance!

Edited by oscarafv

Share this post


Link to post
Share on other sites

I just installed XeS0r's simple2ext-v8-jb.zip and now the camera says "SD card is full". Lotsa space available on all partitions now.

Just stay with KonstaT's version of S2E. It works fine. No need to change anything...

Share this post


Link to post
Share on other sites

Hello again and thanks for the quick reply.

I did do a full wipe (data/factory reset, dalvik cache etc...)

If others confirm that switching modes back & forth from power menu has solved the alarm issue, I'll try again.

I'm just unconfortable not being sure I can rely on the alarm ;)

regarding the toggle switch, I know this can be done through power menu or notification bar. It's just that I liked the lockscreen swipe but again, it's just a nice to have.

Thanks !

I can confirm that switching the sound modes enables alarm sounds again. But you should try it with an test alarm to be sure it will work!

Share this post


Link to post
Share on other sites

I cannot confirm any problems with s2e in the current version (3.0.2).

I've created a thread to solve problems related to s2e.

I hope KonstaT likes the idea of splitting such problems from this thread.

Best regards

Share this post


Link to post
Share on other sites

when we will have news about the camcoder?

You better ask Lalit about that. He's the one who 'promised' a fix when I had already given up. I haven't even included any Qualcomm OMX bits in a long time anymore.

Whether this CM10 ROM can be installed on 256MB RAM ZTE Blade model (Idea Blade)?

Sure you can install it, I have no idea how it will work though. :P I probably wouldn't recommend it though. Using zRam or swap might help with low memory issues.

I've just compiled my own cm10 with Konsta's "patches to 160 MB". The UI transitions seems a little bit slow, is it my imagination?

I've been using my CM9 build (ECoBlade) with dithering off for quite some time, and so I'm now used to "apparently" fast transitions. Is the project butter forcing too much frames per second on the transitions and our Blade's can't handle it, or the problem lies in other places?

...

Did you apply the two patches in the second post or just some trimming patches? Those make quite a difference in UI speed.

The Picture Gallery (Gallery2.apk) still does not sync with Google Picasa. Is there any reason why you don't include different version that can sync with your Google account?

Picasa sync needs Google's proprietary gallery app. In jellybean camera is wrapped into gallery app, so it can never be used. Search for GalleryGoogle.apk if you need it.

Hi, Is there any blank screen problems with Facebook and gmail app in this ROM

No.

Voice search in Google Now is not working right?

For about the millionth time, you need to use the separate voice search app that you'll find in your app drawer. It works just fine.

Will this be supported natively (it is because nobody adapted it for JB or native support is removed since ICS ?) ?

("usb" or "tethering" search in this topic give me 0 results ..)

Of course jellybean has native usb-tethering. It just doesn't work until someone fixes it. :P

Search function in this forum doesn't work anymore. It will return 0 results no matter what you're searching for.

Just stay with KonstaT's version of S2E. It works fine. No need to change anything...

It would be better to move to the latest version from the Play shop. Uninstall hacked S2E (can't be updated because I resigned it). Install S2E from market. Configure it (check boxes for apps and mount as ext4 in settings) and only after this reboot your phone. Worked without any issues for me but might be best to make nandroid backup before this just in case.

  • Upvote 2

Share this post


Link to post
Share on other sites

@konstaT. Some of us experience internet issue (on your CM9 too): signal icon stays gray, it even changes between E and H (2g/3g), but there is no internet connection. For me only reboot helps... Did you experienced that issue? is there a solution?

Share this post


Link to post
Share on other sites

@konstaT. Some of us experience internet issue (on your CM9 too): signal icon stays gray, it even changes between E and H (2g/3g), but there is no internet connection. For me only reboot helps... Did you experienced that issue? is there a solution?

I also have this problem.

Share this post


Link to post
Share on other sites

I also have this problem.

I had internet problems with my own compiled CM9, I think it's just the Blade or CM or CM+Blade's fault.

sometimes takes forever to switch 2g/3g, sometimes data can't be turn on or even off, only going to the settings and checking on and off national roaming helps..

gave up on that issue

Share this post


Link to post
Share on other sites

What about AMR-support ???

Android has native amr support and there's nothing wrong with it. I just recorded an amr clip in 3gp container and it records and playbacks just fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.