Jump to content

ClockworkMod Not Working on My SF II

Recommended Posts

So I bricked my phone and tried unbricking it myself, following these instructions with the help of a friend. We did everything, and now when I turn my phone on, the green man comes up, and LED light and camera light flashes (the latter didn't used to when I turned my phone on). Then the ClockworkMod Recovery (v3.0.1.4) thing comes up, which all sounds great - except when I scroll through the options and select any one of them, the ClockworkMod logo comes up and nothing happens. I've tried everything - rebooting, clearing data, backing up and restoring, I've tried all the options, and the ClockworkMod logo just comes up and nothing else happens no matter how long I leave it. (Incidentally, unlike some other people who have had this same problem, I know I'm pressing the right button to select an option.) If I press anything else, it just goes back to the options page. I tried installing another version of CWM and even tried CyanogenMod, but that completely failed ...

Can anyone tell me what I can do? I've been Googling endlessly, and I find others in the same position as me, but I can't use the same solutions as them for whatever reason. Or the download links in the posts are old and I can't use them. I'm not sure if I can take it to the shops to get fixed or not.

Compared to others here, I'm pretty much a noob when it comes to this kind of thing. I've unlocked phones before, but this is the first time I've bricked and unbricked it.

Help appreciated. Thank you!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.