Jump to content
Sign in to follow this  

Drivers (adb)

Recommended Posts

Having a problem with drivers ( i think)

When I connect the phone, I see USB debugging connected and USB connected and I am able to use USB storage,

But when I run the command,

adb devices
i cannot see my phone in the list, I am an app developer, and when i connect other phones, I see them listed there and am able to test my apps from eclipse directly. Any help? I installed this driver

Am I doing something wrong? Thx.


Problem solved

I read about someone with a similar problem.

I grabbed USBDeview from link below (scroll far down to find the download links)

Installed it, and looked for all instances of USB android drivers and uninstalled, giving particular beef to those with Samsung since my phone was appearing in Device manager as a Samsung Android phone.

Rebooted, installed the Intel drivers and connected my phone but got the same problem, still appearing as a Samsung, and ADB command and eclipse not yielding anything.

Opened task manager, located the adb.exe process, found out it was in my Windows folder. Deleted it.

I updated my Path settings to include Program files/android/android-sdk (just know i mean the path to my sdk)

run adb devices again, but same problem, still samsung in device mgr.

took some coffee.

opened Registry, searched for "Samsung android"

Deleted all entries that had it.

Reinstalled the intel drivers, rebooted computer.

Finished coffee.

Connected phone to pc, (made sure debugging option was enabled on phone)

Installed now in device manager as Android phone. (phew)

Opened eclipse

tried to push my app to the phone, opened the Run configurations lists to see available devices, but i didnt see my phone listed (more coffee?)

It looked like this.


I then noticed that wen i mouse over, the device list area, it would highlight it, and i selected it and could click ok. The app was pushed to my device. Interesting. Did a little dance, but still scratched my head over why my device name is missing.

as u can see in the image below, the device is highlighted but no names or any words there in the first slot. Well it works now.


Edited by Fixticks

Share this post

Link to post
Share on other sites

No one else with this problem? Windows 7 (ultimate)

i to am having this issue i am stumped as all Google searches bring me to the above link i've installed it all correctly i am just stumped :blush:

Share this post

Link to post
Share on other sites

Wow, that's odd. Have you looked at Paul's sticky on how to use adb with the San Diego?

Also, in device manager is the device listed a different phone. Samsung? I'm guessing it is?

USB Debugging definitely on?

Only things I can think of... :huh:

Share this post

Link to post
Share on other sites

You could try deleting all the android drivers from your machine(obviously keeping ones you need for any other devices) and reinstall the intel drivers, reboot and connect your device again. Seems very strange your OSD is seen as samsung, some kind of confusion going on in windows there.lol

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.