Jump to content
Phil Sempers

Bricked S2 after unlocking with GalaxyS_Unlock

Recommended Posts

Hi, I feel a bit of a fool for doing it but I tried unlocking my s2 gt-i9100 with an app off android market called GalaxyS_Unlock and it worked for 5 minutes and then crashed, rebooted and bootlooped. I tried reflashing stock rom with odin which completed fine but it still would not boot. I just got stuck on the first boot screen. I couldn't access recovery despite the correct procedure for trying to get into it (volume + & Home & Power) I could get into download mode but not into recovery. Now my battery has died I am unable to get into download mode either as it fails with "Battery too low, can't download!!!" So I am stuck with an expensive samsung shaped paperweight. Anyone got any ideas what I could do to rescue it? £20 to the person who fixes it. (By paypal, don't get paid till 17th though). Please help!

Share this post

Link to post
Share on other sites

few questions before we can help you:

1. was your phone rooted and busybox installed before you start GalaxyS_unlock?

2. which version of android did you have before your unlocking? was it GB or ICS?

3. which stock rom did you try to flash after unlocking failed?

4. even if you can't get into recovery/battery died, can you still charge your phone while it's off?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.