Jump to content
Sign in to follow this  

SU Binary Update

Recommended Posts

On booting my Vega, I get a message saying 'SU binary outdated'. When I click to update, it runs through several checks/ messages then stops at 'Copying su to /system... fail' and when I hit 'Try again' it runs through the same process again and sometimes stops at a different stage/ message, but either way it doesn't seem to update.

From searching this topic on a number of Android forums, it seems to be a common problem. I tried the suggested fixes like downloading the Superuser Update Fixer app from Google Play and also trying to install Busybox Installer, neither of which worked.

Is there anything else worth trying to update the su binary, or is my best bet to flash a new ROM?

On that note (and apologies for going slightly off topic), as I'm still using the R8 Custom ROM, I was thinking about updating to a more recent ROM in any case (probably VegaCream). Although I'm comfortable with the process of flashing a new ROM (using the NVFlash method), reading all of the Vegacream/ ROM posts on here with discussions about partition sizes, full wipes, ModdedStock ROM V1 and V2 etc. can get a little confusing.

Can I just flash VegaCream directly over the existing R8 Custom ROM, or do I need to flash one of the ModdedStock ROMs first? I think that it's probably the latter, which I believe creates the correct partition sizes for the new ROM, but it's always sensible to confirm this before I go ahead and do something that I may later regret!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.