Jump to content
KonstaT

[DEV][ROM][24.7.] CyanogenMod 10.1 (Android 4.2.2)

Recommended Posts

Short Question: what is the best I/O-Scheduler for this ROM? The Default which is BFQ?

Thx! Best Way to test this out?

I've always used "noop" and it works fine.

It wakes up quickly and deep sleeps quickly too. (or, at least I think so...)

How can one test this? Try them out and check the phone's reaction and battery drain.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hiho!

Short Question: what is the best I/O-Scheduler for this ROM? The Default which is BFQ?

Thx! Best Way to test this out?

Thx!

http://forum.xda-developers.com/showthread.php?t=1631894

Read the link first, but remember that touching to perfomance settings may make your phone unstable. I have never touched to I/O settings, so I dont know are those handy or not.

  • Upvote 1

Share this post


Link to post
Share on other sites

I have been using another rom but wanted to try this one. So I booted into ClockworkRecovery, did a factory reset, select install zip from sd-card, select this rom, and I get this error:

Installing: /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip

Finding update package...

Opening update package...

Installing update...

assert failed: getprop("ro.product.name") == "blade"

|| getprop("ro.build.product") == "blade"

E:Error in /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip

(Status 7)

Installation aborted.

What have I done wrong?

Share this post


Link to post
Share on other sites

I have been using another rom but wanted to try this one. So I booted into ClockworkRecovery, did a factory reset, select install zip from sd-card, select this rom, and I get this error:

Installing: /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip

Finding update package...

Opening update package...

Installing update...

assert failed: getprop("ro.product.name") == "blade"

|| getprop("ro.build.product") == "blade"

E:Error in /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip

(Status 7)

Installation aborted.

What have I done wrong?

Check for md5 checksum in SDCard.

You may have a corrupted file.

Share this post


Link to post
Share on other sites

I have been using another rom but wanted to try this one. So I booted into ClockworkRecovery, did a factory reset, select install zip from sd-card, select this rom, and I get this error:

Installing: /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip

Finding update package...

Opening update package...

Installing update...

assert failed: getprop("ro.product.name") == "blade"

|| getprop("ro.build.product") == "blade"

E:Error in /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip

(Status 7)

Installation aborted.

What have I done wrong?

Redownload, you have corrupted file. Of course u can check md5, but I havent ever done it :D Edited by peetu20

Share this post


Link to post
Share on other sites

I have re-downloaded twice, and also checked the MD5 checksum, it matches. I don't see how the file can be corrupted.

Well, the file may be corrupted on it's way to the SDCard or your SDCard may have problems.

That's why I told you to check the md5 in the SDCard.

But, since you checked it.... I don't know what can be the problem.

Try this: In CWM wipe dalvik and cache and format /system then install.

Share this post


Link to post
Share on other sites
Hiho!

Short Question: what is the best I/O-Scheduler for this ROM? The Default which is BFQ?

Thx! Best Way to test this out?

Thx!

From the io schedulers available to blade users I also prefer noop as it has the least CPU overhead, and is fast. Other schedulers are better for multitasking etc, read that link that peetu gave for more info

  • Upvote 1

Share this post


Link to post
Share on other sites

KonstaT, could it be that the low memory killer causes stability issues? I have experienced about 10 reboots in one week with latest build :(

Blade seems to crash with hard wifi tethering use and while gaming, and in normal use too, i.e while opening dialer... Got two reboots yesterday, in 30 min while gaming( And the device was not warm...)

I am just intrested could the lowmemorykiller cause this, because with earlier builds I have got about 1 or 2 reboots at this spring :)

So maybe I need to roll back to older build?

EDIT: I havent touched to any perfomance settings, so the phone must be stable, just this latest build seems to cause problems :(, and wifi tethering has always made my blade unstable( Its overheating hardly, I could boil something with Blade while wifi tether is turned on)

Edited by peetu20

Share this post


Link to post
Share on other sites

KonstaT, could it be that the low memory killer causes stability issues? I have experienced about 10 reboots in one week with latest build :(

Blade seems to crash with hard wifi tethering use and while gaming... Got two reboots yesterday, in 30 min while gaming( And the device was not warm...)

I am just intrested could the lowmemorykiller cause this, because with earlier builds I have got about 1 or 2 reboots at this spring :)

So maybe I need to roll back to older build?

EDIT: I havent touched to any perfomance settings, so the phone must be fine, just this latest build seems to cause problems :(

Hi Peetu20

I have 2 Blade, one reboot more than other, but I found the reason, this is the battery!! The battery move and the power is lost. A little paper on the bottom of the battery solves my issue.

Perhaps same for you.

Share this post


Link to post
Share on other sites

@peetu: I use the low memory killer that comes with latest CM10 and it's perfectly fine. But I don't use CM10.1 so I can tell for sure it's not the problem.

Share this post


Link to post
Share on other sites

I have been using another rom but wanted to try this one. So I booted into ClockworkRecovery, did a factory reset, select install zip from sd-card, select this rom, and I get this error:

Installing: /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip
Finding update package...
Opening update package...
Installing update...
assert failed: getprop("ro.product.name") == "blade"
|| getprop("ro.build.product") == "blade"
E:Error in /sdcard/cm-10.1-20130514-KonstaKANG-blade.zip
(Status 7)
Installation aborted.[/CODE]

What have I done wrong?

Are you absolutely sure that you have a ZTE Blade? ;) Because you certainly don't have a blade ClockWorkMod on your device. Swedish Snow was ported to couple of other ZTE devices as well...

Share this post


Link to post
Share on other sites

Just redownload your rom, I had that same problem several times

I did it once, today, or soon it will be first time I check md5 sum :)

Share this post


Link to post
Share on other sites

I did it once, today, or soon it will be first time I check md5 sum :)

Yes.

But check it when the ROM file is already inside the SDCard.

The file may be OK in the PC but when it goes to the SDCard it may be corrupted in the writing process or the SDCard itself may be faulty.

Share this post


Link to post
Share on other sites

Hi folks,

I've noticed that Google Callendar app is not working on this ROM and it can not be updated to the latest version. ( when I install the latest callendar I get 2 versions present simultaneously) Anyone else having this problem? Does anyone have the solution? I wasn't able to uninstall or remove the old app even using specialized "uninstallers"...

Share this post


Link to post
Share on other sites

Hi folks,

I've noticed that Google Callendar app is not working on this ROM and it can not be updated to the latest version. ( when I install the latest callendar I get 2 versions present simultaneously) Anyone else having this problem? Does anyone have the solution? I wasn't able to uninstall or remove the old app even using specialized "uninstallers"...

Google Calendar is working well.

If you've just installed this ROM.... do it again.

And, don't forget to wipe dalvik and cache and format \system which must have at least 160MB.

Share this post


Link to post
Share on other sites

there are 2 versions of google calendar: the play store one et the one from the GAPPS... if you can't manage to uninstall it try to 'disable' it (go to applications, click on the one from your phone, scrool down and disable)

Share this post


Link to post
Share on other sites

there are 2 versions of google calendar: the play store one et the one from the GAPPS... if you can't manage to uninstall it try to 'disable' it (go to applications, click on the one from your phone, scrool down and disable)

Well, if what you say about existing 2 versions of Calendar is true, then...

... maybe he can replace one for the other inside the GApps.zip before installation, or just remove it and install the one from Play.

Anyway, it's weird that it doesn't work because mine comes with GApps and it works well.

Share this post


Link to post
Share on other sites

I have read some nice comments about this rom, can't wait to try it :)

But first, can someone help me with expanding my storage? I've search this topic, but couldn't find it.

If I got it right, i have to format my SD card with extra partition, so I can install this rom?

Can that partition be used for installing apps? I need to buy some new card, so what do you suggest, Class4 or Class10 card?

Thanks for answers

Share this post


Link to post
Share on other sites

Hi folks,

I've noticed that Google Callendar app is not working on this ROM and it can not be updated to the latest version. ( when I install the latest callendar I get 2 versions present simultaneously) Anyone else having this problem? Does anyone have the solution? I wasn't able to uninstall or remove the old app even using specialized "uninstallers"...

There's an AOSP calendar app included in the ROM (not gapps). It's different app than Google Calendar that you install from the Play Shop.

You can easily remove /system/apps/Calendar.apk with root uninstallers/file managers/TitanIum Backup/etc.

I have read some nice comments about this rom, can't wait to try it :)

But first, can someone help me with expanding my storage? I've search this topic, but couldn't find it.

If I got it right, i have to format my SD card with extra partition, so I can install this rom?

Can that partition be used for installing apps? I need to buy some new card, so what do you suggest, Class4 or Class10 card?

Thanks for answers

No, you don't need to create any partitions on your SD card. If you don't know what EXT partition is, or what it does, you most definitely shouldn't do it.

Share this post


Link to post
Share on other sites

No, you don't need to create any partitions on your SD card. If you don't know what EXT partition is, or what it does, you most definitely shouldn't do it.

KonstanT, thank you for your swift answer and great rom :)

I am asking this because you posted "You'll need at least 160mb system partition". How to check my system partition space? I have ZTE Blade Gen2.

Well, I have some knowledge of Linux system, so I know what EXT is, but not quite sure what is it in Android system?

Edit: Should I use, TPT Helper app to reconfigure my system partition?

Edited by Dabar23

Share this post


Link to post
Share on other sites

KonstanT, thank you for your swift answer and great rom :)

I am asking this because you posted "You'll need at least 160mb system partition". How to check my system partition space? I have ZTE Blade Gen2.

Well, I have some knowledge of Linux system, so I know what EXT is, but not quite sure what is it in Android system?

Edit: Should I use, TPT Helper app to reconfigure my system partition?

Run 'df' in terminal.

If you haven't done a TPT before, you'll have a stock partition layout (220mb /system).

Share this post


Link to post
Share on other sites

HI Guys,

I've got a silly issue what I cannot solve.

As we use Viber and VOIP also, when starting a call it always asked which one to use: Viber/MobileVOIP/Phone... with two options of the choice: "Always" and "Once" (or "Just now"?).

Last time I accidentally pressed the "Always" and there is no option any more now. (it does what I asked to do it always ... :wacko: .)

How should I reset to make it ask me again?

Strange but frustrating.

(It is still the 0329 on it)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.