Jump to content

EXTended storage, Unlimited storage

Recommended Posts

I've tried so many things to get it working, but all failed...

S2E with EXT2, ext3, ext4 and even on FAT

link2SD with EXT2..... (this even gives a Blue screen of death and immediately reverts the glow to Fastboot mode with an error -> fixed this problem by booting without any SD and then deleting the init.d file for link2sd; in case any1 runs into the same problem)

I think we need your help/support for this; can you please built in support for SD-EXT storage?

i'm so used to this with CMod on all my previous devices and it allow virtually unlimited storage (everything goes on the second partition, data, apk's, cache, ... and you make 'm as big as you want)

in the recovery you can even create the second partitions (ext3 only) but you cannot mount them afterwards (option 'mount /sd-ext' is missing)

i also saw the same question popping up in one of the other topics, only there it was asked a bit more trivial...

So Vache, since we have this great device that you made running so well; the only issue a lot of people have is diskspace... with S2E-support this would be all gone; could you please help us out here?

I'll donate you a tenner (€) if you can fix this! That's how much i would love to see this on this great machine! (it's the only Acer stuff i'll ever buy, their computers are horrible quality)

Edited by Bogy1980

Share this post

Link to post
Share on other sites


Here you go : http://vache-android.com/Smartphones/Liquid%20Glow/ROMs/Mods/Internal2SD.zip

This will move apps, data and dalvik-cache to SD.

Flash this with the recovery.

1. Be sure to already have an ext2/3/4 partition on your SD before flashing this

2. The phone may bootloop on first boot after flash, just reboot again the phone and all should be fine

Share this post

Link to post
Share on other sites

after first boot i didn't have any connection with my gsm (cell) network; it said it didn't find my simcard; but after a second boot it seems allright...

as opposed to S2E this app really takes the EXT partition and sets it as your new 'internal storage' partition; cuz in totalcmd i see it's storage capacity which is new to me; but nonetheless it seems to work allright...

allthough it's not your script, i think i owe you a tenner :)

tell me where to send it.

ow, for the ones interested; i used EXT4 as filesystem

Share this post

Link to post
Share on other sites

UPDATE: having problems after all it seems....

I installed like 60 apps which i had on my previous phones and all of a sudden it stopped with installing, i also lost my connection to the play store, so i though there'd be a glitch since it didn't continue installing when the connection was made again...

i thought; i'd reboot my phone... and i just did that. it took a while because all of a sudden I got a popup (after the ACER logo) saying 'optimizing app X of 165' and it was counting, so it looked good. But all of a sudden while it's somewhere in the beginning of 100 it blanks out and reverts to the fastboot mode stating; 'could not do normal boot; reverting to fastboot mode'

when trying safe mode (vol UP + power) it only wants to do 55 apps, and it completes them, then i get 'starting apps', a blue screen and fastboot mode....

so now i'm stuck; i tried rebooting a few times, but the counter (optimizing apps) always starts over with 1 and it always goes back to fastboot mode..

what happened?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.