Jump to content
Sign in to follow this  

Home screen locked - please help!

Recommended Posts

Ok, so I had a busted board, and I found at some dude's repair shop, a working logic board (mainboard) for this phone. and I was soooo happy when I replaced everything and when it turned on, just to see home screen locked :(

But that is far from over, troubles JUST began!

G300 seems to be the FIRST phone ever, to disable recovery buttons when home screen is locked. If I enter recovery, I am not able to move up/down via volume buttons.

And then - no bootloader. I was actually trying to see if maybe recovery is faulty but there is no bootloader. UP + POWER goes straight to recovery, and "adb reboot bootloader" just boots the phone without bootloader.

So, I tried to force "wipe data" through Shell command:

recovery --wipe_data

but it says: recovery command denied.

Then, I tried to connect it via HISUITE, which is telling me that USB debugging is disabled on the device, so I cant connect it to HISUITE. really dumb situation, I cant believe that im stuck like this, just because of damn lock screen.

I am not able to reach previous owner of the phone from which I took the Mainboard to ask him for the unlock code. Dude that sold me the board doesnt even know where and when he got it.

PLEASE tell me that I can get out of this. Please tell me that there is some kind of complete flash tool for this phone.

Share this post

Link to post
Share on other sites

You could try putting an official update.app into dload folder on the SD card and performing a forced update by vol+ and vol- and power

Edited by tcpaulh
  • Upvote 1

Share this post

Link to post
Share on other sites

That's how it's done then .. ? I really hope this will work, im downloading it now.

so, for forced update, im going with BOTH volume buttons and power .. ?

Share this post

Link to post
Share on other sites

Unfortunately, it wont update.

it starts with little green android with the "update box" on his head

box turns into a triangle with exclamation

goes into recovery with no volume control.


anyone with some other idea ... ?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.