Jump to content
Webreaper

Vodafone S3 freezing and crashing

Recommended Posts

Hi all,

Had my S3 for quite a few months (since June) and it's been running really well.

However, in the last 2-3 weeks the phone has started randomly freezing - needing a long-press on the power key to force it to reboot. Sometimes it happens several times in 15 minutes.

I've tried disabling / uninstalling recent apps to see if something was crashing the OS, and I've even done a factory reset - which helped for a few days. However, it's started coming back now.

The thing is really irritating and making the phone unusable. Has anyone else seen this? Do we know if there's a fix?

Share this post


Link to post
Share on other sites

Having exactly the same problem, had mine for a few months and worked perfectly but like yours recently started freezing and crashing. Lookis like we have done the same, I have deleted apps and a factory reset but no joy. Could do with a fix or its back to the shop on the weekend

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.