Jump to content
PlaguedByPenguins

[DEV][ROM] CyanogenMod 10.1 (Android 4.2.2) for ZTE V9

Recommended Posts

I wonder if a new release with the 4.3 is going to follow. :)

4.3 release for nexus this time..maybe pbp found something >_>

Share this post


Link to post
Share on other sites

Assuming you already have Root Access and that this is going to be a clean install and you have a backup of your SD Card.

1 - Reboot in to Clockwork Recovery

1.1 Power Button -> Reboot -> Reboot -> Recovery -> OK

2 - Cleaning Tablet (Menu navigation is done by the Volume buttons and confirmation is done by the Power button)

2.1 Wipe Data/Factory Reset -> Yes

2.2 Mounts And Storage -> Format /boot -> Yes

2.3 Mounts And Storage -> Format /system -> Yes

2.4 Advanced -> Wipe Dalvik Cache -> Yes

2.5 Advanced -> Wipe Battery Stats -> Yes

3 - Partition SD Card (All the information in the SD Card Will Be Lost)

3.1 Advanced -> Partition SD Card -> 512MB -> 32MB -> Yes

4 - Copy ROM and Gapps to SD Card

4.1 Mounts And Storage -> Mount USB Storage

4.2 Copy ROM and Gapps from your Computer to your SD Card

4.3 Unmount

5 Flash ROM and Gapps

5.1 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the ROM -> Yes

5.2 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the Gapps -> Yes

5.3 Reboot System Now

Any help, please? I flashed CyanogenMod 10.1 for ZTE V9 from the base of CM7 and I followed exactly the steps above. Flashing was all fine but when the my ZTE V9 boots up, it has two errors: 1. Gapps FC 2. Setup Wizard FC. So I can't access to the home screen. Please tell me how to fix these errors?

Many thanks.

Share this post


Link to post
Share on other sites

good point. thanks for finding that! I always use adb push/pull so never noticed...

now that adb is working I can debug things like this :)

fixed in this ->

recovery-clockwork-6.0.3.2-20130601-v9-sideload.zip

md5sum 302fa9d7f8b7bdbb76ad5e73c6d5e582

DEar PlaguedByPenguins This recovery works fine and well on my v9. But I want to enlarge my knowladge....1. How to enter FTM mode (on blade tpt discussion they use restore_stock_recovery.zip , but I afraid use it because it is for blade I think ). 2. How to uninstall this recovery? use ROM manager?...

Edited by mufidfathul

Share this post


Link to post
Share on other sites

Can this last ROM cm-10.1-20130715-PenguinKANG-v9 runs VPN. Until now I can't connect vpn. I use also app from google play but neither runs....can someone suggest me what have to do...?

Share this post


Link to post
Share on other sites

First off, kudos to the OP for working on this :) I recently got my hands on a ZTE V9C (Capacitive, QC 800Mhz version) and have been looking ever since for a decent custom ROM. Unfortunately, I was unable to get any of the CWM recoveries linked in this forum to work on my device - It would hang up at boot loader screen. Then I came across the device's thread in the 4PDA Russian forums. Therein I found a working CWM recovery (5.0.2.8) and a very decent PA ICS ROM.

When I tried to flash your CM 10/1 ROMs, however, I fell back to square one. Only this time the device entered a boot loop within a few seconds on being turned on. I suspect this has to do with the kernel (I'm mostly guessing here) that this ROM comes with. Any ideas on how I can proceed further, if at all?

Thanks in advance.

Share this post


Link to post
Share on other sites

...I recently got my hands on a ZTE V9C (Capacitive, QC 800Mhz version) ...

When I tried to flash your CM 10/1 ROMs, however, I fell back to square one. Only this time the device entered a boot loop within a few seconds on being turned on. I suspect this has to do with the kernel (I'm mostly guessing here) that this ROM comes with. Any ideas on how I can proceed further, if at all?

firstly the v9c isn't supported by this rom - I don't have one which means I can't port to it. however the only issue reported by other folks who have tried to run it is that the touchscreen doesn't work properly(*). it kinda works if they hold down the home button, or something like that.

AFAIK there are no kernel/boot problems. so if I had to guess I'd say that your current booting problems might be due to wrong partition sizes and hence corrupted flashing. it might also be that your v9 isn't similar enough to the 'v9 light' - it might be a plus or 2 or something which is likely very different.

(*) IIRC in this thread someone made/found a libinput.so that works with a capacitive screen v9. maybe it hardcodes the input dev to be the atmel capacitive screen instead of the (unattached?) msm resistive - I dunno. despite me asking, they didn't explain how they did this or release any source, so it's a black box that I can't incorporate into these roms. that black box binary can read all your keypresses and may send them to the NSA for all I know :)

  • Upvote 1

Share this post


Link to post
Share on other sites

What about 4.3...

there are several serious issues with cm10.2 on armv6 right now. it's completely unusable in its current state. ETA unknown.

do you get twitchy if you don't flash often? for something different try Firefox OS for v9 :) (do a backup first)

Share this post


Link to post
Share on other sites

dear PlaguedByPenguins, ive recently bought a zte light tab v9 and searching for ics/jb roms for it.

i tried several of them including cm7 official , cm9 by rustorg & this one :). And with the last two of that (which im very interested to use) ive encountered same problem.

They both ( cm9 rustorg & cm 10.1) will stuck on welcome screen on my device .....a.k.a touchscreen somewhat didnt work.

but as cm 9,...which the last one i tried (after many trial with others rom), i found that the touchscreen would works as long as I press the "go back" button (im sorry if this out of topic about being discuss another rom). I dont know if this working with cm 10.1 as well. but thats doesnt really a solution right? :) ( i mean, i think everybody doesnt want to operate touchscreen while pressing another button :D )

im pretty sure my /system is 220mb.... as freespace app tells me that (installed it in cm 7 which ive use right now)

im using z4root_blade_perm_root_v2 & CWM v4.0.0.8

now im stuck in cm7 ..its stable,its good, its working but i hope (and want) to use cm 10.1 of your.

please tell/explain it to me what ive done wrong or some clue for that "touchscreen" bug in my device.

thank you for your big effort for creating this rom

& sorry for bad english.

best regards

Share this post


Link to post
Share on other sites

... i found that the touchscreen would works as long as I press the "go back" button (im sorry if this out of topic about being discuss another rom). I dont know if this working with cm 10.1 as well. but thats doesnt really a solution right? :) ( i mean, i think everybody doesnt want to operate touchscreen while pressing another button :D )

it sounds like you have a capacitive screen v9 model. unfortunately those aren't supported by my roms.

I'd like to support v9c's and I've tried quite a few things for folks to try to fix it, but ultimately I can't sort it out as I don't own a capacitive model to do serious testing and debugging on. sorry. if you know a place with cheap v9c's then let me know.

there is a libinput.so hack somewhere in this thread that might help you. it's not something I can ship as it is a binary blob of unknown origin with no source available and so I can't stand behind it.

Share this post


Link to post
Share on other sites

it sounds like you have a capacitive screen v9 model. unfortunately those aren't supported by my roms.

I'd like to support v9c's and I've tried quite a few things for folks to try to fix it, but ultimately I can't sort it out as I don't own a capacitive model to do serious testing and debugging on. sorry. if you know a place with cheap v9c's then let me know.

there is a libinput.so hack somewhere in this thread that might help you. it's not something I can ship as it is a binary blob of unknown origin with no source available and so I can't stand behind it.

Hai pbp,im have a little prob with with my gps issue,this my gps.conf

I mean im use sygic and gps lock very.. ... ...Zzzzz

XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin

XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin

XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin

SUPL_HOST=supl.google.com

SUPL_PORT=7276

Any idea?:(

Edited by naifah

Share this post


Link to post
Share on other sites

Hai pbp,im have a little prob with with my gps issue,this my gps.conf

I mean im use sygic and gps lock very.. ... ...Zzzzz

gps works fine for me, so I'm pretty sure this isn't a rom issue.

some ideas:

  • maybe your v9 is broken or you don't have a clear view of the sky. try looking at the satellite view in eg. gpsessential - for a decent fix you would ideally have 3 or 4 high up in the sky and it should be rare to have less than 8 or so visible.
  • I don't know much about how gps works to speed up fixes, but presumably you need the time correct to within a few seconds on the phone and (sometimes at least) a working network connection to download an up-to-date almanac.
  • I've also seen apps (eg. mytracks) that can cause the gps to stop working until a reboot. that happens on other phones too, not just v9.

Share this post


Link to post
Share on other sites

i tried again your rom, out of curiousity...but this time with new method from someone in another forum. but with your rom + gapp form konstat.

it succed...workin...but the same problem exist. i have to touch while pressing the "back" button to make the touchscreen works.

i still used the same cwm (4.0.08 from oneclickrecovery)

oh...and im pretty sure that this is zte light v9 (just bought it couple days ago, while the v9c is more pricey than this one/v9)

i forgot to mention that this was some kind of bundling (maybe) with MTC operator (there was their brand/MTC on my tablet replacing the ZTE logo)

thank you for your reply sir...cheers

Share this post


Link to post
Share on other sites

Hi,

I would like to have an info about this Rom... does it supports wifi teathering?! I've tried a CM.10 rom in the past and at the time it did not so I had to go back to CM7 official.

If any of the new ROMS are able to do this, I would gladly try them, as I need to do at least a factory reset to my CM7 official rom (camera stop working 2 or 3 days ago and no luck getting it to work again with the rebooting of the device)

Share this post


Link to post
Share on other sites

Hi,

I would like to have an info about this Rom... does it supports wifi teathering?! I've tried a CM.10 rom in the past and at the time it did not so I had to go back to CM7 official.

If any of the new ROMS are able to do this, I would gladly try them, as I need to do at least a factory reset to my CM7 official rom (camera stop working 2 or 3 days ago and no luck getting it to work again with the rebooting of the device)

If I remember well it didn't, so I used fox fi for tethering

Share this post


Link to post
Share on other sites

I would like to have an info about this Rom... does it supports wifi teathering?! I've tried a CM.10 rom in the past and at the time it did not so I had to go back to CM7 official.

If any of the new ROMS are able to do this, I would gladly try them, as I need to do at least a factory reset to my CM7 official rom (camera stop working 2 or 3 days ago and no luck getting it to work again with the rebooting of the device)

yes, wifi tethering works.

the first post will lead you konstat's page which says what works and what doesn't.

if your camera has died a new rom is unlikely to fix it.

Share this post


Link to post
Share on other sites
gps works fine for me, so I'm pretty sure this isn't a rom issue. some ideas:
  • maybe your v9 is broken or you don't have a clear view of the sky. try looking at the satellite view in eg. gpsessential - for a decent fix you would ideally have 3 or 4 high up in the sky and it should be rare to have less than 8 or so visible.
  • I don't know much about how gps works to speed up fixes, but presumably you need the time correct to within a few seconds on the phone and (sometimes at least) a working network connection to download an up-to-date almanac.
  • I've also seen apps (eg. mytracks) that can cause the gps to stop working until a reboot. that happens on other phones too, not just v9.

Yeah right pbp,i try again outside and everything is ok,maybe satelite..:lol:

Share this post


Link to post
Share on other sites

Hello good evening.
Congratulations on the great job friend.
I installed your mod on my V9 10.1 without any problem.

  • Using the system, when using the camera the image gets bug (see attached image).

IMG_20130929_155609.jpg

  • Another curiosity is on the home screen, is a sign "?" orange in the middle of the screen. As the screen is locked, the following message appears: No data. Tighten to update.

Share this post


Link to post
Share on other sites

Assuming you already have Root Access and that this is going to be a clean install and you have a backup of your SD Card.

1 - Reboot in to Clockwork Recovery

1.1 Power Button -> Reboot -> Reboot -> Recovery -> OK

2 - Cleaning Tablet (Menu navigation is done by the Volume buttons and confirmation is done by the Power button)

2.1 Wipe Data/Factory Reset -> Yes

2.2 Mounts And Storage -> Format /boot -> Yes

2.3 Mounts And Storage -> Format /system -> Yes

2.4 Advanced -> Wipe Dalvik Cache -> Yes

2.5 Advanced -> Wipe Battery Stats -> Yes

3 - Partition SD Card (All the information in the SD Card Will Be Lost)

3.1 Advanced -> Partition SD Card -> 512MB -> 32MB -> Yes

4 - Copy ROM and Gapps to SD Card

4.1 Mounts And Storage -> Mount USB Storage

4.2 Copy ROM and Gapps from your Computer to your SD Card

4.3 Unmount

5 Flash ROM and Gapps

5.1 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the ROM -> Yes

5.2 Install Zip from SD Card -> Choose Zip from SD Card -> Choose the Gapps -> Yes

5.3 Reboot System Now

 

i did all the above but i ca not install

symli: some symlinks faild

E:Error in /sdcard/cm-10.2-20130919-PenguinKANG-v9.zip

(Status 7)

Installation aborted

The only thing that i did because not described at this post is at :

3.1 Advanced -> Partition SD Card -> 512MB -> 32MB -> Yes

My card is 4Gb and i choose 2048M and Swap size 32M

What i m doing wrong??????????

i use CWM by RusTog v5.0.2.8

Edited by staman

Share this post


Link to post
Share on other sites
Capacitive screen works on ics (tricky).
 
I use this cm9, and this cm10, and capacitive screen works:  press and hold home button, touch the screen and then release home button to apply the action (in cm10 is worst implemented)
 
Is unusable but maybe somebody can find out something, i can test but i dont know anything about android kitchen.
 
Regards
Edited by pikisnikis

Share this post


Link to post
Share on other sites

Capacitive screen works on ics (tricky).

I use this cm9, and this cm10, and capacitive screen works: press and hold home button, touch the screen and then release home button to apply the action (in cm10 is worst implemented)

Is unusable but maybe somebody can find out something, i can test but i dont know anything about android kitchen.

Regards

This version of cen_y or rustorg?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.