Jump to content
Sign in to follow this  

Huawei ascend g300 stuck at vodafone logo

Recommended Posts

Hello all. Kind of new here. My Huawei ascend g300 was fine after i rooted it but then i downloaded beats audio installer (maybe not my smartest move) and i allowed it on superuser but when the phone rebooted it got stuck at the vodafone logo, left it like this before i slept and the next morning it still hadn't loaded. really desperate. Thanks. By the way i've tried to flash just about every rom i could find on this site but no luck :( also tried to do a factory reset which didn't work either :(

Edited by temi

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.