Jump to content
Sign in to follow this  

stuck on splash screen - weird problem

Recommended Posts

The phone is stuck on splash screen. unfortunately USB debugging is not enabled. on TOP of that - wont go into recovery ? o.O

I downloaded factory rom and tried to force update.zip via power + volume up/volume down but it wont do anything except enter the splash screen.

is there any way out of this ? I cant use fastboot/ADB as it is not enabled, I cant get into recovery.

if this is important, the phone should be all stock (recovery, ROM)

How can I force recovery ? I believe both volume buttons are working as the device is fairly new. please help

Share this post

Link to post
Share on other sites

But what did you do? You must have installed something? Tried pulling the battery? Your phone shouldn't just stop booting by itself.

Share this post

Link to post
Share on other sites

Dont know. little sister uses it and im trying to repair. after pulling the battery for 5-6 hours, now it gets stuck at FTM screen and still wont enter recovery ... ? And I hoped it would go once Ive seen FTM, damn!


weird still, but working!

DOWN + Power: enters FTM mode, wont go beyond

UP + power: little green android that appears when updating, but no more than 4 seconds, restart, then normal boot into android. I have never seen android device flash ROM from SD that fast.

Oh, and the trick was pulling the battery, but it needed to be more than couple of hours, dont know why. When I tried it before, it wouldnt boot, and I pulled it for 5-10 minutes. Why would it need to be many hours I dont know.

Edited by Igoritza

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.