Jump to content
KonstaT

[DEV][ROM][20.12.] CyanogenMod 10.2 (Android 4.3.1)

Recommended Posts

Well, after all this. Opinions, what is the "best" version (of Cyanogenmod) to have on old rusty Blade? Honestly, I never though to see the day, that there is somehow working ROM, with so high version number ;)

Kudos to Konstat and all the others, who made this possible. Nice work, indeed...

  • Upvote 1

Share this post


Link to post
Share on other sites

What else can i delete except Apollo in this new build to make it upto 180 mb

Share this post


Link to post
Share on other sites

Hi All again,

I have a problem with battery draining. I am on Blade Gen2 on Oct build.

 

8ukx.png

41lk.png

 

Just before the battery drop the blade changed and I need to remove battery.

What is also strange here is that the battery statistics shows that WiFi is used all the time, however, it is disabled.

 

Is this known issue?

How can I help to debug? How to gather logs if needed?

 

Thanks in Advance.

Share this post


Link to post
Share on other sites

Left my zte blade almost one year ago and now running a flagship device.

I came here today to pay homage to KonstaT and Co and I want to say thank you for being such a great supporter of this device and really make a difference to us that use your builds!

On a sidenote, it's remarkable that blade is getting these releases!

  • Upvote 2

Share this post


Link to post
Share on other sites

...

What is also strange here is that the battery statistics shows that WiFi is used all the time, however, it is disabled.

Is this known issue?

How can I help to debug?

I have noticed that before on earlier build.

Share this post


Link to post
Share on other sites

@szpilasty

is it a bug? Is there any way to fix that? is there any workaround?

 

@KonstaT

 

Is it possible to check what is wrong in the battery drain and WiFi? I could help gathering some logs and run some debug build if necessary.

Edited by grot84

Share this post


Link to post
Share on other sites

@grot84 It is a bug which I do not care too much. Used 131011 build for 2 months without problems. Normal battery behavior. Never had drop like You had. If there is a problem that's bugs you will have to fix it by yourself....

Edited by szpilasty

Share this post


Link to post
Share on other sites

What else can i delete except Apollo in this new build to make it upto 180 mb

things i deleted...

apollo

cmfilemanger..

lang pack from latinime..down to 2.3mb

email

terminal

exchange

gmscore...moved to data/app

all ringtones,alarms etc the cyan ones ...down another 4-5 mb

bootscreen

now it fits under 160mb

159.8mb to be precise

Share this post


Link to post
Share on other sites

Hi All again,

I have a problem with battery draining. I am on Blade Gen2 on Oct build.

What is also strange here is that the battery statistics shows that WiFi is used all the time, however, it is disabled.

 

It is a known issue with Android 4.3, go to Wifi -> Menu -> Advanced and disable "Scanning always available".

  • Upvote 3

Share this post


Link to post
Share on other sites

What else can i delete except Apollo in this new build to make it upto 180 mb

Why don't you want to remove Apollo from ROM? You can copy it to your SDcard and install it after flashing the ROM.

 

From ROM I removed:

     bootanimation and some sounds

     Apollo

     BasicDreams

     Calculator

     CMFileManager (replaced by Filemanager from Android 2.3 = 113KB)

     Effem

     Email

     DeskClock

     LiveWallpapersPicker

     LockClock

     QuickSearchBox

     SoundRecorder

     Term

     ThemeChooser

     ThemeManager

     and trimmed LatinIME to 3MB                                        (some of these I installed later, but then, they'll go to /data)

From GApps I removed:

     ChromeBookmarksSyncAdapter.

 

Now /system is occupied 156MB/160MB

  • Upvote 1

Share this post


Link to post
Share on other sites

It is a known issue with Android 4.3, go to Wifi -> Menu -> Advanced and disable "Scanning always available".

 

Thanks. that configuration changes fix the WiFi always on.

I am going to check if that was related to the battery drop.

  • Upvote 1

Share this post


Link to post
Share on other sites

I know it is, because I had the same issue and now it's back to normal. I guess some don't notice the drop because they don't spend most of the day in areas where the phone wifi has to work overtime to scan for networks. With that setting on, it pretty much drained by battery within a day no matter what I did and how much I used the phone.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks. that configuration changes fix the WiFi always on.

I am going to check if that was related to the battery drop.

That one OFF and "Wi-Fi optimisation" ON, in the same menu, are parameters we should check if they have the right settings.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello guys.... am still in the Oct build.... last night I experienced severe battery drain from 88% to 36% ..... Looking at battery stats... mobile standby is the culprit .... please help.

Share this post


Link to post
Share on other sites

Hello guys.... am still in the Oct build.... last night I experienced severe battery drain from 88% to 36% ..... Looking at battery stats... mobile standby is the culprit .... please help.

Mobile standby shouldn't be that high!

Maybe your phone isn't sleeping or maybe the battery is just dieing! :(

Share this post


Link to post
Share on other sites

Mobile standby shouldn't be that high!

Maybe your phone isn't sleeping or maybe the battery is just dieing! :(

What do I need to do for it to sleep properly..

Share this post


Link to post
Share on other sites

Yes!... no! Not now..

Don't get your hopes up. Even though I can't think of reason why it wasn't possible, it's not that likely to happen. Quite frankly I didn't do much in the 4.3 bring up either. AndroidMeda did all the ARMv6 compatibility and PlaguedByPenguins did some of the more device specific stuff (wifi tethering, FM radio) on V9. Legacy display/media implementations we of course shared with Blade III. It should be a fun project for someone else to pick up but I won't even bother with it until if/when there's fully working ports on other ARMv6 devices.

Ps. PM me if you want your money back.

Share this post


Link to post
Share on other sites

Anyone knows if our blades are going to recieve the latest android version (android 4.4)?

 

That's a good question. Since KitKat can run well on low end devices like our Blade is nowdays it would really make sense.

But KonstaT said in this thread 4.3.1 would be his last release :(

Edited by redandr

Share this post


Link to post
Share on other sites

That's a good question. Since KitKat can run well on low end devices like our Blade is nowdays it would really make sense.

But KonstaT said in this thread 4.3.1 would be his last release :(

First, KonstaT is a very modest man, so, he never assumes he will be able to do this or that.

Second, he is a very capable man, so don't underestimate his skills.

Third, although he is now more entertained with his Blade 3, I think he will never let go of his Blade 1... a phone that always gave him so much joy in hacking, cracking and smacking!!!

So, I wouldn't put my sword down yet...

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.