Jump to content
KonstaT

[DEV][ROM][20.12.] CyanogenMod 10.2 (Android 4.3.1)

Recommended Posts

Well, the ROM needs more sliming down, then in the past, but I managed to get it down to just 85MB. Ended up with 156MB/160MB on the system partition without touching gaps.

That's nice.... am also using it on my 160MB partition..

Share this post


Link to post
Share on other sites

do you know what is the purpose of gms core in gapps?

 

Google play services

 

Play store downloads play services automatically.... no need to have it

It's needed for initial device setup. Setting up Google account doesn't work with the new CyanogenMod account setup if it doesn't exist. I wouldn't have added ~8mb to system if it wasn't necessary!

 

I wonder if you could help me out with my new Blade G.

There's already a root and CWM for it in some foreign forums. Google search.

  • Upvote 2

Share this post


Link to post
Share on other sites

It's needed for initial device setup. Setting up Google account doesn't work with the new CyanogenMod account setup if it doesn't exist. I wouldn't have added ~8mb to system if it wasn't necessary!

 

Said from the man himself... Thanks for putting it in the limelight... Thanks again for the rom... it's a superb experience.

Share this post


Link to post
Share on other sites

It's needed for initial device setup. Setting up Google account doesn't work with the new CyanogenMod account setup if it doesn't exist. I wouldn't have added ~8mb to system if it wasn't necessary!

 

Said from the man himself... Thanks for putting it in the limelight... Thanks again for the rom... it's a superb experience.

Share this post


Link to post
Share on other sites

Hi Konstat,

 

I wonder if you could help me out with my new Blade G. I am aware that this is off topic, but since you are the ZTE guru I was hoping you could give me some advice.

 

I am trying to root the fecker, but keep running into one BIG thing. ZTE locked the USB debugging function(greyed out under the developer's menu) for some reason so the only way to open the device for modification is FTM mode.

As most of the universal rooting instructions mention USB debugging rather than FTM, I assume that's the reason why no exploit worked yet. And I am not going to flash some custom CWM until I am sure it's verified to work.

I'd like to remove some bloatware and run be able to run a samba server on the phone.

 

Would appriciate if you could help me out here, I am currently running czech firmware v10: http://www.ztedevices.com/support/smart_phone/898599d8-265c-4b8e-a571-e130daf921af.html?type=software

 

 

 

PS.:

Thanks for the great work and keeping the good old blade alive, it's kinda cult by now :) Unfortunately mine died 2 weeks ago, hence I had no chance to test CM 10.2 yet :(...

 

 

Cheers,

G

 

If you can understand or use auto translate, some info is here http://forum.androidsrbija.com/viewtopic.php?f=321&t=4589

 

I got mine with v5 telenor rom, now happily running swedish v10...

Share this post


Link to post
Share on other sites

My dad wants to thank you for this rom, it's working great, he's still using a ZTE Blade due to him working in an area where he is unable and unwilling to use an expensive Android phone but he can never get his head around texting with one of those candybar tough phones.

Share this post


Link to post
Share on other sites

Thanks a lot for maintaining the Blade as much as you do! I am still enjoying your 4.2 ROM, but I am very happy that the 4.3 ROM is available now.

 

I have looked at other phones, but every time I realize it will not get the support the Blade has they seem a lot less interesting. I just can not be bothered to shell out 200-300 euro for a phone that will not get much love after the date of purchase. Meanwhile the Blade has come such a long way; I remember the original 2.1 software and how cumbersome and clunky that was compared to the smooth accelerated 4.2 we see today. It is almost like I have had a number of ever improving phones with every new Android version that became available.

  • Upvote 2

Share this post


Link to post
Share on other sites

 

Does the BT work properly on this, as I have always struggled with upgrading from 4.1.2.  I found the CM 10.1 4.2.2 version had problems with BT on my San Francisco Blade so have been using very successfully the version 14.5 CM 10 (continuation of KonstaT's work)

 

Would be nice if it did?

Either way, thanks again for the work and continued support on this and other ROM's.

 

 

 

BT works perfectly, I had the same challenges as you with 4.2.2, but all gone with 4.3 :-)

Share this post


Link to post
Share on other sites

also remove gms core from gaaps..

 

 

and we don't need that to use with play?

 

 

It's needed for initial device setup. Setting up Google account doesn't work with the new CyanogenMod account setup if it doesn't exist. I wouldn't have added ~8mb to system if it wasn't necessary!

 

thanks KonstaT for the clarification.

Edited by la72pt
  • Upvote 1

Share this post


Link to post
Share on other sites

As I have still not moved to 4.3, I have a few slightly dumb questions, hopefully someone can help:

 

1. Does this still have a Calendar? One of my current problems is, that I have two calendars, when I update the original one, I get a second app.

2. How can one save wifi passwords. I know that theoretically, they should be saved onto the Google cloud servers, but they've never came back and I often forget to save them before installing a new version of CM.

Share this post


Link to post
Share on other sites

If you can understand or use auto translate, some info is here http://forum.androidsrbija.com/viewtopic.php?f=321&t=4589

 

I got mine with v5 telenor rom, now happily running swedish v10...

Hi cutlass, thanks for the effort. However I will not risk bricking my phone by flahing an unverified recovery. It might work for Srbijan Telenor devices, but mine runs the Czech v10 rom. So my situation is different by default and I could easily brick the fecker if I use the Srbijan method. I am looking for a way to get USB debugging enabled. Could you enable it with the Telenor Stock rom?

BTW, I was checkingthe official ZTE web, and there is no Swedish distribution whatsoever.

 

Cheers,

G

Share this post


Link to post
Share on other sites

ad1. Yes there is calendar. No need to install Google calendar. If you do so you will have 2 apps. No need for update also.

ad2. I think format /system is required then You will be changing system not upgrading. Google will not bring back your settings as this will be 'different device'.

Share this post


Link to post
Share on other sites

1. I'm kind of an update-maniac when it comes to stuff like this. My calendar is version 201306302, while the other one is 4.2.2-eng.tuomas.20130724 (this is the one integrated within KonstaT's rom). I'm not really sure what the differences between these two versions are, and I'm interested to know, because the downloaded version updated better than the original one, which took longer to get the info from my Google Calendar.

2. Ah, I see, I thought they were integrated into my Google Account. Guess I'll have to figure out a way around this, if somebody has some ideas on the matter, feel free to share.

Share this post


Link to post
Share on other sites

Installed Google Calendar I do not see any difference. I am pretty sure that if this is necessary you will find new version of gapps here. That's the way if you want use custom rom.

Edited by szpilasty

Share this post


Link to post
Share on other sites

Hi Konstat,

 

I wonder if you could help me out with my new Blade G. I am aware that this is off topic, but since you are the ZTE guru I was hoping you could give me some advice.

 

I am trying to root the fecker, but keep running into one BIG thing. ZTE locked the USB debugging function(greyed out under the developer's menu) for some reason so the only way to open the device for modification is FTM mode.

As most of the universal rooting instructions mention USB debugging rather than FTM, I assume that's the reason why no exploit worked yet. And I am not going to flash some custom CWM until I am sure it's verified to work.

I'd like to remove some bloatware and run be able to run a samba server on the phone.

 

Would appriciate if you could help me out here, I am currently running czech firmware v10: http://www.ztedevices.com/support/smart_phone/898599d8-265c-4b8e-a571-e130daf921af.html?type=software

 

 

 

PS.:

Thanks for the great work and keeping the good old blade alive, it's kinda cult by now :) Unfortunately mine died 2 weeks ago, hence I had no chance to test CM 10.2 yet :(...

 

 

Cheers,

G

Hi again,

 

I am googling for the past week, no worries I wouldn't approach you if I hadn't tried everything else. I've spotted the Serbijan method, however most of the people who tried it report either brick or ending up without root PLUS without recovery. So I decided not to risk that.

 

PS.: I am not a dev but quite experienced with rooting/flashing phones, and wouldn't dare asking stupid questions(at least I hope so :)).

 

Thanks for looking into it anyway :)

 

Ceers,

 

G

Share this post


Link to post
Share on other sites

Hi again,

 

I am googling for the past week, no worries I wouldn't approach you if I hadn't tried everything else. I've spotted the Serbijan method, however most of the people who tried it report either brick or ending up without root PLUS without recovery. So I decided not to risk that.

 

PS.: I am not a dev but quite experienced with rooting/flashing phones, and wouldn't dare asking stupid questions(at least I hope so :)).

 

Thanks for looking into it anyway :)

 

Ceers,

 

G

PS.: Plus as mentioned, the USB debugging option is locked on mine :(..

Share this post


Link to post
Share on other sites

USB Debugging on blade G is avalible ONLY when device connects to pc in "Connect to PC Software" mode ( i dont know why but thats how it is )

Share this post


Link to post
Share on other sites

Well I was testing 3G mode only and I kept getting some network error... reboot, still the error so I flashed cm10. 1 and ohh men... the roboto fonts... are way uglier than that of cm10. 2.... heheheheheh... This is crispier.... sharper and beautiful.... am back here to stay... am using 3G/2G... mode works fine....

The error occurred after a couple of time.. usage... mostly with online chat apps eg 2go

Edited by Fizziebaunz

Share this post


Link to post
Share on other sites

As I have still not moved to 4.3, I have a few slightly dumb questions, hopefully someone can help:

 

1. Does this still have a Calendar? One of my current problems is, that I have two calendars, when I update the original one, I get a second app.

2. How can one save wifi passwords. I know that theoretically, they should be saved onto the Google cloud servers, but they've never came back and I often forget to save them before installing a new version of CM.

 

1. Just install Google Calendar from Play Store. You can also disable (in app settings) the system calendar from the ROM before or after that.

2. Use Titanium Backup (or other backup app) to backup your wifi passwords and then restore them in the new ROM. But never restore all system data to a new ROM, just passwords, sms, contacts, call logs, bookmarks. You will have problems otherwise.

Share this post


Link to post
Share on other sites

As I have still not moved to 4.3, I have a few slightly dumb questions, hopefully someone can help:

...

2. How can one save wifi passwords. I know that theoretically, they should be saved onto the Google cloud servers, but they've never came back and I often forget to save them before installing a new version of CM.

 

you can try this, backup and restore your wifi passwords.

Edited by la72pt

Share this post


Link to post
Share on other sites

hi everyone, i am currently running cm 10 (running smoothly) and wanted to know if it is a good idea to shift to this rom for daily use, as blade is my only device. also does the new trim function of 4.3 work to keep the device fluid even after installing alot of apps; and lastly if someone could tell me a good solution for a substitute of s2e, for this rom,

Thank You

Share this post


Link to post
Share on other sites

USB Debugging on blade G is avalible ONLY when device connects to pc in "Connect to PC Software" mode ( i dont know why but thats how it is )

Hi again,

 

thanks for the hint, makes things much easier. I managed to root my Blade G in the meantime. Here's what I did:

 

- Download srsroot from http://www.srsroot.com/

 

- Boot your phone into ftm mode - Vol Down + Power(might work with USB debugging on as well without FTM).

 

- Connect phone to PC

 

- Install and run srsroot - all methods

 

***

At this point I could spot the SU binary being present, but still had no root access.

So I went on and:

***

 

- Download latest SU binary from http://androidsu.com/superuser/ - arm-signed

 

- Replace the current SU file in the srsroot program folder(which is 3.0.0 I believe) with the downloaded 3.1.3 SU

 

- Run srsroot again

 

***

I still had no root access, so I gave up. After about 30 minutes I looked at my phone and voila 'Clean Master is requesting Superuser permission' Allowed and rooted :)

 

 

NO FLASHING OF RISKY UNVERIFIED RECOVERIES OR THE-LIKE, JUST PURE ROOT ACCESS. ENJOY

 

Cheers,

 

G

Share this post


Link to post
Share on other sites

hi everyone, i am currently running cm 10 (running smoothly) and wanted to know if it is a good idea to shift to this rom for daily use, as blade is my only device. also does the new trim function of 4.3 work to keep the device fluid even after installing alot of apps; and lastly if someone could tell me a good solution for a substitute of s2e, for this rom,

Thank You

AFAIK trim is working only on newer NAND flash memories

  • Upvote 1

Share this post


Link to post
Share on other sites

/ some long text /

 

I still had no root access, so I gave up. After about 30 minutes I looked at my phone and voila 'Clean Master is requesting Superuser permission' Allowed and rooted :)

 

NO FLASHING OF RISKY UNVERIFIED RECOVERIES OR THE-LIKE, JUST PURE ROOT ACCESS. ENJOY

 

Cheers,

 

G

 

There you go! Flash it with CWM so you can backup your rom and wait till there are custom roms for us on blade g

Share this post


Link to post
Share on other sites

There you go! Flash it with CWM so you can backup your rom and wait till there are custom roms for us on blade g

Hiya mate,

 

Ummm... I don't really trust the CWM that works for the Serbijan v5 , not sure if it would work with the Czech distro. And I checked with ROM Manager if there's an official recovery for the G - negative. I rather use Titianium for the backup and as long as there's no custom ROM, there's no point in flashing CWM anyway.

 

But yeah!! got rid of the bloatware and changed the I/O scheduler to noop, gouvernor to interactive - gained about 200 pts in Antutu :). Waiting for a kernel that supports smartass(v2) gouvernor.

 

PS.: Would flashing a custom rom not work with the stock recovery if renamed to update.zip?

 

Cheers,

 

G

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.