Jump to content

Re-Partition any MTK6589 Phone, Without A PC! (More /Data Storage!)

Recommended Posts

I just got my THL W200 (MTK6589T) phone yesterday, i restored the Titanium Backup i made on my Xiaocai X9 (1.5gb /data partition i think?). After doing this i tried updating my apps on Market and was promptly told i had run out of storage already. Turns out the W200 has a pitiful 1gb /data partition for apps, it's enough for most people and you can mess about moving stuff to sdcard etc but this didn't suit me.

Turns out the W200 has a 6gb+ internal sdcard which is nice but i have a 32gb Class 10 sdcard i like to use, so that internal sd is TOTALLY wasted space to me. It turns out there is a simple app created by "meteos" that can help move that space around a little bit.

I used the app to go from,

1gb /data partition with a 6gb internal sdcard
to a
5gb /data partition with a 2gb internal sdcard.

Here is what you need to do to follow suit, assuming you have ROOT.

Just remember

you do this at your own risk,

i do not guarantee i can help you return to stock partitions etc although you should just need to flash your stock rom with SP Flash Tools.



How to.


1. First you need to make a Clockwork Mod Backup of your current rom as you have it RIGHT NOW :) Do not skip this step please.


2. Check to make sure you have completed Step 1 ;)


3. Download this .apk file. Install it and open it.


4. You will be presented with some options mostly for 8gb ROM phones. Only the first option should be used on phones with 4gb of ROM. This will still give you a 1.5gb /data partition. Choose whatever suits you best. I went with 5gb /data partition option . Go through with all the confirmation prompts.


5. Select the Reboot to Recovery option in the app. When in recovery select "Wipe Data/Factory Reset". Then you need to restore your Clockwork Mod backup that you made earlier.


6. That's it now when your phone boots if you check storage you should see that your partition sizes have updated. Except your internal sdcard is now corrupted and unmountable... Does it bother you? Keep reading.


7. Unfortunately not a totally pc-less process if you want to use the now tiny internal sdcard partition. Connect the phone to your pc and mount usb storage. If you're on Windows it will pop up a prompt to format the corrupt internal sdcard. 


That's it you're now done!

Share this post

Link to post
Share on other sites


I have a Star N9500 4GB and tried using this tool but incorrectly chose a partition size larger than the first option and after rebooting the phone the rom does not load past the initial android start up screen, where the animation continually goes on.  I have tried restoring various CWM backups and some other roms and all process correctly in CWM but when booting the phone it still does not go past start up screen.


Does anyone know if there is a way to fix this?


Thanks in advance.

Share this post

Link to post
Share on other sites

Yes you need to flash any stock rom for youe device with SP FLASH Tool. Then you can re root and restore a backup. It's not broken it will be fine.

Share this post

Link to post
Share on other sites

Tried this on my  Chinese POMP W89 using the 4gb/8gb option and it worked perfectly Main internal is now up from 1gb to 1.48gb and SD/Nad is 1.27gb..... I used iRoot to root phone Clockworkmod for backup ... This process will prob work for most Chinese phones but I can only say for sure it will for the Pomp




The POMP W89 sees the second partition as your SD card and NOT you external SD card so the backup is done to the this partition which is erase when you do a wipe and reset so MAKE SURE after backup finished you restart your phone then copy the backup file off your phone ...... THEN go back to recovery mode do the wipe and reset ..... Then restart phone again and copy file back to the second partiction which is now 1.27gb restart into recovery mode and run restore user data and all should go well


To start POMP W89 in recovery mode hold power and volume up button until the Andriod bot shows and it says no commands .....releace buttons then press the power button again ....use volume down to scroll through options and volume up to select THIS is different to instructions given using power button to select


Just one last thing which I thought maybe a problem is I use my external SD card as default write to so the internal SD space is not used and so was empty on my phone. If its full on yours when you do a restore user data it may be a problem due to the smaller space so it maybe wise to move files or back up files from this to your pc or external SD card



Edited by ygjhvgjvgvghc

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.