Jump to content
Digital_kid

Tesco server down

Recommended Posts

Ok I have reset my Hudl and its now stuck on the wifi page. Upon investigation once you connect to wifi the Hudl connects to the Tesco server and with that being down it puts us in a loop back to wifi screen.

 

Question is can anyone make a custom rom and remove the tablet from looking for the tesco server?

Share this post


Link to post
Share on other sites

We are in the same boat over here. And more people are in trouble over this. I wonder if Tesco will fix the issue? If not to make a "factory update" is the pathway for their custumers to to bricking the device. Digital_kid, you can find more people struggling with this here:

 

https://www.modaco.com/forums/topic/382204-hudl-2-connects-to-wifi-but-tesco-update-server-not-switched-on/?tab=comments#comment-2290357

 

Share this post


Link to post
Share on other sites

I called tech support, the advisor said he is getting 30 calls a day about this and 2nd line are aware. Just thought if there was a custom firmware that removed this check then that would do the job sooner. The tablets are made by Wistron Corporation, was going to email them and see if they have a non branded firmware we could flash?

Share this post


Link to post
Share on other sites

I've looked into the build.prop values to bypass this and also replacing the setup wizard apks but nothing.

The only thing I can think is to decompile the setup apk, patch it out and recompile it but I've got no time for that atm.

Or update /etc/hosts to point the Tesco servers to a different server that responds correctly.

Share this post


Link to post
Share on other sites

If we knew what the expected response from hudl-v3-swarm2.uksouth.cloudapp.azure.com should be it would make things a lot easier...

Share this post


Link to post
Share on other sites

First it uses https so you need to be running a site that use https with a certificate that is signed by a CA the device accepts as valid, second the fist thing you have to get past is the hudl.oat package.  As for the request and payload do know what it is someting like
/ota/20140424.153851
{"status":"OK", "update": null}
see my solution for the hudl 2, doesn't work on the hudl 1 even if I add my fake CA to the system CA's via root, the hudl.ota is using something else.

Part of the solution for the hudl 1 is to edit /data/user/0/hudl.ota/shared_prefs/OTA_CLIENT.xml via a rooted system just change the value (i.e. to 20140424.153850) of the last_known_version_number
<?xml version='1.0' encoding='utf-8' standalone='yes' ?>
<map>
<null name="shared_location_update" />
<boolean name="shared_active_new_download_notification" value="false" />
<int name="ota_status_update" value="1" />
<string name="last_known_version_number">20140424.153851</string>
<null name="shared_info_update" />
<long name="shared_download_id" value="-1" />
</map>

Then if goes on to update the apps that just goes around and around, that talks to my site via the fake CA after a response to /appupdater.

Share this post


Link to post
Share on other sites

And the hudl 1 is solved 🙂
Okay the other response you will need to appupdater is
{"mandatory": false,"apps":[]}

Getting the CA on the device I used this information
https://stackoverflow.com/questions/44942851/install-user-certificate-via-adb

Share this post


Link to post
Share on other sites

@chrisevilgenius can you do an image that's passed the WiFi with no user installed maybe please?

 

Then it'll be easier for users to have a clean image and all they have to do is add a Google Account.

 

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

That is actually beyond my current knowledge, I literally took on this problem on the 3rd with no knowledge about how android works, so I'm not sure if you can make images with user data let alone how to do it, without the potential of really killing the device.

What the hudl 1 needs is  an image creating with a replacement for the hudl.ota, as it is never going to get a new image by calling home and maybe the Tesco stuff like the app updater removing replacing but I'm not sure I know how to do that either.

Although the reason for working on the problem was to help out another SEN parent, they have taken this as an option to move on, so I might look at it more now I have not worries about bricking it completely.

Share this post


Link to post
Share on other sites

It has started working for me this morning, I was going to go on and do a similar fix to yours, using a Proxy but Tesco might have fixed it?

Share this post


Link to post
Share on other sites

Hi All!

I have just successfully factory reset my Hudl 1 (HT7P16S3) through the boot menu details below...

 

Android version 4.2.2

Kernel version 3.0.36+

Build number JDQ39.20140424.153851

 

...so (from my POV) the Tesco/MS servers are now giving the correct response to let the Hudl 1 reset complete to a proper conclusion.

 

After reset I followed the steps in Anna65's post of the 27th February

 

  • On the “Hello” start-up screen, select Start.

  • Select the your WiFi connection – and log in!

  • On the Terms & Conditions pop-up box, select Continue.

  • When asked if you’d like to add a Google Account or sign up for one, select No.

  • Untick both boxes in Google & Location and tap the arrow to proceed.

  • On “Have a Tesco Account”, select No.

  • On Register with Tesco, select Skip.

  • You’ll see Checking for Updates and Updating Apps progress pages.

  • When asked to update apps, select Not Now.

  • Select Finish.

  • You’ll now be taken to the Home screen of your Hudl and you’ll be able to use it as normal.

 

BUT after I got to the home screen I went into applications and cleared the data, disabled notifications, force stopped then disabled the below, mostly Tesco, bloatware...

 

  • Blinkbox

  • Blinkbox music

  • Blinkbox widget

  • Clubcard TV

  • Getting Started

  • Google+ - Never used this App (it might now be defunct anyway)

  • Groceries

  • Groceries widget

  • Hangouts – Never used this App

  • Picasa Uploader – Picasa is now defunct anyway

  • Store Locator

  • Tesco Account Manager

  • Tesco Clubcard

  • Tesco Direct

  • Tesco World

 

I then opened Play Store and signed in with my account and let it update the apps it wanted to, but please note that the Play Store App itself and possibly a few other base Google services need to update themselves first and this can look like the Play Store has frozen on a partially empty screen for about 5ish minutes. Once the PS has updated the other Apps start updating.

 

I now have a fully working Hudl 1...!

Share this post


Link to post
Share on other sites

As of 21st March 2019 the set up procedure is working as razzler's post above shows.  If anyone is interested why Tesco is likely to have done a U-turn on the hudl, then check out page 8 onwards on this thread.   It looks like the solution we suggested to Tesco and/or involving the media may have done the trick! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.