Jump to content
Sign in to follow this  
The PocketTV Team

i600 Registry PATCH Released! lets you install all apps!

Recommended Posts

[EDITED]

The PATCH is posted here:

http://smartphone.modaco.com/viewtopic.php...p=370391#370391

Samsung had also released i600 patches on their website (at http://www.samsungtelecom.com/support/mit/ ), unfortunately they have now pulled-off the page.

Verizon Wireless is working on a software PATCH for the i600, to solve the application install issue (i.e. some non-signed apps cannot install on the i600).

We are working with Microsoft and Verizon Wireless to test/validate this patch.

Could you tell us what application(s) cannot (currently) be installed on your i600 ?

(and what error message you get when installation fails)

Share this post


Link to post
Share on other sites

Thanks so much. I really aprreciate what you are doing. I JUST got my i600 today and was hoping a solution would be found. Im glad to hear samsung/verizon are cooperating (I thought they locked the phone on purpose and it would need to be hacked).

Thanks again.

Share this post


Link to post
Share on other sites
(I thought they locked the phone on purpose and it would need to be hacked)

No, it was just a configuration error, similar to that of the Mitac 8380.

Can you try to install some non-signed applications (i.e. most freeware are non-signed) and tell us which ones you cannot install and what message you get.

This will help up to test the patch.

Thanks!

Share this post


Link to post
Share on other sites

encece has an ongoing thread on which unsigned apps work and dont work on the i600.See it here.

The only problem I have had thus far is with SmartNES (NES emulator for smartphone). It is just an executable and it runs fine, but the button mapping doesnt work on the i600 (while it does for other smartphones). It doesnt take any settings. The problem you propose with the registry would make sense, if the program is trying to save the button mappings to the registry.

Share this post


Link to post
Share on other sites
encece has an ongoing thread on which unsigned apps work and dont work on the i600.See it here.

The only problem I have had thus far is with SmartNES (NES emulator for smartphone). It is just an executable and it runs fine, but the button mapping doesnt work on the i600 (while it does for other smartphones). It doesnt take any settings. The problem you propose with the registry would make sense, if the program is trying to save the button mappings to the registry.

Thanks for the link to the other thread.

I'll check to see if SmartNES button mapping works with their patch.

Can you provide a link for SmartNES ? The link in http://smartphone.modaco.com/viewtopic.php...hlight=smartnes does not work.

Share this post


Link to post
Share on other sites

You dont need any roms. Just launch SmartNES, goto Options | Controllers. Try mapping one of the keys... After it says "Press Key" and you do so, a window pops up with the key code of the button you were trying to map with OK as the first soft-key. You cannot press okay. The only button that does anything is the back button and your setting is not saved. My assumption is that the OK button saves your setting to the registry, which is why it wont work. The i600 is the only phone I have heard of having this problem.

Thanks.

Share this post


Link to post
Share on other sites
You dont need any roms. Just launch SmartNES, goto Options | Controllers. Try mapping one of the keys... After it says "Press Key" and you do so, a window pops up with the key code of the button you were trying to map with OK as the first soft-key. You cannot press okay. The only button that does anything is the back button and your setting is not saved. My assumption is that the OK button saves your setting to the registry, which is why it wont work. The i600 is the only phone I have heard of having this problem.

Thanks.

Indeed it does not work, but that may be another issue, there is no guarantee that it's Registry related. It may be something totally different. The developers of this application should do some debugging to figure out why it does not work on the i600.

By the way there seem to be a number of other problems with SmartNES, e.g. if you hit Home, then you cannot return to SmartNES (even by selecting its icon in the Home lineup).

Share this post


Link to post
Share on other sites

Yeah, unfortunately the developer stopped work on the app :lol: As far as I know, its the only NES emulator for smartphone and it's unusable on the i600 with the default button config :D Since the button mapping works on other smartphones Im hoping it has to do with this registry problem.

Share this post


Link to post
Share on other sites
Yeah, unfortunately the developer stopped work on the app :lol: As far as I know, its the only NES emulator for smartphone and it's unusable on the i600 with the default button config :D Since the button mapping works on other smartphones Im hoping it has to do with this registry problem.

I truely think it's an unrelated issue, since with the patch, the allowed parts of the Registry are actually allowed. Maybe they try to access some parts of the Registry that are normally not allowed ? For example, it would work on the MPx200, because they disabled completely the security, but it's not the normal configuration for application-unlocked Smartphones.

If the developper stopped working on this app, there is little chance it will get resolved. sorry...

Share this post


Link to post
Share on other sites

Do you have an ETA on this patch?

Im sorta confused now though. The i600 IS software-locked, but there is a bug that is blocking unsigned software that SHOULD work anyway? If any unsigned app can access the reg and such, what other limits are there that require the digital signature?

Thanks for your time and help.

Share this post


Link to post
Share on other sites

> Do you have an ETA on this patch?

No, I don't have any. I hope soon!

> Im sorta confused now though. The i600 IS software-locked,

No! the i600 from Verizon is APPLICATION-UNLOCKED.

> but there is a bug that is blocking unsigned software that SHOULD work anyway?

Yes, there is a configuration bug, that prevents the phone from installing *some* unsigned applications.

Normally, when a phone is application-unlocked, you should be able to install *all* unsigned applications. Not the case with the i600, because of that bug.

> If any unsigned app can access the reg and such, what other limits are there that require the digital signature?

Digital signatures are of different sorts and have different purposes.

"Regular" signatures are necessary to install applications on application-locked Smartphones (like those from Orange).

"Privileged" signature are necessary to install and run applications that access privileged API's on the phone (e.g. access to the SIM or to the low-level telephony or network API's), even if the phone is application-unlocked.

The only exception to that latest rule is the AT&T MPx200 which (incredibly) allows full access to all the privileged API's with no security restriction.

Share this post


Link to post
Share on other sites

Sorry, I thought I was the only person dealing with this/cared :) You can remap the buttons in the registry... they are indeed stored in HKCU so its no problem.

Cheers.

Share this post


Link to post
Share on other sites
So I'm not alone on the SmartNES button mappings not working? : )

I'm soooo eager for a fix to this....

I'm just wondering what keys are you trying to remap... I can remap the keys on my i600, and there are only 2 keys that I cannot change, thats the home key and the back key.

Share this post


Link to post
Share on other sites

I'm just wondering what keys are you trying to remap... I can remap the keys on my i600, and there are only 2 keys that I cannot change, thats the home key and the back key.

You mean you can play the games?

I can't map ANY buttons..i.e when I goto the mapping option and choose a key it just freezes and doesnt let me press OK.

Plus, I don't know what if any are the default keys ...just to be able to play at least...

Please help by telling me exactly what you did, and if you updated your phone or anything...

Thanks in advance!

Share this post


Link to post
Share on other sites

I don't know why your keys are mapping but I haven't made any changes that i can think of to the phone other then doing the Samsung MSN update... I initalized a few days after the update because the phone had started acting really weird and I wanted to reinstall my apps. I can't tell you if it worked or not before this. I don't recommend you trying to do the same. Anyway I'm running Smartnes v 1.2 directly from my storage card.

I run the program then select controllers A, B, Select, Start, etc. I select the |...| box. Once i do that I get another popup box asking me to Press a Key... I then select 1 or 4 in my case thats what i like.. The Press a Key box goes away and the key is then remapped. I then select ok and load my rom. The only problem I've had is if i power the phone off my key map settings are erased. But as long as I don't power off.. I'm good to go. I'm rather suprised to see that many people are having this problem and I'm not. Anyway if you guys want we can compare program settings and versions let me know... There is always an answer to every problem

Share this post


Link to post
Share on other sites

Then its just as well to remap them in the registry cause the settings say after power-offs. Thats pretty lame it would lose the settings, and doesnt make too much sense if its editing the registry.

The developer of this emu is a twat anyway. Its based on PocketNester which is open source under GPL and he wont release the SmartNES source code. He was trying to SELL the code, and when I asked for it based on the GPL he told he his harddrive crashed and he lost the source :roll: What a lovely coincidence.

Share this post


Link to post
Share on other sites
I don't know why your keys are mapping but I haven't made any changes that i can think of to the phone other then doing the Samsung MSN update... I initalized a few days after the update because the phone had started acting really weird and I wanted to reinstall my apps. I can't tell you if it worked or not before this. I don't recommend you trying to do the same. Anyway I'm running Smartnes v 1.2 directly from my storage card.

I run the program then select controllers A, B, Select, Start, etc. I select the |...| box. Once i do that I get another popup box asking me to Press a Key... I then select 1 or 4 in my case thats what i like.. The Press a Key box goes away and the key is then remapped. I then select ok and load my rom. The only problem I've had is if i power the phone off my key map settings are erased. But as long as I don't power off.. I'm good to go. I'm rather suprised to see that many people are having this problem and I'm not. Anyway if you guys want we can compare program settings and versions let me know... There is always an answer to every problem

ATTENTION

Thanks to Omegared I have found hot to fix this!

Apparently, all of us who have the i600 and CANNOT map the buttons using SmartNES have an OLDER VERSION.

Because of Omegared's assistance, I ventured out to find a way as why it would'nt work with my i600.

Anyways, it all came down simply to this:

- We have an OLDER version of SmartNES which does'nt work. I'm pretty sure all of you who can't get it to work downloaded SmartNES from:

http://www.monolithix.org/SPV_software.html

while the WORKING VERSION (1.2) is from here: http://perso.wanadoo.fr/wawawoum/smartnes.exe

Enjoy! :)

Share this post


Link to post
Share on other sites

ATTENTION

Thanks to Omegared I have found hot to fix this!

Apparently, all of us who have the i600 and CANNOT map the buttons using SmartNES have an OLDER VERSION.

Because of Omegared's assistance, I ventured out to find a way as why it would'nt work with my i600.

Anyways, it all came down simply to this:

- We have an OLDER version of SmartNES which does'nt work. I'm pretty sure all of you who can't get it to work downloaded SmartNES from:

http://www.monolithix.org/SPV_software.html

while the WORKING VERSION (1.2) is from here: http://perso.wanadoo.fr/wawawoum/smartnes.exe

Enjoy! :)

I'm glad that we have found the answer to this problem. Hopefully we can work together and find solutions to some of the other issues with the phone. I think thats the only draw back the smartphone has a great following in the GSM world, but only a handful have the i600 :D

Share this post


Link to post
Share on other sites
Yeah, unfortunately the developer stopped work on the app :) As far as I know, its the only NES emulator for smartphone and it's unusable on the i600 with the default button config :D Since the button mapping works on other smartphones Im hoping it has to do with this registry problem.

This has been solved here: http://smartphone.modaco.com/viewtopic.php...p=342980#342980

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.