Jump to content

Switching between Wifi and 3G/GPRS


Guest Loconinja

Recommended Posts

Guest rickwookie
Rick, I am wondering if there is something common among us causing this problem. So I propose these few questions:

1) What type of Hermes device are you using?

2) Is your SSID broadcasting?

3) What type of encryption are you using?

4) How did you add the details, i.e. did you turn on the WLAN and your network was automatically detected and the details added from the today page or did you manually add the configuration details through comms manager/wireless connections (only option if SSID broadcast is off)?

For me, when I had this problem rather than my newer problem,

1) Vario II

2) Off

3) WEP

4) Manually

When it worked, in so much as it tried to use my router and failed rather than automatically choosing the 3G, I had just hard reset my phone and,

1) Vario II

2) ON

3) WEP

4) Automatic

This suggests to me, either it doesn't like the SSID being turned off, which would seem unlikely, or adding the details manually changes a less than obvious setting.

To be honest I don't really understand the structure of the comms manager. It would seem data connections get an entry in the table, i.e. TMobile Internet but wifi doesn't, which suggests to me it should always use wifi if present, but then the subsequent tabs in that table make even less sense to me. Maybe someone could do a comprehensive list of these network options and what they actually MEAN.

1) Vario II

2) Off

3) AES -> downgraded to TKIP for this device :D

4) Manually

This has nothing to do with my problem though as I see it. I can connect without any problems to my WiFi network. It's just that unless I select 'Start->Settings->Connections->Connections->Advanced->Select Networks - Programs that automatically connect to the Internet should connect using: My Work Network ok ok X' (that's eleven clicks I counted) then PIE will always try to use T-Mobile GPRS/3G even though I am connected via WiFi.

If I do change the setting as above, then if I'm not connected to my WiFi network then I can't use the internet on the device until I change it back again. That's:

'Start->Settings->Connections->Connections->Advanced->Select Networks - Programs that automatically connect to the Internet should connect using: T-Mobile Internet ok ok X'

Another 11 clicks! :D

In 'Start->Settings->Connections->Connections' under 'My Work Network' there's an option 'Set up my proxy server'. If you select that you'll see a check box for 'This network connects to the Internet'. Brilliant. Only if you check it and click 'ok', then look at it again, you'll see that it is not stored.

The only way to get that box checked is to, wait for it:

'Start->Settings->Connections->Connections->Advanced->Select Networks - Programs that automatically connect to the Internet should connect using: My Work Network ok ok X'. In which case it will be checked, and you can't then get it to be unchecked! :D

It's all a bit of a nightmare really.

One might wonder why I care since I have WnW Pro with HSDPA. Well that's not as reliable as my home broadband, it's not 4 Mbps, it takes a little while to connect (not too long though) and most importantly I can't connect to any webservers sitting on my home network with it.

It needs to work the same way as on a windows desktop where you can specify:

post-53305-1156845501_thumb.jpg

It seems as though on these devices there are only settings that allow the first and the last of those three options. We need the middle one. :D

Edited by rickwookie
Link to comment
Share on other sites

Guest rickwookie
Mine only tries opening a 3g connection if directpush is on, or if I have PIE minimised from a previous 3g connection.

How do you switch directpush on/off?

As long as you set the wifi network card set to connect to the internet and have no existing web enabled apps open or minimised when you connect to wifi, it should use wifi.

It does. But then if you set the wifi network card (or more importantly, the connection settings) to connect to 'The Internet', you can't then access anything on your local network. For example, if I try to access a network share in File Explorer, I get a pop-up message:

"Cannot Connect

Cannot connect with current connection settings, To change your connection settings, tap Settings."

I get the same message if I try to connect to my slimserver's webserver on my network using PIE and browsing to http://192.168.11.2:9000/

So I have to set the WiFi settings to connect to 'Work'. This is what gives all the issue already mentioned. You need to set it to 'Work' to be able to access anything at, work, but there seems no way to set it that 'Work' actually connects to 'The Internet' so don't start another connection.

Edited by rickwookie
Link to comment
Share on other sites

Guest jimbouk
Great in theory. Had MS decided not to to remove wireless (wifi) syncing in Activesync 4.x :D

:D

Directpush only works with exchange server 2003 sp2 and you can sync with exchange servers over wifi.

Link to comment
Share on other sites

Guest jimbouk
How do you switch directpush on/off?

It does. But then if you set the wifi network card (or more importantly, the connection settings) to connect to 'The Internet', you can't then access anything on your local network. For example, if I try to access a network share in File Explorer, I get a pop-up message:

"Cannot Connect

Cannot connect with current connection settings, To change your connection settings, tap Settings."

I get the same message if I try to connect to my slimserver's webserver on my network using PIE and browsing to http://192.168.11.2:9000/

So I have to set the WiFi settings to connect to 'Work'. This is what gives all the issue already mentioned. You need to set it to 'Work' to be able to access anything at, work, but there seems no way to set it that 'Work' actually connects to 'The Internet' so don't start another connection.

You turn directpush on and off with the Directpush button in Com Manager - but the button is only usable if you have set up syncing with an exchange server.

You guys are all over complicating things. In Network Management, I have Orange World as my Primary network (as this allows me to connect over 3g/gprs to the web. If wifi is already enabled, then it ignores this anyway. I have My Work Network selected as the private network option (but as there are no entries in My Work, it is immaterial.

In my wifi network settings for my home wifi, if I click on the SSID for the network, then its says Internet in the Connects To box.

You are talking about two different things.

Link to comment
Share on other sites

Guest rickwookie
You turn directpush on and off with the Directpush button in Com Manager - but the button is only usable if you have set up syncing with an exchange server.

You guys are all over complicating things. In Network Management, I have Orange World as my Primary network (as this allows me to connect over 3g/gprs to the web. If wifi is already enabled, then it ignores this anyway. I have My Work Network selected as the private network option (but as there are no entries in My Work, it is immaterial.

In my wifi network settings for my home wifi, if I click on the SSID for the network, then its says Internet in the Connects To box.

You are talking about two different things.

But with these settings, you can't connect to anything on the LAN (can you?), either using PIE or File Explorer. If you don't need to connect, or have nothing to connect to, on the LAN then it's fine, but if you do, what's the solution.

Beleive me, I really don't want to make it any more complicated than it already is. :D

Link to comment
Share on other sites

Guest Dr Who
1) Vario II

2) Off

3) AES -> downgraded to TKIP for this device :D

4) Manually

It's all a bit of a nightmare really.

Hi Rick, I can see three similarities here. The Vario II part, which could be at fault if there is a problem with their ROM, the SSID 'OFF' part and the 'manual' adding of the settings.

Could you try turning your SSID broadcast to 'on' and maybe give it a new SSID temporarily? Then turn on the WLAN on the Vario and let it search for the network and then add the details at the prompts?

I am going to reconfigure the wireless here at work and see if I have any luck using a different router to the one at home, for my different wireless issue.

Link to comment
Share on other sites

Guest jimbouk
But with these settings, you can't connect to anything on the LAN (can you?), either using PIE or File Explorer. If you don't need to connect, or have nothing to connect to, on the LAN then it's fine, but if you do, what's the solution.

Beleive me, I really don't want to make it any more complicated than it already is. :D

Try resco file explorer as the inbuilt file explorer is not network-capable. I can map network drivers from all the machines on my home lan with the settings above.

Edited by jimbouk
Link to comment
Share on other sites

Guest Dr Who
Hi Rick, I can see three similarities here. The Vario II part, which could be at fault if there is a problem with their ROM, the SSID 'OFF' part and the 'manual' adding of the settings.

Could you try turning your SSID broadcast to 'on' and maybe give it a new SSID temporarily? Then turn on the WLAN on the Vario and let it search for the network and then add the details at the prompts?

I am going to reconfigure the wireless here at work and see if I have any luck using a different router to the one at home, for my different wireless issue.

OK Rick, I have just got my Vario's wifi connection working properly at work. To add the connection I turned on SSID broadcast (and changed the encryption mode from AES to TKIP, obviously). I turned on the WLAN on the Vario and let it pick up the router and then followed the onscreen configuration, clicking connect to input the WPA password.

This worked perfectly, with no choosing 3G in preference and no problems with my internet connecting.

I then turned off the WLAN and changed the routers SSID broadcasting to off, and turned on the WLAN on the Vario. It picked up the wireless and worked perfectly.

So I am thinking,

1) My router at home is incompatible with my Vario, which is no biggie really since I can always use passthrough. I will post the exact model number at some point.

2) Perhaps adding the settings manually, at least on the Vario II, seems to create a wireless connection that means the 3G connection is used in preference. Be nice if you could test this theory Rick, since I am reluctant to start messing about now its all working.

Link to comment
Share on other sites

Guest rickwookie
Try resco file explorer as the inbuilt file explorer is not network-capable. I can map network drivers from all the machines on my home lan with the settings above.

The inbuilt file explorer IS network-capable:

Menu->Open Path->New Path...

\\machine_name\sahre_name\

or just \\machine_name\ to get a list of shares.

Very interesting that you can map network drives using those settings though.

Any chance you could try accessing a share using File Explorer as above?

Cheers.

Link to comment
Share on other sites

Guest jimbouk

Logically speaking, whether you set up the WLAN manually or use the auto-connect feature shouldn't make a difference.

It certainly seems that some routers are not happy with WM5 devices. I would check for a new firmware on the router - as this sort of thing is usually picked up on by the manufacturers - and also try the router in different modes (G, B, Mixed etc).

With some models, the manufacturers default "extras" such as "QOS" options, and the routers "hi-speed" (108mps) modes may also affect compatibility, so try turning all of them off and seeing if that helps.

Link to comment
Share on other sites

Guest Dr Who
Logically speaking, whether you set up the WLAN manually or use the auto-connect feature shouldn't make a difference.

I agree. However, having experienced this problem the only difference between the time when the Vario chose to use 3G in preference and when it chooses wifi in preference (as it should) was whether I put the details in by going into the the settings in Comms Manager or just letting it detect the router itself. Based on that evidence I would have to say that by adding the information manually the setup was NOT the same. It is possible that when I entered the details manually that I *may* have had PIE open, or I *may* have clicked the push mail icon, even though no exchange server is configured on my Vario, or some other weird confluence of software events may have taken place. I will be interested to see how rick gets on and see whether it works for him.

Link to comment
Share on other sites

Guest rickwookie
OK Rick, I have just got my Vario's wifi connection working properly at work. To add the connection I turned on SSID broadcast (and changed the encryption mode from AES to TKIP, obviously). I turned on the WLAN on the Vario and let it pick up the router and then followed the onscreen configuration, clicking connect to input the WPA password.

This worked perfectly, with no choosing 3G in preference and no problems with my internet connecting.

I then turned off the WLAN and changed the routers SSID broadcasting to off, and turned on the WLAN on the Vario. It picked up the wireless and worked perfectly.

So I am thinking,

1) My router at home is incompatible with my Vario, which is no biggie really since I can always use passthrough. I will post the exact model number at some point.

2) Perhaps adding the settings manually, at least on the Vario II, seems to create a wireless connection that means the 3G connection is used in preference. Be nice if you could test this theory Rick, since I am reluctant to start messing about now its all working.

What do you have set under 'Start->Settings->Connections->Network Card on the Network adapters tab where it says 'My network card connects to:'

I think that this setting becomes the default for any new connection, so I'd be interested also to see what setting you have on the Wireless tab if you click on your new work connection and then look at its 'Connects to:' setting. If it's 'The Internet', then I would expect all browsing to work through WiFi in PIE without any problems.

I connected at the office by letting the device detect the Network itself and at home I created it manually. I'm having the same issue at both locations. For me, I have the setting 'Connects to:' = 'Work', but I don't see how I can access anything on my LAN otherwise.

@jimbouk are you sure yours is set to 'Connects to:' 'The Internet' and yet you can still access your lan???

Edited by rickwookie
Link to comment
Share on other sites

Guest Dr Who
What do you have set under 'Start->Settings->Connections->Network Card on the Network adapters tab where it says 'My network card connects to:'

I think that this setting becomes the default for any new connection, so I'd be interested also to see what setting you have on the Wireless tab if you click on your new work connection and then look at its 'Connects to:' setting. If it's 'The Internet', then I would expect all browsing to work through WiFi in PIE without any problems.

I connected at the office by letting the device detect the Network itself and at home I created it manually. I'm having the same issue at both locations. For me, I have the setting 'Connects to:' = 'Work', but I don't see how I can access anything on my LAN otherwise.

@jimbouk are you sure yours is set to 'Connects to:' 'The Internet' and yet you can still access your lan???

I have had to put the work router back to AES due to a few complaints so can't check with this on at the moment.

However My Network Card connects to : Work.

However, under the wireless settings if I click on the details of the wireless router here at work it says Connects To: The Internet.

I didn't try accessing any network shares here at work. However, I am planning to change everything around in the next few days which will put all wireless connections on the same network as our desktops and I will try and browse the shares on those when I do it.

Only other thing I could suggest is try hard resetting and then letting the connection detect automatically, that seems to have cured the problem for me.

Link to comment
Share on other sites

Guest rickwookie
I have had to put the work router back to AES due to a few complaints so can't check with this on at the moment.

However My Network Card connects to : Work.

However, under the wireless settings if I click on the details of the wireless router here at work it says Connects To: The Internet.

I didn't try accessing any network shares here at work. However, I am planning to change everything around in the next few days which will put all wireless connections on the same network as our desktops and I will try and browse the shares on those when I do it.

Only other thing I could suggest is try hard resetting and then letting the connection detect automatically, that seems to have cured the problem for me.

Hmm, unfortunately if yours says Connects to: The Internet, then it's working as I would expect. If I set mine the same it PIE browses over WiFi fine too. That's doesn't let me at my LAN though.

Interesting to note that it auto set to the Internet even though you have 'My Network Card connects to : Work'. This blows out of the water my theory that this setting becomes the default, or did you maybe change this setting after the connection to your work router was created?

[Edit:] Just swapped my 'Connects to:' to 'The Internet', and left my 'My Network Card connects to :' as 'Work'. It doesn't function as you've described. Very interesting, only works if they are both set to The Internet. Going to try this auto create method again and see what happens. BTW at work I have SSID broadcast and at home I don't.

Edited by rickwookie
Link to comment
Share on other sites

Guest Dr Who
Hmm, unfortunately if yours says Connects to: The Internet, then it's working as I would expect. If I set mine the same it PIE browses over WiFi fine too. That's doesn't let me at my LAN though.

Interesting to note that it auto set to the Internet even though you have 'My Network Card connects to : Work'. This blows out of the water my theory that this setting becomes the default, or did you maybe change this setting after the connection to your work router was created?

[Edit:] Just swapped my 'Connects to:' to 'The Internet', and left my 'My Network Card connects to :' as 'Work'. It doesn't function as you've described. Very interesting, only works if they are both set to The Internet. Going to try this auto create method again and see what happens. BTW at work I have SSID broadcast and at home I don't.

Hopefully have the network share info by the end of the week.

My wifi wasn't connected at the time I checked so the Work/Interent thing might change I guess. Just checked and it is definitely set to Work with the wifi off though. I didn't edit any of the settings after connecting to the work router.

Very confusing, although I think I tried swapping the Work/Internet settings when mine wasn't working correctly previously to no avail. Even tried filling in the proxy details and the like specified by professor julie in a post linked to on the first page, which also didn't work.

Guess that the SSID on/off bit makes no difference other than having it off means you can't let the Vario find the network.

How much effort is it to hard reset your Vario at the moment?

Link to comment
Share on other sites

Guest rickwookie
Hopefully have the network share info by the end of the week.

My wifi wasn't connected at the time I checked so the Work/Interent thing might change I guess. Just checked and it is definitely set to Work with the wifi off though. I didn't edit any of the settings after connecting to the work router.

Very confusing, although I think I tried swapping the Work/Internet settings when mine wasn't working correctly previously to no avail. Even tried filling in the proxy details and the like specified by professor julie in a post linked to on the first page, which also didn't work.

Guess that the SSID on/off bit makes no difference other than having it off means you can't let the Vario find the network.

How much effort is it to hard reset your Vario at the moment?

I don't think I need to go down that drastic route yet. :D What I've found so far seems consistent with what you have.

After trying again with a auto detected network, it does PIE browse fine without trying to 3G.

Here's what I can tell.

If you have 'My Network Card connects to :' 'The Internet' or 'Work' any new connection either manually of automatically created will have 'Connects to:' 'The Internet' by default. This 'Connects to:' setting has to be set to 'The Internet' for PIE browsing to happily go through WiFi.

However:

If the connection settings were created by auto detection then PIE will browse fine over WiFi whatever the setting of 'My Network Card connects to :' (so long as 'Connects to:' 'The Internet' is set of course). If the settings were created manually using 'Add New...' then 'My Network Card connects to :' HAS to be set to 'The Internet' for PIE browsing to work over WiFi without it trying to start a GPRS/3G connection.

Now that's weired!

What I have noticed and I think Dr Who did too is that the automatically generated settings have in the last tab 'Use IEEE 802.1x network access contol' checked and greyed-out, whereas manually created settings have it un-checked and greyed-out. Either way it's greyed-out so you can't change it and there doesn't seem to be a way of 'un-greying' it. So I suppose if there are differences visable, what other difference are there between the settings that we can't see. Time to install a registry editor and see if I can find out.

Anyone know where to look in the registry for the WiFi profile settings or are they stored in a file somewhere? Also is PHM Registry Editor still the best free registry app for PPC?

I don't think anyone should have any problems if they're only interested in browsing on the Internet as whenever I've set both the aforementioned options to 'The Internet' it always works without going 3G on me. The problem is definately if one or both are set to 'Work'. @Dr Who try it again at home making sure they're both set to 'The Internet'. I just need to have the LAN access resolved but perhaps it's just not possible.

Link to comment
Share on other sites

Guest rickwookie
Rick, when you say you can't see anything on your home lan...what are you using to try to see shares etc?

Sorry jimbouk I missed this post at the bottom of the last page...

...anyway as I posted earlier:

'Start->Programs->File Explorer'

'Menu->Open Path->New Path...

\\machine_name\share_name\

or just \\machine_name\ to get a list of shares.

This works if the WiFi connection is set to Connects to: Work.

Edited by rickwookie
Link to comment
Share on other sites

Guest Dr Who
After trying again with a auto detected network, it does PIE browse fine without trying to 3G.

Here's what I can tell.

If the settings were created manually using 'Add New...' then 'My Network Card connects to :' HAS to be set to 'The Internet' for PIE browsing to work over WiFi without it trying to start a GPRS/3G connection.

Now that's weired!

I don't think anyone should have any problems if they're only interested in browsing on the Internet as whenever I've set both the aforementioned options to 'The Internet' it always works without going 3G on me.

The problem is definately if one or both are set to 'Work'. @Dr Who try it again at home making sure they're both set to 'The Internet'. I just need to have the LAN access resolved but perhaps it's just not possible.

Glad it seems to be working, although interested to see if you can get to the bottom of the network share access. It is weird that it would appear that something different is happening under the hood depending on how you add the connection. When I was having the 3G connect problem I *may* have changed some of the settings because I was just having a look through all the settings when I set up the original wifi connection. What wuldn't I give for a cancel button in some of these tabs!!!!!

No point trying at home since my router definitely seems not to like my Vario. Might just get a new router when the 'n' standard is agreed. Maybe you should put Resco Explorer on?

Link to comment
Share on other sites

Guest jimbouk

Ok - try resco. Its free - it will allow you to map shared drives etc (unless your weird network issue stops it) and it comes with a great reg editor!

Link to comment
Share on other sites

Guest rickwookie
Ok - try resco. Its free - it will allow you to map shared drives etc (unless your weird network issue stops it) and it comes with a great reg editor!

Not really 'free' though, is it?

Link to comment
Share on other sites

Guest jimbouk

It is if you are a PLUS member...

If not I am sure you can download it and use the trial to see if it will browse your lan - if not use the VN Netbrowser

Link to comment
Share on other sites

Guest rickwookie
It is if you are a PLUS member...

If not I am sure you can download it and use the trial to see if it will browse your lan - if not use the VN Netbrowser

Resco does find the shares. Hmmm...

...must mean that it's ignoring the setting 'Programs that automatically connect to a private network should connect using:' and just using whatever connection it currently has.

Just had a bit more of a play in PIE though and found that it will browse to http://192.168.1.1/ say. This is with 'My Network Card connects to :' 'Work' and an automatically created (this is the important bit it seams)WiFi profile that has 'Connects to:' 'The Internet'. This setup never worked before using a manually created WiFi profile.

Anyway, this is good, and got me thinking...

...if PIE is now happy talking to addresses on my LAN and yet 'Programs that automatically connect to the Internet should connect using:' is stile set to 'T-Mobile Internet', I thought what if I now set 'Programs that automatically connect to a private network should connect using:' also to 'T-Mobile Internet'. Will File Explorer, which seems to use this setting to tell it where to look, now be able to connect to network paths.

So I tried it. AND IT WORKED! :D

Is this the holly grail I've been searching for at last?

Just removed Resco (don't get me wrong, it's very good and it lets you launch files over the network (although picture browser wouldn't open them), but File Explorer seems a little quicker browsing network folders, and if I don't need Resco then it's more space saved on the device). Soft reset the device and all is still working as hoped!

So it really does seem as though the key thing is whether or not the WiFi profile is created automatically or manually, and that, in my mind, is definitely a bug.

Cheers all for helping, and wish me luck that it all works at home too.

Link to comment
Share on other sites

Guest Dr Who
I thought what if I now set 'Programs that automatically connect to a private network should connect using:' also to 'T-Mobile Internet'. Will File Explorer, which seems to use this setting to tell it where to look, now be able to connect to network paths.

So I tried it. AND IT WORKED! :D

So it really does seem as though the key thing is whether or not the WiFi profile is created automatically or manually, and that, in my mind, is definitely a bug.

Cheers all for helping, and wish me luck that it all works at home too.

The whole comms manager thing is WELL confusing. It bears very little relationship to a standard Windows box or smartphone interface and I just don't get this whole, connects to work, connects to internet, connects to VPN thing. Especially as very similar settings seem to be duplicated in about three places, none of which sound exactly like what you are looking for.

I too believe that adding the wifi network manually does something 'funny' under the hood, that is not transparent from the settings that are given, although this may only apply to the Vario II ROM.

Really hoping that it works for you at home too Rick, and that should prove or disprove our theory I guess, but if true I would DEFINITELY include it as a bug. Can't be the only people this affects can we?

Be nice if it is true if someone can track down exactly what is changing, if not at GUI level maybe at the registry level. That would make my brain hurt though.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.