Jump to content

►► Permanent GPS fix for Samsung i900 & i8000 Omnia ◄◄


Guest Junoman
 Share

Recommended Posts

Only thing different

- GPS program port = COM4

- GPS Hardware port = COM9 and Bud rate = 9600

Test Drive Tomorrow :(

Edited by Turtbogeit
Link to comment
Share on other sites

  • 4 weeks later...

Done everything as written in the first post, exept

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 5 (when there was put 0 garmin was crashinh everytime)

It worked just one or two times, after this it was like before ... all the time searching for satelites ;)

Then I flashed the phone part to DXIF1, and now my omnia finds satelites in 1 minute everytime, but now I have another big issue it is giving me the wrong possition - about 300 m from the correct possition!

Anybody faced the same problem and managed to fix it, how?

Link to comment
Share on other sites

i have a problem , i by mistake delete the value under

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\current driver

can anyone help me by reply by the value written here

Link to comment
Share on other sites

i have a problem , i by mistake delete the value under

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\current driver

can anyone help me by reply by the value written here

I have this (there are no numbers, but just this text): Samsung GPS Hardware

Link to comment
Share on other sites

  • 2 weeks later...

Hey Junoman,

I did all the registry editings but no signal in tom tom 7.19. I am using the i900 with OCK' M2Dv2 rom.

I use program port com 3 and com 9 rate 4800 (external GPS). My tom tom settings are NMEA 4800 com3. It says bad signal and no sattelites available. Even after 20 minutes no signal.

Do i need to change tom tom setting to inbuild receiver cause when i do that, it says no GPS.

Only thing that works is GPS proxy and i must say VERY FAST! Almost instantanelouly or after 5 second i have GPS, so the settings really work. I only can't get it to work without GPS Proxy bypass.

Any suggestions?

Link to comment
Share on other sites

Hey Junoman,

I did all the registry editings but no signal in tom tom 7.19. I am using the i900 with OCK' M2Dv2 rom.

I use program port com 3 and com 9 rate 4800 (external GPS). My tom tom settings are NMEA 4800 com3. It says bad signal and no sattelites available. Even after 20 minutes no signal.

Do i need to change tom tom setting to inbuild receiver cause when i do that, it says no GPS.

Only thing that works is GPS proxy and i must say VERY FAST! Almost instantanelouly or after 5 second i have GPS, so the settings really work. I only can't get it to work without GPS Proxy bypass.

Any suggestions?

Can you please place link here for GPS Proxy. I too am struggling with TT which has worked previously without any add-on program. I updated my rom to OCK 29005 and now I have trouble again. Note that TT did work for me with a previuos rom by OCK. It may have something to do with the phone section.

Can anyone tell me what is the latest i900 phone rom - XXHI5???

Link to comment
Share on other sites

Can you please place link here for GPS Proxy. I too am struggling with TT which has worked previously without any add-on program. I updated my rom to OCK 29005 and now I have trouble again. Note that TT did work for me with a previuos rom by OCK. It may have something to do with the phone section.

Can anyone tell me what is the latest i900 phone rom - XXHI5???

It has nothing to do with your Rom. I got it to work yesterday, it's running perfect now without add-on program.

I just played with the settings a couple of times, did some soft-resets and all of a sudden it worked perfectly.

But junomans editings really work! It just took the omnia a few hours to learn ;)

Don't give up, it will work!

Link to comment
Share on other sites

  • 3 weeks later...

All i900 users who want to have a fast fix!

I have 2 i900 phones and I really have tried almost all suggestions.

The registry change will make TomTom work but often you need to wait long for your i900 to find the sattelites.

In order to find the satellites quickly, you need to change the Phone software using Grandprix.

The best Phone software for GPS reception is version ZHIE1 or PUJA1.

This has changed everything for me.

1) Switch on the motion sensor in settings, system. (easier to edit the registry data)

2) install a registry editor like PHM reg-edit

3) Make the changes as written below

- HKEY_LOCAL_MACHINE\Software\Samsung\RIL\GPS\Accuracy set from 19 to 1

- HKEY_LOCAL_MACHINE\Software\Samsung\RIL\GPS\QOPDelay set from 12 to 1

- HKEY_LOCAL_MACHINE\Software\Samsung\RIL\GPS\RefreshRate set to 1 (default)

- HKEY_LOCAL_MACHINE\Software\Samsung\RIL\GPS\VAccuracy set from 0 to 1

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\InputBufferSize: set from 4096 to 512

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\OutputBufferSize: set from 4096 to 512

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\RetryWaitOnError: set from 1000 to 0

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\MaxBufferSize: set from 16384 to 1024

4) Go to your device's registry, and see the key HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver

5) Change the following string values to nothing (don't delete them, just edit them and clear the value):

CurrentLogFile (originally \GPSID_log.txt)

OldLogFile (originally \GPSID_log.bak)

6) Soft-reset your device

7) With File Explorer, go to My Device, and delete the two GPSID_log files you see, and the file named xtra. If you don't soft-reset, you will not be able to delete some of them.

8) Check again the registry setting. Sometimes in rare cases it may revert the settings back - but that's a general WM problem.

9) Go to Settings > System > Enhanced GPS and set both settings to "Disable"

10) external GPS settings: Programs COM3 Hardware COM9 4800 Access activated

11) Launch the phone keyboard

12) type in *#1472365#

13) go to menu go to setting and make sure GPS is on Standalone, Hot start, Navigation, press ok.

14) go to menu go to setting and make sure QOS is on 1,1,2,1,0 and press ok.

15) go to menu go to setting and make sure XTR is on Disable, Disable, Enable and press ok.

16) go to menu go to setting and make sure NMEA logging and check if both paths are empty and press ok.

17) To ensure quick GPS locking it is best to ghange the phone version using Grandprix.

I am testing 2 versions now, PUJA1 and ZHIE1 (Phone bin files)

For more info on how to do this go to this page.

http://www.samsung-omnia.org/rom-discussio...69268/#msg69268

In stead of using the loader, pda and CSC in line 7 of the above mentioned webpage only add the Phone bin file.

Make sure windows 7 has found the phone and if the samsung driver is installed for the first time wait for the found i900 phone after installing the driver before flashing.

Connect and disconnect the phone from your computer if it takes a while.

This to prevent your computer from finding the phone while flashing!

Do not use USB extension cables, they might disturb the signal.

Also make sure the phone battery is charged.

After this a cold start and a lock within 1 minute.

Maybe you have to test several com ports to find the best one for TomTom.

Good luck and remember all of the above is always at your own risk.

I did this on 2 I900 phones and it worked the first time.

Hope this helps

JP

Link to comment
Share on other sites

I install GPS fix but still not working good... Its a hardware problem... Nevermind installing those cabs... Something may occour that sky its more clear, a place litle more hight... forget aobut it its just a hardware problem...

Link to comment
Share on other sites

...

***UPDATE***

I HAVE CHANGED DOWNLOAD SETTINGS TO 0 SO NO DATA CHARGES WILL OCCUR AND BACKED UP THE RELEVANT REGISTRY KEYS AND POSTED THEM BELOW FOR FAST INSTALLATION.

I use this with spot on accuracy and immediate fix.

Here are my registry settings for gps and xtra settings in "nogarder gps"

...

This registry settings really works to me great!

Very fast lock (about 10sec) on my i8000 and very strong signal in my TomTom with internal GPS device.

But one small issue: ACCURACY :(

Even when signal is always very strong when I'm driving and take a turn...my position on screen is quite inaccurate and it take a long time to refresh right position. With my old HTC Kaiser this is very good, I would say instant.

Is this problem with settings or hardware prob?

Edited by xheretic
Link to comment
Share on other sites

  • 2 months later...
Here are some screenshots of the settings you should have in nogarder gps.

If these are not correct then edit your settings as in screen shots and reset phone and try downloading.

PS. Add http:// to the beginning of server addresses and amend download interval as required (1=every hour, 2= every 2 hours etc (Default is 168)

If it is still not sorted insert the attached application into \windows\startmenu\programs and download xtra using this app( I find it does a better job than built in version)

Hi jh787,

thanks a lot for all your posts to fix this GPS problems! I felt very frustrated with my i8000 due to the GPS delay with Tomtom until I found your posts.

Just a comment: in the CAB files that you posted on your message #95 settings are put in a way that disables the XTRA automatically, which explains why some people where reporting problems. However, once I changed settings as in this post everything seemed OK. I suggest you update post #95 mentioning the need to revise these.

I also have a question: do you use your TomTom together with GPSMod or a similar tool?

Thanks once again for your work!

Link to comment
Share on other sites

  • 1 month later...

Hi Folks, I had been following this thread for some time however I am confused. I installed the GPSMod driver 3.4.3 onto my I8000 and installed the registry setting recommended by jh787. I encountered the following problem/observations:

Firstly I must mention that my Garmin XT have much better trackig response than before using default settings and drivers.

1) GPSMod driver is automatically installed to COM2, default driver is COM7.

2) I have to goto System/GPS/Connection setting to change the program com port to COM2 (I supposed so because the GPSmod Driver is assigned to COM2). Only then can I select COM2 for Garmin XT.

3) However I did noticed I have an new option of selecting GPS Intermediate Driver (not under serial port selection in Garmin XT). There were other threads or forums that said using GPS Intermediate Driver is a better option and also Garmin tends to bounce back to default COM7 if COM2 is selected.

4) My Nogarder (*#1472365#) cannot load any satellite maps and posn info anymore, just blank screen although the menu options are still there. No body seems to mention having this problem in the threads....I wondered where went wrong. I have no issue viewing satellites on Nogarder before the GPS Mod Driver installation.

5) I don't think I noticed have the GPS Intermediate Driver in my registry before install GPS Mod Driver 3.4.3--> Can any verify if this is the case?

Can anyone advise what is the best setup (fast satellite fixing and tracking) to use Garmin XT from the above? What is the difference between GPS Intermediate driver and GPS mod Driver 3.4.3?

Thanks alot!

Link to comment
Share on other sites

Hi Folks, I had been following this thread for some time however I am confused. I installed the GPSMod driver 3.4.3 onto my I8000 and installed the registry setting recommended by jh787. I encountered the following problem/observations:

Firstly I must mention that my Garmin XT have much better trackig response than before using default settings and drivers.

1) GPSMod driver is automatically installed to COM2, default driver is COM7.

2) I have to goto System/GPS/Connection setting to change the program com port to COM2 (I supposed so because the GPSmod Driver is assigned to COM2). Only then can I select COM2 for Garmin XT.

3) However I did noticed I have an new option of selecting GPS Intermediate Driver (not under serial port selection in Garmin XT). There were other threads or forums that said using GPS Intermediate Driver is a better option and also Garmin tends to bounce back to default COM7 if COM2 is selected.

4) My Nogarder (*#1472365#) cannot load any satellite maps and posn info anymore, just blank screen although the menu options are still there. No body seems to mention having this problem in the threads....I wondered where went wrong. I have no issue viewing satellites on Nogarder before the GPS Mod Driver installation.

5) I don't think I noticed have the GPS Intermediate Driver in my registry before install GPS Mod Driver 3.4.3--> Can any verify if this is the case?

Can anyone advise what is the best setup (fast satellite fixing and tracking) to use Garmin XT from the above? What is the difference between GPS Intermediate driver and GPS mod Driver 3.4.3?

Thanks alot!

I'm sorry I sounded mis-leading. The GPS intermediate driver or GPS Mod driver 3.4.3 worked very well for me. Except for GPS Mod Driver, Garmin XT keep switching back to default COM9 for GPS. Using GPS intermediate driver is fine.

I wanted to know which is the best configure for my garmin xt. GPS intermediate driver or GPS mod driver?

Link to comment
Share on other sites

  • 4 weeks later...

Hello,

I bought i8000 ~year ago and with your help I have got also TomTom 7.910 working on it.

So I just registered to say THANK YOU.

One thing that I haven't seen mentioned in this topic is a advice for XTRA data.

I have also NoData installed as I don't have any data plan and don't want any data transfer to happen.

But still it's possible to get XTRA data updated everytime you connect to PC/ ActiveSync with USB cable (Bluetooth is a pain in the ass but it's another problem).

(My WinMo is not in English so this is guessed translation from Finnish)

Goto Settings - Network setting - GPS - XTRA

all selection should be greyish

Select Take XTRA-server in use

and also Load XTRA-data automatically

select When PC has ActiveSync-connection

as well Take SNTP-server in use

and press load XTRA-data

Under this you'll see the date to refresh

I don't even need to deselect these settings, NoData seems to do it, I just press OK and if I go to XTRA page again, "Take XTRA-server in use" is again unselected.

Very simple to do when loading e.g. photos to PC...

Best regards

JannuX

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
  • 1 month later...

Guys i confront a serious problem with GPS signal. I cant find a satellite!

So i tried this trick to fix that problem, but after that tweak i cant see any difference angry.gif

As a result the main problem with weak GPS is still remaining... sad.gif

Any help?

Edited by hersos
Link to comment
Share on other sites

  • 1 year later...

After trying so many solutions, the best one was to flash a new rom.

The phone part is JJ1 and the others I can't say now, but I think they are JG5.

After flashing, the GPS is working fine.

It's not needed to change registry keys and neither use GPS Mod.

Easy and efficient !!!

Modded GPS driver for i90X and i78X series.(not for i8000 and i9000!!!) to work with most of gps software.

-no portsplitter needed;

-tomtom fix (option)

http://forum.xda-dev...d.php?t=1330805

Edited by testando123
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.