Jump to content

ROM Building for Dummies (i900) using SYOK


Guest shokka9
 Share

Recommended Posts

Guest shokka9

have you extracted the csc? I dont that matters, but you shouldnt get error.

If you open the warnings.log file that it creates after running the scripts, it will tell you exactly what it did and didnt do.

Using those warnings, you can manually remove what you need to. Sometimes the files arent in the same place as what the kitchen is looking for. Samsung like moving stuff about :(

Link to comment
Share on other sites

Guest s0cks
have you extracted the csc? I dont that matters, but you shouldnt get error.

If you open the warnings.log file that it creates after running the scripts, it will tell you exactly what it did and didnt do.

Using those warnings, you can manually remove what you need to. Sometimes the files arent in the same place as what the kitchen is looking for. Samsung like moving stuff about :(

I extracted the CSC...

And edited like you suggest in .doc file...

But I got this warning's and some errors when I try to remove the things (when press RUN SCRIPT)...

I looked warning.log... and the warning is the same...

But, as I said, if I click RUN SCRIPT twice, the warning disappear!

Do you believe that is more interesting for me, to try to remove manually the files that I want? Like in an "old" way (PaSSoA's guide)?

Thanks!

Edited by s0cks
Link to comment
Share on other sites

Guest shokka9

Updated in first post..

Advanced guide coming to a Personal Computer near you soon.

:(

Thanks to anyone who has helped or contributed to me and the chefs (you know who you are).

B)

Link to comment
Share on other sites

Guest sector
I extracted the CSC...

And edited like you suggest in .doc file...

But I got this warning's and some errors when I try to remove the things (when press RUN SCRIPT)...

I looked warning.log... and the warning is the same...

But, as I said, if I click RUN SCRIPT twice, the warning disappear!

Do you believe that is more interesting for me, to try to remove manually the files that I want? Like in an "old" way (PaSSoA's guide)?

Thanks!

when u run the script again it overwrites the warnings.log so i dont what u get first and secondly.

better to check what u get in the first warning.log and remove manually some things that are not removed.

This happens to incorrect tasks declaration, different rom language (non-english), new roms that files are differently allocated through the directories, etc.

Link to comment
Share on other sites

Guest k3bol

hi bro

when i add the m2d auto from kitchen it Works well but the tap of settings when i press menu and press wireless network It does not work , also when i press communication and prees setting and prees wireless lan also It does not work !!!!

plzz help me

Edited by k3bol
Link to comment
Share on other sites

Guest shokka9

there are many issues with SYOK and the tasks, these are hopefully being fixed.

You need to find the cause yourself. We cannot help with a build that we know nothing about. I suggest leaving fave settings in next time and the settings tab in M2D will link to this instead (instead of Comm Manager).

Good luck

Link to comment
Share on other sites

Guest MrJoneswii
there are many issues with SYOK and the tasks, these are hopefully being fixed.

You need to find the cause yourself. We cannot help with a build that we know nothing about. I suggest leaving fave settings in next time and the settings tab in M2D will link to this instead (instead of Comm Manager).

Good luck

hey shokka, do you know a way I can test out my rom before flashing it on my omnia or releasing it to the public? I don't want to be the cause of bricked omnia's.

Is there a way to emulate the omnia on PC?

Link to comment
Share on other sites

Guest shokka9

yeah you can use microsofts emulator, but its not as easy as that.

you need to look into it...flashing is the quickest way, unless you have good knowledge of these things...

i think somebody posted what you need to do this..not sure where...use the search function or look very hard :(

Link to comment
Share on other sites

Guest pepech
yeah you can use microsofts emulator, but its not as easy as that.

you need to look into it...flashing is the quickest way, unless you have good knowledge of these things...

i think somebody posted what you need to do this..not sure where...use the search function or look very hard :(

As far as I remember , I think that Taril posted it in PassoA's thread

Edited by pepech
Link to comment
Share on other sites

Guest Smurf001

Hello All,

I'am stuck with something and can't find any solution....

I installed everything whats is on the first page....

I tryed everything what's written in the "Building_ROMs_for_Dummies__i900_.doc" I also checkt several other sites like the one PaSSoA has written....

I extract on several ways....

i've used this ROM 'i900_Dutch_XKHJ3.exe" or others get the same error.....

1: I use "i900_EXEcutor.exe" to extract the XKHJ3.exe to 7 other files...

post-497910-1237231578_thumb.jpg

Then I copy "pda.bin" to root directoy and use "ExtractROM_bin.cmd" after extracting I have 4 files

post-497910-1237231968_thumb.jpg

I read somewhere that it is possible that the XIP folder doesn't always goes into the ROM folder... so place XIP to ROM folder...

Only in the OEM folder in have 4 folder and 1 file I mis the OEM_lang_0XXX folder.... like in PaSSoA's threat....

post-497910-1237232542_thumb.jpg

after this I run "syakr.exe" to change things.... but I don't.. I only click on "run scripts" no erros....

then I drag the OS.nb to "BuildROM.cmd" then click the green button....

and get this error: "error, last status: "creating initiflashfiles.dat..." "...

post-497910-1237232900_thumb.jpg

And can't find initflashfiles.dat don't know where it is..... all files and system files are NOT hidden....

2:I drag "XKHJ3.exe" to "ExtractROM_exe.cmd" and do every thing that's written in the manual..... get the same error...

I know I'am missing something can't figure out what B)

Maby someone knows the answer...

Danny

Link to comment
Share on other sites

Guest s0cks
Hello All,

I'am stuck with something and can't find any solution....

I installed everything whats is on the first page....

I tryed everything what's written in the "Building_ROMs_for_Dummies__i900_.doc" I also checkt several other sites like the one PaSSoA has written....

I extract on several ways....

i've used this ROM 'i900_Dutch_XKHJ3.exe" or others get the same error.....

1: I use "i900_EXEcutor.exe" to extract the XKHJ3.exe to 7 other files...

post-497910-1237231578_thumb.jpg

Then I copy "pda.bin" to root directoy and use "ExtractROM_bin.cmd" after extracting I have 4 files

post-497910-1237231968_thumb.jpg

I read somewhere that it is possible that the XIP folder doesn't always goes into the ROM folder... so place XIP to ROM folder...

Only in the OEM folder in have 4 folder and 1 file I mis the OEM_lang_0XXX folder.... like in PaSSoA's threat....

post-497910-1237232542_thumb.jpg

after this I run "syakr.exe" to change things.... but I don't.. I only click on "run scripts" no erros....

then I drag the OS.nb to "BuildROM.cmd" then click the green button....

and get this error: "error, last status: "creating initiflashfiles.dat..." "...

post-497910-1237232900_thumb.jpg

And can't find initflashfiles.dat don't know where it is..... all files and system files are NOT hidden....

2:I drag "XKHJ3.exe" to "ExtractROM_exe.cmd" and do every thing that's written in the manual..... get the same error...

I know I'am missing something can't figure out what B)

Maby someone knows the answer...

Danny

Did you put some package inside OEMApps?

Link to comment
Share on other sites

Guest Smurf001

@ s0cks

I didn't change or put in the OEMApps....

I didn't change anything at all....

I only extract the "pda.bin" and then drag OS.nb" to "BuildROM.cmd" maby this is wrong....

@ sector

initflashfiles.dat is not in OEMDrivers.... I cannot find it at all.... I search the entire "omnia-eng" folder the only "initflashfiles" files I get is this:

post-497910-1237311635_thumb.jpg

I think it doesnt extract the files somehow..... B)

When I'am wrting this I tryed another ROM "i900DXIA5_BUIB1_SHK15aL.exe" with the kitchen from PaSSoA's threat....

install it on root C: extract... it but no "initflashfiles.dat"

I think somehow it doesn't extract this files... but how is this possible? noboy else has this problem :(

Have installed

.net framework 1.1 SP1

.net framework 2.0 SP2

.net framework 3.0 SP2

.net framework 3.5 SP1

MV C++ 2005 redistributable

MV C++ 2008 redistributable

lies the problem in this.... i don't know maby you do?

Danny

Link to comment
Share on other sites

Guest pepech
@ s0cks

I didn't change or put in the OEMApps....

I didn't change anything at all....

I only extract the "pda.bin" and then drag OS.nb" to "BuildROM.cmd" maby this is wrong....

@ sector

initflashfiles.dat is not in OEMDrivers.... I cannot find it at all.... I search the entire "omnia-eng" folder the only "initflashfiles" files I get is this:

post-497910-1237311635_thumb.jpg

I think it doesnt extract the files somehow..... B)

When I'am wrting this I tryed another ROM "i900DXIA5_BUIB1_SHK15aL.exe" with the kitchen from PaSSoA's threat....

install it on root C: extract... it but no "initflashfiles.dat"

I think somehow it doesn't extract this files... but how is this possible? noboy else has this problem :(

Have installed

.net framework 1.1 SP1

.net framework 2.0 SP2

.net framework 3.0 SP2

.net framework 3.5 SP1

MV C++ 2005 redistributable

MV C++ 2008 redistributable

lies the problem in this.... i don't know maby you do?

Danny

read the whole thread : YOU CANNOT COOK A COOKED ROM ( except greater chiefs here ); you have to extract a full fat ROM

Link to comment
Share on other sites

Guest Smurf001

@ pepech

So I made a mistake... with the last "cooked" ROM

overlooked that part :(

but the Dutch_XKHJ3 is official ROM or not?

I downloaded it from here

http://www.modaco.com/content/i9x0-omnia-r...read-new-dxia2/

or is this also a "cooked" ROM?

I downloaded an update from samsung.... and this one I can change....

So the ROM from the threat is cooked..... :( worries and stress for nothing... but thanks for the help.... I think I have the right ROM "DXHH3" from samsung site....

And know I can say I have made my first ROM.... YES!! FINALLY B)

know I must try it...

Danny

Link to comment
Share on other sites

Guest Smurf001

Hello,

I'am not sure this is the right threat for asking about ROM's

couldn't find the right one B)

I'am looking for an Original Dutch ROM.... the one on the samsung site XKHJ3 I cannot change it....(my latest version is XKHJ3)

by accedent I downloaded DXHH3... I change it but not Ducth language...

does anybody know where I can get a FULL Dutch ROM (that I can change)?? or a Full English ROM (that I can change)....

Danny

Edited by Smurf001
Link to comment
Share on other sites

  • 2 weeks later...
Guest s0cks

I don't know why... but if I try to use SYAKR to update the XIP version... I got stuck at Omnia logo after update.

Everything went well... the ROM build, the UPDATE process... No errors!

But the phone doesn't start... only stay at Omnia's Logo...

And, if I don't update the XIP... I got my new ROM working very well!

Can someone explain why it happens? Thanks!

Link to comment
Share on other sites

Guest pepech

When you update XIP , you have to use at least the same version of SYS , or above , and when using syakr , SYS update task is defective : you have to do it manually , as explained by Sztupy himself in the file.txt joined with SYS task : in this way , XIP/SYS update work for 20757 and 20954 , but you have to use versions of XIP provided by Stevenh http://www.modaco.com/content/i9x0-omnia-r...ports-and-more/

I hope this will help you

Edited by pepech
Link to comment
Share on other sites

Guest shokka9
Shokka...

And how about a tutorial to update a XIP/SYS version? Can you create or is this too difficult and hard-work to do?

Thanks.

It can be done easily, but at the moment, i am not really fully doing this. I am getting the SYS from other chefs already ready to use.

The XIP part is also easy, you just need xip from same or higher SYS. Need to master the 'osnbtool -c os.nb 1 xip.bin' command B) to insert xip into os.nb.

When i have more info a guide will be released, but time is precious. Stevenh was gonna do one, so was sztupy, and so i am I.

Time is always against us!

Link to comment
Share on other sites

Guest s0cks
erm.........from someone that has it??

Sorry for my noob question...

But when you are talking about SYS... are you referring to the SYS folder?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.