Jump to content

26/Jan 2.2 - MoDaCo Custom ROM for Sprint CDMA Hero (now with online kitchen)


Guest PaulOBrien
 Share

Recommended Posts

Guest jmanley

Paul,

This one too has FC and no radio support issues when I have more than XXmeg of apps installed on my apps2sd partition. I don't know what the threshold is, but it seems to be lower than the 51meg from before. I cleared down to about 45-48 meg and was still having force close and no radio, but when I completely cleared out my /data/app directory it boots up just fine (albeit missing all my apps).

Does this make sense? Is there something in the compile of Android that you did that could impose a limit on the size (meaning mb) of apps installed? maybe a pointer size, or a long integer limit, or page file size or something like that? Some switch in the make that could make it so that the OS can't address the apps if there are more than XXmb?

Link to comment
Share on other sites

Hello,

I am using the v2.1 rom, with about 25 apps installed. What is the amount of available memory that should be free when no apps are running? Using Advanced Task Killer, it tells me I have 50mb of 'available memory' with no apps running. Is this low?

My phone seems to get very sluggish, very fast.

Link to comment
Share on other sites

Guest jmanley
What format is your a2sd partition?

P

My partition on the SD card is ext3. It works just fine with 1.1... I've never run into any problem installing "unlimited" apps, I just seem to have the problem with 2.0, 2.01, and now 2.2. With 2.0/2.01 I was able to figure the limit was a hard 51mb. If I installed an app over 51mb, the phone would slow to a crawl and then if I reboot I get FC on almost all apps (not just the big ones or the new ones) and the radio doesn't work at all. If I would remove any (literally any... not just the new ones, not the big ones, not the old ones.. any) apps that took me under 51mb between /app and /app-private, the phone would boot normally and there's no problem.

Like I said, I was playing around with removing apps from 2.2 and I think I got down as far as 48mb and was still having issues, so I just did rm /data/app/*, reboot, and it came up just fine so the limit seems to be someplace between 1mb and 48mb.

I'd also like to know if somebody else can confirm this. Just push a bunch of apps to your apps2sd partition until you've got more than 45/50mb installed, reboot, and see if you all of the sudden have a problem. (do a nandroid backup first)

FYI - At first I thought maybe it was /data/boot-cache that was causing the FC's, so I did rm -r /data/boot-cache/* and rm /data/dalvik-cache/* then rebooted and I still had the same problems.

Link to comment
Share on other sites

Guest jmanley
Hello,

I am using the v2.1 rom, with about 25 apps installed. What is the amount of available memory that should be free when no apps are running? Using Advanced Task Killer, it tells me I have 50mb of 'available memory' with no apps running. Is this low?

My phone seems to get very sluggish, very fast.

on 1.1, I ran ad about 44mb free unless I opened the browser and then it would stay at about 25mb free until it finally cleaned up the browser. What I found sped up my phone significantly is to install Autostarts and clear out a bunch of the apps. For instance, you may have the SprintTV Widget installed on your phone, but you're not actually using it. According to Autostarts, the phone is still sending notifications to the SprintTV Widget to update whenever you do anything (like come out of sleep or whatever). If you disable all the "events" that you don't use, you'll notice that your phone may be TOO fast! (not really, but it sure makes a huge difference).

Link to comment
Share on other sites

Guest TyrNight

So Far so good.. its fast...

One problem.. Uptime..

Im at 50% at 3 hours and it varies... it was at 100% and I havent used it..

UPDATE:

the Uptime issue I have been experiencing is due to being plugged in to my computer.. once I unplugged it, it worked fine..

Edited by TyrNight
Link to comment
Share on other sites

Guest catpunt

thanks for this rom, using it with compcache, no awake time trouble so far... and all my apps seem to work great. not using apps2sd or sd swap partition.

Link to comment
Share on other sites

Guest LasVegas

Hey Paul!

Excited as always when a new MoDaCo ROM package comes out. I installed 2.2 and all the extras (except the Hebrew language… Don't really need that.). On startup, WaveSecure gave a FC. Shutdown and restarting caused multiple FCs!

Okay… Perhaps I have too many Apps. I do a restore back to 2.1, go through and remove the Apps I don't really need and try again. WaveSecure still FCs. When restarting, it's still only WaveSecure that fails. Hmmm…

Everything else is working great!

LasVegas

Edited by LasVegas
Link to comment
Share on other sites

Guest Neecee Babe

Helllooooooooo................

Sigh's I'm back! :)

So I have 2.0 the Madaco Rom on my phone, and i've been having this problem and its driving me CRAZY. If my phone happens to die or I turn it off and turn it back on I get a million FC's and nothing works afterwards... even a simple phone can't be made because the signal can not be found. I have to to a factory reset wipe for it to even work, then I have to reinstall my apps that i had befor and Ive done this numerous times. sighs... Does anyone know why its doing this?

Also this new update, can I just do a flash update zip to install it?

Also whats the difference between a Bart Backup and a Nandroid backup?

Edited by Neecee Babe
Link to comment
Share on other sites

Guest LasVegas
So I have 2.0 the Madaco Rom on my phone, and i've been having this problem and its driving me CRAZY. If my phone happens to die or I turn it off and turn it back on I get a million FC's and nothing works afterwards... even a simple phone can't be made because the signal can not be found. I have to to a factory reset wipe for it to even work, then I have to reinstall my apps that i had befor and Ive done this numerous times. sighs... Does anyone know why its doing this?

In a nutshell, delete a few apps that you don't really need and reboot. Until we get past 1.5, this is going to be an issue.

Also this new update, can I just do a flash update zip to install it?

Yep. You shouldn't need to wipe if you have a previous version of MDC ROM.

Also whats the difference between a Bart Backup and a Nandroid backup?

Do a Bart Backup if your SDCard is partitioned for app2sd. Use Nandroid if it's not.

LasVegas

Link to comment
Share on other sites

Guest Neecee Babe
In a nutshell, delete a few apps that you don't really need and reboot. Until we get past 1.5, this is going to be an issue.

Yep. You shouldn't need to wipe if you have a previous version of MDC ROM.

Do a Bart Backup if your SDCard is partitioned for app2sd. Use Nandroid if it's not.

LasVegas

TY so much... I'll let you know what happenns....

Link to comment
Share on other sites

Guest Neecee Babe
See this post (just 2 above your original post)

I've experienced those FC's but I've realized if you install it then uninstall it and reinstall it. it doesn't FC, Tedious but it Works for me lolol

BTW this update is sooo much Faster... I do get what that person said the update makes it unrealistic fast, its hard to move icons around on Home because the phone is so fast no9w.... Thnks thou! :)

Link to comment
Share on other sites

Guest jmanley

I've noticed that apps aren't closing after being idle.

I'm running 2.2 from the kitchen with compcache installed, enabled, and running at the default size.

Could this be a situation with the new kernel? the new build? or compcache?

I just went into estrongs and found that every program I'd run since my last boot last night was still listed as running (albeit idle or empty) and taking up memory.

Link to comment
Share on other sites

Guest reddick

just want to give a heads up.The new kernel runs smooth.But i noticed that a couple of google app dont work properly ex: voice search and google voice.I get the force close when i run the app.I did everything to clear and tried to get it to work.So i reverted back to old version, and it works well.not sure what he kernel has to do with it....but i may have to revert back to old kernel for now...

Link to comment
Share on other sites

Guest TheCodeMonk

Works great and definitely much faster...however, my voicemail is just a yellow "!" now though and no text to identify it (it still works, just no icon or text in the menu)

Also, the SuperUser permissions app doesn't appear to be working.

This is on a fresh install (RUU->Modaco).

EDIT:

Ignore the SuperUser permissions app issue...my nubness at forgetting to turn on usb debugging.

EDIT2:

Screenshot attached, lower right corner is supposed to be the voicemail app (clicking it still brings it up, as mentioned...the app is functional, just the icon doesn't appear to be working)

post-608085-1264714709_thumb.png

Edited by TheCodeMonk
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.