Jump to content

How to unlock the bootloader on your Nexus One


Guest PaulOBrien
 Share

Recommended Posts

Guest DanH48
In which case my SPL would probably be useful since its definitely a regular retail Nexus One, not a dev phone or holiday phone.

Need to find out how to dump this....

Edited by DanH48
Link to comment
Share on other sites

  • 3 weeks later...
Guest joeyweaver

I'm new to this but just tried to unlock my bootloader. I get this message:

< waiting for device >

... INFOErasing userdata...

ERROR: usb_read failed with status e00002ed

FAILED (status read failed (No such file or directory))

The unlock shows when I reboot my phone, but did the unlock actually go through? Any ideas on what I can do to fix it if it didn't work?

Thanks!

Link to comment
Share on other sites

  • 2 weeks later...
Guest Papa_I

For everyone that is having "waiting for device" issues, try this.

-On your phone, click Settings > Applications > Development and make sure USB Debugging is on.

-Plug your phone into your computer via USB cable (it needs to be on). It should say installing drivers if using Windows.

After that, windows should install the correct drivers from the sdk and than you can turn your phone off and boot into fastboot and follow the instructions from the first post. This worked for me. Thanks.

Link to comment
Share on other sites

  • 2 weeks later...
Guest aryoxp

Hi Paul,

In my case, extracting fastboot to C:\fastboot\, copying "adb.exe", "AdbWinApi.dll" and "ddms.bat" to the fastboot folder and running:

C:\fastboot>fastboot-windows.exe oem unlock

give me the following message and the program just stop in there.

< waiting for device >

I already updated the USB driver for Windows to the latest version (USB Driver for Windows, revision 3)

This is what I had done to unlock the bootloader

- Entering bootloader mode on the handset

- Connect the handset to the computer by using USB cable and make sure it was connected (identified) by the computer

- Copy fastboot-windows.exe from the fastboot.zip file to directory tools\ of Android SDK installatation directory. In my case:

C:\android-sdk-windows\tools

- Open the command prompt and change the directory to tools\

- Execute the "fastboot-windows.exe oem unlock" from there

- Voila! the bootloader unlocking screen appear

- Confirm the bootloader unlocking, and my handset restart and reset to "factory setting"

PS:

Actually when I executed the fastboot-windows.exe oem unlock command, the following message appear:

C:\android-sdk-windows\tools>fastboot-windows.exe oem unlock

... INFOErasing userdata...

FAILED (status read failed (Too many links))

Well, I don't know whether it was successfully unlocked or not, but I had successfully installed superboot after this anyway.

My handset is Google Nexus One, updated to Froyo FRF91 OTA

Edited by Paul
Link to comment
Share on other sites

  • 1 month later...
Guest hedwards

I think there may have been a typo in the original instructions. I was having trouble with fastboot waiting, and as far as I can tell the list of files to include was wrong. I had to add AdbWinUsbApi.dll to the fastboot directory in order to get my device detected. I'm not sure if you need to also have AdbWinApi.dll, but I left it in there just in case. I had it work first shot after that.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 9 months later...
  • 4 months later...

Hey Paul,

From everyone's response this seems like a real simple process but i seem to be having so much trouble with it. whenever i try to run the 'fastboot-windows oem unlock' in the command prompt i get 'INFO [ERR] Command error !!! OKAY' i attached a screenshot of my desktop with each of the folders open, please help me out it'll be greatly appreciated!

EDIT: I just read one of the comments below where he dragged the AdnWinUsbApi.dll file and it worked for him. when i did that and tried running the oem unlock command i got 'FAILED <status read failed <Too many links>>'

HTC Desire Z

Android 2.3.3

HTC Sense 2.1

post-942966-0-71985600-1320863737_thumb.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.