Jump to content

CyanogenMod for HTC Hero (GSM) v1.0 (now with online kitchen)


Guest jnwhiteh

Recommended Posts

another thing just notice, is when taking a photo, the preview comes up all corrupted, didn't see anything in the known issues section. I guess its a similar thing to the gallery issue?

snap20100205_114028.png

Link to post
Share on other sites
Guest jnwhiteh

No, I don't have modules compiled for this kernel.

another thing just notice, is when taking a photo, the preview comes up all corrupted, didn't see anything in the known issues section. I guess its a similar thing to the gallery issue?

Yes, the camera is borked in all of these ROMS, it's one of my biggest pet peeves =/ Not because I need the functionality, but because it bothers me on some fundamental level not having it work =)

Edited by jnwhiteh
Link to post
Share on other sites
Guest jnwhiteh
if you put the update.zip over the installation it works, maybe you can just add it to your zip

Oh, you're quite right. I didn't see the versions for the kernel we're using, but I see them now. I'll toss them in the next release.

Link to post
Share on other sites
Guest Bantumi

Thanks for your hard work on the other AOSP rom and on getting this working for the hero jnwhiteh. Will be downloading this once i get home and flashing it ;)

From reading the posts (and i know this probably isn't going to happen) i would love it if somehow you managed to have "Vibrate" as the last "notch" when turning down the volume, and if the "Home, then Sleep" worked from Spare Parts (though this hasn't worked in any eclair roms, tried benhaams,lox's,yours).

One point about the lag... any users experiencing it should make sure they check spare parts and set their window transitions to "Fast" or "Off". I used these settings in MCR and AOSP felt laggy at first until I realised that it was these settings :D

Will break things and report back at some point lol

Link to post
Share on other sites

Can you add this to apns_conf.xml, it will make all the carriers using telenors network in Denmark work

<apn carrier="telenor"

		mcc="238"

		mnc="02"

		apn="internet"

		user=""

		server=""

		password=""

		mmsc=""

		type="default"

	/>

	<apn carrier="telenor MMS"

		mcc="238"

		mnc="02"

		apn="telenor"

		user="telenor"

		server=""

		password="telenor"

		mmsc="http://mms.telenor.dk"

		mmsproxy="212.88.64.8"

		mmsport="9201"

		type="mms"

	/>

It seems it is a lot of the APN's in scandinavia not working.

I have problems with Telia. However it works with manual set up.

This is some of the APN's in Sweden. (It's the one's I have info on anyway.)

Please add them if possible.

and thank you for the great ROM =)

Tre

Name: Tre

APN: data.tre.se

Proxy: <Empty>

Port: <Empty>

MMSC: "http://mms.tre.se"

MMS Proxy: mmsproxy.tre.se

MMS Port: 8799

MCC: 240

MNC: 02

APN type: <Empty> (galaxy: internet + mms)

Tele2

Name: Tele2

APN: internet.tele2.se

Proxy: <Empty>

Port: <Empty>

MMSC: "http://mmsc.tele2.se"

MMS proxy: 130.244.202.030

MMS port: 8080

MCC: 240

MNC: 07

APN type: <Empty> (galaxy: internet + mms)

Telenor

APN 1:

Name: Telenor Data

APN: internet.telenor.se

MCC: 240

MNC: 08

APN type: default (galaxy: internet)

APN 2:

Name: Telenor MMS

APN: services.telenor.se

MMSC: "http://mms"

MMS Proxy: 172.30.253.241

MMS Port: 8799

MCC: 240

MNC: 08

APN type: mms

IF MMS is not working on port 8799 port 8080 or 9201 might work.

Telia

APN 1:

Name: Telia online

APN: online.telia.se

Proxy: 10.254.254.254

Port: 8080

MCC: 240

MNC: 01

APN type: default (galaxy: internet)

APN 2:

Name: Telia MMS

APN: mms.telia.se

Username: mms

Password: telia

MMSC: "http://mmss/"

MMS Proxy: 193.209.134.132

MMS Port: 8080

MCC: 240

MNC: 01

APN type: mms

Halebop

APN 1:

Name: Halebop Online

APN: halebop.telia.se

Port: 8080

Proxy: 10.254.254.254

MCC: 240

MNC: 01

APN type: default (galaxy: internet)

APN 2:

Name: Halebop MMS

APN: mms.telia.se

Username: mms

Password: telia

MMSC: "http://mmss/"

MMS Proxy: 193.209.134.132

MMS Port: 8080

MCC: 240

MNC: 01

APN type: mms

Link to post
Share on other sites
Guest jnwhiteh

It seems it is a lot of the APN's in scandinavia not working.

I have problems with Telia. However it works with manual set up.

This is some of the APN's in Sweden. (It's the one's I have info on anyway.)

Please add them if possible.

It would save me quite a bit of time and effort if these are put into the correct format, and posted and aggregated on the cyanogen APN list: http://www.google.co.uk/search?sourceid=ch...anogen+apn+list

Once you've posted there in the correct format (I've done this for telenor dk), I will add them to the apns_conf.xml file. However, you have to be careful considering your 'Tre' is the same as the '3mms' that's already in the file and it definitely can't be called 'Tre', considering it's an MMS APN. It would need to be 'Tre MMS' or such. Let me know once you've got it all worked out!

Edited by jnwhiteh
Link to post
Share on other sites
It would save me quite a bit of time and effort if these are put into the correct format, and posted and aggregated on the cyanogen APN list: http://www.google.co.uk/search?sourceid=ch...anogen+apn+list

Once you've posted there in the correct format (I've done this for telenor dk), I will add them to the apns_conf.xml file. However, you have to be careful considering your 'Tre' is the same as the '3mms' that's already in the file and it definitely can't be called 'Tre', considering it's an MMS APN. It would need to be 'Tre MMS' or such. Let me know once you've got it all worked out!

Ok, will do..

I will also try to get a few more APN's verified since I know this is an issue.

Link to post
Share on other sites
Guest commodoor
I appreciate that you consider it to be slow, but your experiences are not the majority. Most people who try the ROM agree that it is very snappy and very responsive for most tasks. Of course I will continue to try and improve the speed as best I can, but there it is.

Don't get me wrong i liked your roms and your other roms are much better (they are fast, no lag). ok i know you don't have the source, but who is doing the tweaks for hero? are you the only one that is trying or do you get help from cynagon?

Link to post
Share on other sites
Guest jnwhiteh
Don't get me wrong i liked your roms and your other roms are much better (they are fast, no lag). ok i know you don't have the source, but who is doing the tweaks for hero? are you the only one that is trying or do you get help from cynagon?

Lox, Kiall and myself work on improving things on Hero.. but we're in a bit of a tough place right now as we're using old leaked versions of libraries from HTC rather than the actual versions they'll have in their own 2.X ROM. There's not much 'tweakign' we can do at the moment. Cyanogen has nothing to do with Hero.

Link to post
Share on other sites

about the "lagging" ppl are complaining, just for an example, if you use stock hero rom, and you switch to classic android 1.5 launcher, it doesn't run smooth as rosie....

but if i can i would add that if the old launcher doesn't require a stronger hw (which would be unreasonable) there is probably some driver/kernel problem which could be causing this "jerkyness" when we are swiping over home screens, it almost feels like some ghosting effect that you can see on old LCD monitors

ofc feel free to chit chat about this thing, because i cant proof anything, its just my observation

Edited by cTn
Link to post
Share on other sites
Guest jnwhiteh
about the "lagging" ppl are complaining, just for an example, if you use stock hero rom, and you switch to classic android 1.5 launcher, it doesn't run smooth as rosie....

but if i can i would add that if the old launcher doesn't require a stronger hw (which would be unreasonable) there is probably some driver/kernel which could be causing this "jerkyness" when we are swiping over home screens, it almost feels like some ghosting effect that you can see on old LCD monitors

ofc feel free to chit chat about this thing, because i cant proof anything, its just my observation

Can anyone video/youtube the 'lag' when switching home screens? I've really honestly never experienced this and I'd love to see what you're talking about so I can better understand it!

Link to post
Share on other sites
Can anyone video/youtube the 'lag' when switching home screens? I've really honestly never experienced this and I'd love to see what you're talking about so I can better understand it!

i see this lags too, but i think recording it could be difficult because the camera sometimes tooks only 30 frames per second and my eyes sees around 60 frames, when the lag is in between the fps of the camera it could be impossible to record it.

I don't know if it's really lagging but it's not a smooth scrolling from left to the right.

Overall it's much faster with MCR but i think MCR is much more speed optimized.

When replacing the Homescreen for example with "Slide Screen" there is more lag in scrolling then replacing the homescreen on MCR with slidescreen, so i don't think it's a homescreen issue more or less something in the performance but i don't know if it solvable

even technically everything should look ok on benchmarks but it's the same like with SLI GPU's on a computer there are microlags which only a human can see sometimes.

just my 2 cent ;)

Link to post
Share on other sites
Can anyone video/youtube the 'lag' when switching home screens? I've really honestly never experienced this and I'd love to see what you're talking about so I can better understand it!

i would really like to give u a peak, also a comparison about "smooth swiping" that i was talking in my previous post, but i honestly don't have a suitable camera to capture this ;) ill wait a while if someone can post it, if not ill try to do my best, but with camera in nokia 6120c or 1.3mp webcam from my laptop wouldn't give you any helpful inside about this, slow "blurry" cams are really NO go to capture this problem

Link to post
Share on other sites
Guest bigtunes

Noticed another minor issue: The little headphone symbol doesn't appear when plugging in the headphones. Audio still goes through them though.

Anyone else get an email from the Android team thanking them for their purchase of a Nexus?

Link to post
Share on other sites
Guest jnwhiteh
Noticed another minor issue: The little headphone symbol doesn't appear when plugging in the headphones. Audio still goes through them though.

Anyone else get an email from the Android team thanking them for their purchase of a Nexus?

I don't know where the headphone symbol comes from, but I'll look for it.

Link to post
Share on other sites
Guest mkolonko

htc implemented a different kind of animation when switching screens.

i would say its much more refined then the one we see in all the aosp roms. the animation in rosie runs smoother, not so fast and it has a little snap back on the end.

also it matters how you slide with your finger over the screen and when you let go. try different ways of sliding, and see how the animation differs!

also try this: go to your right/left most screen and press the home button. then the screen animates back to center/homescreen. is this animation laggy?

Link to post
Share on other sites
Guest Blackfish
i would say its much more refined then the one we see in all the aosp roms. the animation in rosie runs smoother, not so fast and it has a little snap back on the end.

Also the normal homescreen runs smoother...but i think that is something that only Google can fix because the Nexus One has the same problem...so maybe it is a problem of Android 2.0 - 2.1...

I will take a Video at home today...i hope the Canon 7D is fast enough...

Link to post
Share on other sites
Guest mkolonko
but i think that is something that only Google can fix

i don't think google will fix that.

its like jnwhiteh said: he couldn't even notice a lag. maybe i'm wrong, but i think its hard for a developer to see the point in this. this is sad, because people DO notice flaws like that.

;) just my 2 cents...

Link to post
Share on other sites

I do think at times the phone/UI is slow to respond, but i experienced this in MCR too, it don't really bother me. I seem to the notice the lag if i have a picture as my wallpaper, if i have a pattern I don't notice it.

Link to post
Share on other sites
Yes, the camera is borked in all of these ROMS, it's one of my biggest pet peeves =/ Not because I need the functionality, but because it bothers me on some fundamental level not having it work =)

I know what you mean, your not on your own, Its not a big deal for me - it still takes a picture.

Link to post
Share on other sites
Guest Stea1thmode

The battery life on this is amazing, full charge since 8am, email and twitter undate by the hour, gsync enabled, and two 20 sec phone conversations. 92% battery remaining.

Jnwhiteh, the LED continues to flash forever after a message/email notification, is there any way you could look into this?

Thanks

Link to post
Share on other sites
Guest Incomer

working for a day now with this rom, love it :D!!

no fc yet:P, 1 soft reboot(when i was browsing, can't make it do it again...(same page is loading now without reboot))

so it is my daily use rom @ the moment ;)

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.