Jump to content

Android 2.2 Development


Guest eckengucker1

Recommended Posts

Guest DanWilson
Have you changed the device identifiers in configuration of udev rules? Because the device identifiers changed between 1.5 and 2.1

I didn't do that last time... :huh: So how do I do that?

Link to post
Share on other sites
Guest starkos
Will it?

DO WANT!

But I need to get fastboot working first... Anyone help?

It's stuck on <waiting for device> I'm on Ubuntu 10.04, and it worked before (using fastboot-linux from Paul's AMON-RA zip)

I just don't know what to do... :huh:

May not be your problem but worth a try anyway, before doing the fastboot command in the Terminal type sudo su & then enter your password. When I forget to do this in Ubuntu I get the waiting for device hang, but could be something else for u...?

Link to post
Share on other sites
Guest DanWilson
May not be your problem but worth a try anyway, before doing the fastboot command in the Terminal type sudo su & then enter your password. When I forget to do this in Ubuntu I get the waiting for device hang, but could be something else for u...?

Worked! Thanks dawg, I'll need to drill this into my head! Now wheres that FroYo ROM?

Link to post
Share on other sites

I've got 3G data working as well now. I'm not sure if I like the solution, but it works (and is very simple).

chmod 6751 /system/bin/netcfg

That should do it. It should work in any rom that had ril working.

Could someone post the output of ls -l /system/bin/netcfg on a 2.1 rom.

I've just done a clean build that should have wifi fixed. I'll do a quick test, then upload it.

Link to post
Share on other sites
Guest flip360

"-rwxr-sr-x 1 0 3003 5640 Aug 2008 /system/bin/netcfg"

thats mine on FLB 1.5, dunno about the numbers, maybe the first one is a ten (10) ;)

p.s. is the automount option inserted into the ROM? really like to test this one :huh:

Thanks Tom G

Edited by flip360
Link to post
Share on other sites
Guest xupamki
"-rwxr-sr-x 1 0 3003 5640 Aug 2008 /system/bin/netcfg"

thats mine on FLB 1.5, dunno about the numbers, maybe the first one is a ten (10) ;)

p.s. is the automount option inserted into the ROM? really like to test this one :huh:

Thanks Tom G

TMN A1 2.1

-rwxr-sr-x root inet 5640 2010-06-30 10:05 netcfg

HTH

Link to post
Share on other sites

Thanks. That was what I expected.

p.s. is the automount option inserted into the ROM? really like to test this one :huh:

Do you mean is the sd card mount issue fixed? No. I haven't found the real cause for it yet.

Edited by Tom G
Link to post
Share on other sites

Froyo ROM 0.40

Changes

-----------

Fixed GPS

Fixed Wifi

Maybe fixed the Network unlock message (I don't get the message so can't test it)

Known Bugs

--------------

SD card doesn't mount correctly if multiple partitions

3G data doesn't work. See my previous post about chmod of netcfg to fix. I will look at including the fix in the next rom.

Wifi has some bugs (signal strength and link speed are reported incorrectly). These can probably be fixed by using wpa_supplicant for a 2.1 rom (I haven't tested). I will look at using a modified wext driver that implements these features correctly at some time.

Network selection doesn't work.

Not yet implemented

------------------------

Lights

Camera

Sensors (It looks like some of these may be shared with the HTC Passion, so a modified Passion driver might work).

I'm sure I've forgotten a lot.

Link: Froyo-Pulse-0.40

Let me know what problems you find :huh:

Edited by Tom G
Link to post
Share on other sites
Guest totiadrenalin
Froyo ROM 0.40

Changes

-----------

Fixed GPS

Fixed Wifi

Maybe fixed the Network unlock message (I don't get the message so can't test it)

Known Bugs

--------------

SD card doesn't mount correctly if multiple partitions

You can always mount the sdcard manually.

Or u can use this and flash your phone via recovery mode with this.

in the terminal type:

su

mountsd

mountext2

And you will have your FAT and EXT2-3 partitions mounted

But it won't mount during boot

Mount_SDCARD_EXT2_signed.zip

Edited by totiadrenalin
Link to post
Share on other sites
Guest xupamki

I've tested it.

WIFI and GPS working properly.

Calls OK.

No more Network unlock PIN. :huh:

I couldn't setup a google account to sync my contacts. No google apps...

It's pretty stable.

Good work.

Reverting back, because I really need the google account.

Link to post
Share on other sites
Guest Holograph
I've tested it.

WIFI and GPS working properly.

Calls OK.

No more Network unlock PIN. :huh:

I couldn't setup a google account to sync my contacts. No google apps...

It's pretty stable.

Good work.

Reverting back, because I really need the google account.

What about the RAM usage?

Link to post
Share on other sites
Guest totiadrenalin
You can always mount the sdcard manually.

Or u can use this and flash your phone via recovery mode with this.

in the terminal type:

su

mountsd

mountext2

And you will have your FAT and EXT2-3 partitions mounted

But it won't mount during boot

Look in init.sd

In froyo the sdcard first is mounted in /mnt and then symlinked to /sdcard

Link to post
Share on other sites
Guest Cazomino05
Froyo ROM 0.40

Changes

-----------

Fixed GPS

Fixed Wifi

Maybe fixed the Network unlock message (I don't get the message so can't test it)

Known Bugs

--------------

SD card doesn't mount correctly if multiple partitions

3G data doesn't work. See my previous post about chmod of netcfg to fix. I will look at including the fix in the next rom.

Wifi has some bugs (signal strength and link speed are reported incorrectly). These can probably be fixed by using wpa_supplicant for a 2.1 rom (I haven't tested). I will look at using a modified wext driver that implements these features correctly at some time.

Not yet implemented

------------------------

Lights

Camera

Sensors (It looks like some of these may be shared with the HTC Passion, so a modified Passion driver might work).

I'm sure I've forgotten a lot.

Link: Froyo-Pulse-0.40

Let me know what problems you find :huh:

I've been watching this thread pretty eagerly for a while now and I'd like to say good job

I can't test this because I need my phone at the moment so I can't install a new ROM which is annoying because I'm on the UK 2.1 which isn't receiving texts but I can't wait to try this

hopefully I'll play with my mates desire for a few minutes if I see him soon and see what it's like ;)

Link to post
Share on other sites

Yiiiiiiiiiiiiiiip!!!!!!!!!!!!!!!!!

Works with 3g, WiFi, GoogleApps works, gooood!

Edit:

A new issue: Market works, but doesn't find lots of things. It would be nice to check the ROM fingerprint.

Edited by gusthy
Link to post
Share on other sites
Guest Epic-Emodude
I've tested it.

WIFI and GPS working properly.

Calls OK.

No more Network unlock PIN. :huh:

I couldn't setup a google account to sync my contacts. No google apps...

It's pretty stable.

Good work.

Reverting back, because I really need the google account.

Somewhere on the forums (I think in the FLB-mod post, there is a flashable zip for google apps

Link to post
Share on other sites
Guest Simon O
Wow, this is super charged! I'm loving it, now we have some kind of data, we can test it a load more :huh:

I agree with that. I've just installed the gapps and done the net_cfg fix. Rebooting now. Hope it works ;)

Update: 3G works. First boot I've got the setup app :(

Edited by flibblesan
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.