Jump to content

Hardware hacking this puppy, input?


Recommended Posts

Guest Spike8585
Dunno... I think it works quite ok, spike used it, seems to work, but he's having troubles with his new external µSD...

Hey, Yes, it works perfectly.

I was having trouble with my external card, but that was not because on the mod.

It was a new card, and I formatted it in windows, and I am not sure what went wrong.

It was a new card, and my old card still worked in there.

I remembered that when I put my old card in my camera to try to use it as a reader, the camera F'd up my card, and the streak read it as 'Damaged'.

So I threw my new card in the camera, and lucky it screwed it up, so the streak recognized it as damaged and prompted me to format.

All is good now!

The perfmod works too. 2512 in Quadrant.

Link to post
Share on other sites
Guest kwenteen
Could we please get a boot.img for Steves new 1.7?

thanks.

here it is, haven't tried it yet, as for the 161, remember to wisely choose your option, so it doesn't replace the original boot.img with another one that I haven't patched !

boot170.img

installation process : like usual, just rename the file boot170.img in boot.img, and put it on the root of the 170 archive !

else, you can just flash it with flashboot !

boujou bien,

K.

Link to post
Share on other sites
Guest Spike8585
here it is, haven't tried it yet, as for the 161, remember to wisely choose your option, so it doesn't replace the original boot.img with another one that I haven't patched !

boot170.img

installation process : like usual, just rename the file boot170.img in boot.img, and put it on the root of the 170 archive !

else, you can just flash it with flashboot !

boujou bien,

K.

Thank you!!!!

I will post my results.

Link to post
Share on other sites
  • 2 weeks later...

Hi!

Tried kwenteen's boot170.img and it works well. Thanks!

However I have a problem. I bought a Streak with a defect external SD card reader.

So I would like to mount a innersd partion as sdcard. Mounting the partition as vfat (formated as fat32) works fine manually, but will not show up as memory in system information and most programs will not find it (filebrowsers and media players work). After searching around I thought I had a solution. This is what I did:

# mount -t vfat /dev/block/innersd0p2 /mnt/sdcard

# mount -o bind /mnt/sdcard /sdcard

# chmod 777 /sdcard

# setprop EXTERNAL_STORAGE_STATE mounted

# am broadcast -a android.intent.action.MEDIA_MOUNTED --ez read-only false -d file:///sdcard

But its a no go. Probably need to add the setprop to init.rc? How did you edit the init.rc? Searched around but only found half solutions. Any pointers?

Thanks again!

Additional info in case anyone else have the same setup, my install procedure went like this:

Installed StreakMod recovery through fastboot, rebooted into recovery and connected through ADB.

Mounted the data partition and pushed StreakDroid 1.7.0 to /data. Pushed image_flash to /system/bin and flashed StreakDroid1.7.0. Rebooted to test installation.

Rebooted into fastboot and flashed kwenteen's boot170.img. Rebooted once more to see that it worked.

Turned of the Streak and opened it up and removed internal SD.

Cloned the SD by:

dd if=/dev/sdb of=innersd.img

Then I transfered the image to a 16GB Sandisk class 10 SD by:

dd if=innersd.img of=/dev/sdb

Added a fat32 partition as partition 2 with fdisk and formated it.

Put the card in the internal SD slot and the Streak booted fine.

The partition can be mounted manually, but will not show up as memory in system information.

Link to post
Share on other sites
Guest kwenteen
Hi!

Tried kwenteen's boot170.img and it works well. Thanks!

However I have a problem. I bought a Streak with a defect external SD card reader.

So I would like to mount a innersd partion as sdcard. Mounting the partition as vfat (formated as fat32) works fine manually, but will not show up as memory in system information and most programs will not find it (filebrowsers and media players work). After searching around I thought I had a solution. This is what I did:

# mount -t vfat /dev/block/innersd0p2 /mnt/sdcard

# mount -o bind /mnt/sdcard /sdcard

# chmod 777 /sdcard

# setprop EXTERNAL_STORAGE_STATE mounted

# am broadcast -a android.intent.action.MEDIA_MOUNTED --ez read-only false -d file:///sdcard

But its a no go. Probably need to add the setprop to init.rc? How did you edit the init.rc? Searched around but only found half solutions. Any pointers?

Thanks again!

Additional info in case anyone else have the same setup, my install procedure went like this:

Installed StreakMod recovery through fastboot, rebooted into recovery and connected through ADB.

Mounted the data partition and pushed StreakDroid 1.7.0 to /data. Pushed image_flash to /system/bin and flashed StreakDroid1.7.0. Rebooted to test installation.

Rebooted into fastboot and flashed kwenteen's boot170.img. Rebooted once more to see that it worked.

Turned of the Streak and opened it up and removed internal SD.

Cloned the SD by:

dd if=/dev/sdb of=innersd.img

Then I transfered the image to a 16GB Sandisk class 10 SD by:

dd if=innersd.img of=/dev/sdb

Added a fat32 partition as partition 2 with fdisk and formated it.

Put the card in the internal SD slot and the Streak booted fine.

The partition can be mounted manually, but will not show up as memory in system information.

Hello !

with the boot.img you installed, you already have the extra space of the innersd that should automatically mount on /intsd (but it should be formated in ext3, not fat32...). so basically, if your external sd doesn't work, you could only bind -o the /intsd to /sdcard...

and try the command :

pm enable com.android.providers.media/com.android.providers.media.MediaScannerReceiver

in sudo mode, it should then rescan the media files, hence find the media located in /intsd !

good luck !

Link to post
Share on other sites
Guest kwenteen

And before anyone ask, here is the boot.img for the 180 djsteve update !

and for your information, yes it works, just went from 161 to 180 without any trouble !

nice fonts btw, love them !

boot.img

proceed as usual !

boujou bien !

K.

Edited by kwenteen
Link to post
Share on other sites
Guest manicsloth

I have had to swap out my internal sd on my streak and currently use a class 2 4gb sandisk (It was the only thing I had lying around and I needed to fix it fast...). To make it work I followed an extremely simple process:

1. Insert card into internal slot

2. Factory reset form dell screen, give it 10 mins to complete the partitioning on boot. Obviosly will not load anything as no os yet.

3. Use QDL tool to install 2.2

Then went on to install steve's latest rom in the normal way. This worked fine and I had 3.something gb available for programs and everything worked great. Market would install etc etc.

However this is not always the case, I have re-installed on a number of occasions, using qdltool to revert back from a screwed rom. On some of these occasions I cannot install anything as it tells me there is no space available. So I would say, if all you are doing is swapping out to a 4gb then try this and it should work for you, you may need to do it twice before it works but that's less complex than some of the other suggestions and easier for those of us without linux.

Having reinstalled from a screwed 1.8 install this morning I cannot install, I'm going to reinstall to solve the issue. If there is anyone who wants me to test anything on the current and then working installs that might help pinpoint what's happening then let me know what you want me to test. I'll leave it 24 hours before I do it so you have time to reply.

P.S I tested the above method on an 8gb and 16gb card and it would not boot.

Edited by manicsloth
Link to post
Share on other sites
Guest kwenteen
P.S I tested the above method on an 8gb and 16gb card and it would not boot.

So we could assume that it works as long as it remains under normal sd specification, not SDHC, if 4GB is the limit !

thanks for having tried this !

:huh:

Link to post
Share on other sites
Guest over2land
Is the boot.img for 1.8 the same as 1.8.1?

I've been running it on mine with 1.8.1 for a couple days now with no un-toward problems.

6Gb class 4 internal

Link to post
Share on other sites
Guest Djp42
I've been running it on mine with 1.8.1 for a couple days now with no un-toward problems.

6Gb class 4 internal

How? If you've used Stephen Davisons tut on page 5 would you mind clarifying exactly what you did after you'd flashed the bios. I'm a quick learner when it comes to PC stuff in general but as far as Android goes i'm a 2 week old noob. I'm currently running DJ's 1.8.1 and have access to the innersd via a small cutout under battery cover but when i tried to follow the "ADB" steps on page 5 i get stuck. My Streak is recognized by my PC running the ADB Devices command. But when i enter the script i get nowhere. Any help from you, or anyone else would sure be appreciated.

So close now but still so far. Lol

Link to post
Share on other sites
Guest Spike8585
I've been running it on mine with 1.8.1 for a couple days now with no un-toward problems.

6Gb class 4 internal

Thanks, I'll check it out.

How? If you've used Stephen Davisons tut on page 5 would you mind clarifying exactly what you did after you'd flashed the bios. I'm a quick learner when it comes to PC stuff in general but as far as Android goes i'm a 2 week old noob. I'm currently running DJ's 1.8.1 and have access to the innersd via a small cutout under battery cover but when i tried to follow the "ADB" steps on page 5 i get stuck. My Streak is recognized by my PC running the ADB Devices command. But when i enter the script i get nowhere. Any help from you, or anyone else would sure be appreciated.

So close now but still so far. Lol

Do you get an error message when you type commands?

Link to post
Share on other sites
Guest Eu4ic
Hello !

with the boot.img you installed, you already have the extra space of the innersd that should automatically mount on /intsd (but it should be formated in ext3, not fat32...). so basically, if your external sd doesn't work, you could only bind -o the /intsd to /sdcard...

and try the command :

pm enable com.android.providers.media/com.android.providers.media.MediaScannerReceiver

in sudo mode, it should then rescan the media files, hence find the media located in /intsd !

good luck !

Hi!

Thanks for the help. Been struggling with this for awhile now. You are right, when I reformat the partion to ext3, it automatically mounts at /intsd. So I no longer have to manually mount it, just bind it to sdcard. The mediascanner trick works for the media player but it does not help other programs like the browser, camera, Evernote etc find the sdcard. They just report that 'Cant find Sdcard' and ends. So I cant use programs that check if a sdcard is present.

Wonder how they solve this for devices with no external sd?

Link to post
Share on other sites
Guest kwenteen
Ive decided to purchase a class10 4gb microsd to try it out and see if there is any improvement.

All ready replaced the screen once and i should have done it before...

I hope this one works:

http://www.newegg.ca/Product/Product.aspx?...N82E16820220492

Apparently, there is a chance that this swap could work without any softmod : your card is not bigger than 4 GB, which is the limit for the system to automatically recognize the sd...

If you simply do a factory reset... that should be it! But you you will loose all your data... if you copy your old card to your new one, you should be able to keep all!

Link to post
Share on other sites
Guest kwenteen
Just one quick question, if I somehow mess up the opening part, will I be able to close it again :(

Depends... if you have 2 left foot instead of hands, you might have some troubles :(

But if you are carefull, you shouldn t have any pb!

I think that the hardest part was to remove the plastic cover located at both sides of the screen... the other steps are way much more simple!

Boujou bien, k.

Link to post
Share on other sites
Guest rahulkadukar
Depends... if you have 2 left foot instead of hands, you might have some troubles :(

But if you are carefull, you shouldn t have any pb!

I think that the hardest part was to remove the plastic cover located at both sides of the screen... the other steps are way much more simple!

Boujou bien, k.

Thanks for the tip seems like I am on my way to a 60 GB phone :(

Link to post
Share on other sites
Guest catapilla
I have had to swap out my internal sd on my streak and currently use a class 2 4gb sandisk (It was the only thing I had lying around and I needed to fix it fast...). To make it work I followed an extremely simple process:

1. Insert card into internal slot

2. Factory reset form dell screen, give it 10 mins to complete the partitioning on boot. Obviosly will not load anything as no os yet.

3. Use QDL tool to install 2.2

Then went on to install steve's latest rom in the normal way. This worked fine and I had 3.something gb available for programs and everything worked great. Market would install etc etc.

However this is not always the case, I have re-installed on a number of occasions, using qdltool to revert back from a screwed rom. On some of these occasions I cannot install anything as it tells me there is no space available. So I would say, if all you are doing is swapping out to a 4gb then try this and it should work for you, you may need to do it twice before it works but that's less complex than some of the other suggestions and easier for those of us without linux.

Having reinstalled from a screwed 1.8 install this morning I cannot install, I'm going to reinstall to solve the issue. If there is anyone who wants me to test anything on the current and then working installs that might help pinpoint what's happening then let me know what you want me to test. I'll leave it 24 hours before I do it so you have time to reply.

P.S I tested the above method on an 8gb and 16gb card and it would not boot.

I used this method and swapped out two micro sd last night.. 8gb class 2 and 8gb class 4.. both streaks boot and operate fine...

Link to post
Share on other sites
Guest Spike8585
Ive decided to purchase a class10 4gb microsd to try it out and see if there is any improvement.

All ready replaced the screen once and i should have done it before...

I hope this one works:

http://www.newegg.ca/Product/Product.aspx?...N82E16820220492

Hey, I bought the same card. Works great.

Let me know if you can just put it in, and do a factory reset. I did it the long way.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.