Jump to content

UPDATED : Real fix for the "stalling/lagging" problem


Guest mimocan
 Share

Recommended Posts

Thanks for the V3...but the market still not working...when the market app initialize the download, its failing.

I follow your updated initial post, but no improvement on my side

Alex

Link to comment
Share on other sites

Negative :

-I normally transfer large files by plugging in the phone to my pc and using 'Mass Storage' USB Setting. After doing this fix, I can't see the external SD-Card (just see only internal SD-Card). Is this problem one of the side effects of this fix? But it's OK for me now, because I can get the microSD out of the phone and use the cardreader to do this job. (But still a little bit inconvenience)

edited: I can see the drive of my external SD-Card, but it's somehow inaccessible with status 'not Encryptable' on Windows 7. any help? sad.gif

Thank you very much for this fix, mimocan. Maybe I will stuck with your fix til official FroYo-update comes out.

same problem here, i used v3

Edited by HansBaer2000
Link to comment
Share on other sites

Well I tried again and this time its great....

I can see the card from windows to unlike some people (did they turn on usb debugging?)

but yeah great work, thanks..... loving the phone now :angry:

be good to see this included in the kitchen etc :D

Link to comment
Share on other sites

Hello all.

Congrats to all involved in this development, specially mimocan.

I've flashed v3 of the kernel and run the script in the first post without any problems.

But now I'm running Quadrant and the software stays in IO phase 3 test (Database writes).

There's a problem for sure. Anyone can help me?

Many thanks.

P.S. Also, Titanium Backup takes ages to start

Edited by iLiquid
Link to comment
Share on other sites

Hello all.

Congrats to all involved in this development, specially mimocan.

I've flashed v3 of the kernel and run the script in the first post without any problems.

But now I'm running Quadrant and the software stays in IO phase 3 test (Database writes).

There's a problem for sure. Anyone can help me?

Many thanks.

P.S. Also, Titanium Backup takes ages to start

Did you check that your apps are actually in /disk?

use a file manager like linda or root explorer etc and check there..

if titanium backup is taking ages then it doesnt sound like you moved them properly... titanium backup on mine is almost instant..

Link to comment
Share on other sites

Did you check that your apps are actually in /disk?

use a file manager like linda or root explorer etc and check there..

if titanium backup is taking ages then it doesnt sound like you moved them properly... titanium backup on mine is almost instant..

Well, inside /disk I have 3 dirs: data, lost+found and media.

data and media have files inside as they should but I dont have any app in /disk.

Should I?

Edited by iLiquid
Link to comment
Share on other sites

Well, inside /disk I have 3 dirs: data, lost+found and media.

data and media have files inside as they should but I dont have any app in /disk.

Should I?

That sounds right, no idea then sorry.. I used v3 on my first go and had some issues..

Went to v2 and everything worked fine.. perhaps you should just try flash v2 over, would only take a few seconds because all the directories are already moved etc..

just an idea :angry:

Link to comment
Share on other sites

Relative n00b here, so please be nice!

I am running JG1 with Pauls R2 ROM, also i have ran all the scripts that were included into his prebake.

This includes the lagfix script to move to NAND.

I've read a bit and heard that I need to run a restore of some sorts before running mimocan's fix?

What exactly do I need to to in order to get mimocan's fix to work?

(i can do the repartitioning, and update the pit file, and also run the commands in a terminal window).

Cheers,

Dave

Edited by djuhn
Link to comment
Share on other sites

Would anyone be so kind as to recommend this method or Paul's? Also, any help for a noob?? Already rooted, and using T-Mobile US Vibrant variant.... Please! Thanks so much in advance

Link to comment
Share on other sites

That sounds right, no idea then sorry.. I used v3 on my first go and had some issues..

Went to v2 and everything worked fine.. perhaps you should just try flash v2 over, would only take a few seconds because all the directories are already moved etc..

just an idea :angry:

I could do that and see what happens.

I'll try it and post the result.

Thanks.

Link to comment
Share on other sites

I could do that and see what happens.

I'll try it and post the result.

Thanks.

It seems the link for version 2 has gone. Anyone have it?

Thanks.

Link to comment
Share on other sites

Would anyone be so kind as to recommend this method or Paul's? Also, any help for a noob?? Already rooted, and using T-Mobile US Vibrant variant.... Please! Thanks so much in advance

Anyone?? PLease? Help!!! :angry:

Link to comment
Share on other sites

For those who have posted the result, thanks for your time and efforts. From these results I think its evident that the major(if not all)boost of performance shown in quadrant benchmark came from mimocan fix alone without the jit patch. Also, we have confirmed that class 2 card yields a similar result to class 4 and even class 6 so an upgrade is not really necessary if u already own one. I will try benchmarking mine on 2gb class2 card shortly to double confirm it :angry:

As for jit, personally I would avoid it until it get more stable.

Edited by gravityz3r0
Link to comment
Share on other sites

Thanks for you work mimocan. Just have a few questions.

If the sd card is removed after applying this fix, would the phone encounter problems?

Is there a way to reverse this fix?

Link to comment
Share on other sites

This looks very interesting :angry:

I think I will wait for it to mature before adopting as I don't want to reset everything on my phone again!

Link to comment
Share on other sites

Woops, in the process of creating the partition on my microsd, i went through the deletion, but after deleting, it coudlnt find any unallocated space to be partitioned. wtf? my microsd is now without partition nor unallocated space :angry:

did anybody know why?

edit : ok, it's alive again, but i can't see the sd card in Paragon Manager. only my hard disk is shown. i cant split nor format the partition. Do i need a dedicated card reader? Or can i do it from the phone? any idea why?

edit 2: i think the reason why i can't play with the partition is because windows 7 see my sd card as removable drive instead of local disk. is there a way i can trick windows to think that it's a local disk instead?

paragomn.jpg

Uploaded with ImageShack.us

Edited by gravityz3r0
Link to comment
Share on other sites

Thanks for the fix mimocan. The phone is running super fast now. Everything seems to be working. Market, mounting of USB drive, elimination of lag (tested with heavy use). I have also run a quandrant benchmark and attached below is the result. Great work!!!

post-643458-1279083323_thumb.png

Link to comment
Share on other sites

sigh, i think i have officially killed the microsd from partitioning and repartitioning crap issues.

i don't understand why you people do not have the problem with windows seeing the micro sd as "removable disk" and thus wont letting you partition it.

Edited by gravityz3r0
Link to comment
Share on other sites

sigh, i think i have officially killed the microsd from partitioning and repartitioning crap issues.

i don't understand why you people do not have the problem with windows seeing the micro sd as "removable disk" and thus wont letting you partition it.

Use gparted, you wont have any issues.

Link to comment
Share on other sites

Woops, in the process of creating the partition on my microsd, i went through the deletion, but after deleting, it coudlnt find any unallocated space to be partitioned. wtf? my microsd is now without partition nor unallocated space :angry:

did anybody know why?

edit : ok, it's alive again, but i can't see the sd card in Paragon Manager. only my hard disk is shown. i cant split nor format the partition. Do i need a dedicated card reader? Or can i do it from the phone? any idea why?

edit 2: i think the reason why i can't play with the partition is because windows 7 see my sd card as removable drive instead of local disk. is there a way i can trick windows to think that it's a local disk instead?

paragomn.jpg

Uploaded with ImageShack.us

maybe it's an idea to use gparted boot cd. This elliminates the windows annoyence.

you can get gparted from:

http://gparted.sourceforge.net/

Link to comment
Share on other sites

Hello all.

Congrats to all involved in this development, specially mimocan.

I've flashed v3 of the kernel and run the script in the first post without any problems.

But now I'm running Quadrant and the software stays in IO phase 3 test (Database writes).

There's a problem for sure. Anyone can help me?

Many thanks.

P.S. Also, Titanium Backup takes ages to start

I just did the fix on my wifes phone and hers has the exact same problem.

Quadrant gets stuck at phase 3.

What card are you using?

I am using a kingston class 4, 8 GB card

Link to comment
Share on other sites

maybe it's an idea to use gparted boot cd. This elliminates the windows annoyence.

you can get gparted from:

http://gparted.sourceforge.net/

Somehow my card got revived, the phone detected it as "Damaged SD Card" and offered to format, so i did it came back alive. Regarding windows annoyance, thanks for the info about the choice of using gparted, but i managed to bypass it using win xp and trick it to see the sdcard as hard disk so i can partition it. Next question, should i assign a drive letter to the ext3 partition? does it matter?

Anywya, i proceeded, but i was stopped at copying stuff from /data/data to /disk. It gave me error saying that "can't create directory /disk/data is a read-only file system". I think someone else had that issue as well earlier. Can somebody help on this! Thanks!

Edited by gravityz3r0
Link to comment
Share on other sites

Somehow my card got revived, the phone detected it as "Damaged SD Card" and offered to format, so i did it came back alive. Regarding windows annoyance, thanks for the info about the choice of using gparted, but i managed to bypass it using win xp and trick it to see the sdcard as hard disk so i can partition it. Next question, should i assign a drive letter to the ext3 partition? does it matter?

Anywya, i proceeded, but i was stopped at copying stuff from /data/data to /disk. It gave me error saying that "can't create directory /disk/data is a read-only file system". I think someone else had that issue as well earlier. Can somebody help on this! Thanks!

did you gain root access before you do the copy command?

can you post the output of mount command ?

Link to comment
Share on other sites

did you gain root access before you do the copy command?

can you post the output of mount command ?

Yea, i have root access from MCR r2, i did not reflash from the scratch though. I apply your fix directly.

Microsoft Windows [Version 6.1.7600]

Copyright (c) 2009 Microsoft Corporation.  All rights reserved.


C:\Users\gravityz3r0>adb shell

$ su

su

# du -h /disk/

du -h /disk/

0	   /disk/

# cp -rp /data/data /disk/

cp -rp /data/data /disk/

cp: can't create directory '/disk/data': Read-only file system

#

Does this have to do with the way i partition my drive? Maybe i should use gparted instead of paragon but the problem is i do not have a blank CD to boot up gparted :angry:

update 2 : i use gparted, splitted my partition into 300Mb (fat32) + 1.6gb (ext3) on a 2gb microsd card. Still having the same problem. Should i just reflash again everything from the scratch? hate to restore my apps/data from backup though :D

Edited by gravityz3r0
Link to comment
Share on other sites

Anyone can tell if this go back to normal if you do a hard reset again? Mean if things go bad and you reflash JG3, does it go back to normal things or this kernel still active? Just good to know

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.