Jump to content

03/August r2 - XXJP3 (Froyo) pre-rooted / insecure boot / ClockworkMod recovery for Odin


Guest PaulOBrien
 Share

Recommended Posts

Yes, JIT is enabled in build.prop in JP3 - but I found if I wanted a stable phone I needed to disable JIT and reduce heap size (using 24MB). All other bugs remain (read only external SD, video contrast, GPS, etc etc - but so long as I got my core Google services I can get by :-) )

No Adobe Flash either right? Cant find it in the market (saw all the other adobe apps). And as soon as I accessed a page with flash it told me to open it in the desktop browser (m.flash.com)

Link to comment
Share on other sites

No Adobe Flash either right? Cant find it in the market (saw all the other adobe apps). And as soon as I accessed a page with flash it told me to open it in the desktop browser (m.flash.com)

Adobe Flash is installed but not working. There's apks around to re-install it, search here or xda - although that might be for JP2. I haven't bothered to re-install it, don't really miss it.

Link to comment
Share on other sites

Adobe Flash is installed but not working. There's apks around to re-install it, search here or xda - although that might be for JP2. I haven't bothered to re-install it, don't really miss it.

One more question. with JP3 are any apps missing from market? Does any market fix need to be enabled? I see a lot of my usual paid apps missing.

Link to comment
Share on other sites

No Adobe Flash either right? Cant find it in the market (saw all the other adobe apps). And as soon as I accessed a page with flash it told me to open it in the desktop browser (m.flash.com)

if you read a page back... i found out that uninstalling adobe flash with astro file manager and then using any adobe flash .apk will do the trick

Link to comment
Share on other sites

Any comments on battery-life? My phone just lost >25% over night, without a single touch...

And I already did the battery-fix (/data/system/batterystats.bin); does anybody else have anything similar?

Link to comment
Share on other sites

One more question. with JP3 are any apps missing from market? Does any market fix need to be enabled? I see a lot of my usual paid apps missing.

Yes, protected apps won't show up in the market. I made sure to backup my paid apps before flashing (you need to be already rooted to backup a protected app).

I would not run the Eris Droid fix - that's for Eclair and I don't actually know what it does so wouldn't risk running it against JP3. (The market fix did work for me on JG5 Eclair however).

The SamSet JP2 ROM has a market fix built in I think, not sure how different it is from JP3 (I know it's been themed orange)

Link to comment
Share on other sites

Any comments on battery-life? My phone just lost >25% over night, without a single touch...

And I already did the battery-fix (/data/system/batterystats.bin); does anybody else have anything similar?

Please can you link me to this fix? Thx!

Link to comment
Share on other sites

Please can you link me to this fix? Thx!

Can't find the original post right now. In a Swiss forum (pocketpc.ch) it's described as follows:

- Charge phone to 100% (wait for popup)

- Completely deplete battery, until the phones turns off on its own.

- Charge phone to 100% (again, wait for the popup that tells you to unplug the charger)

- Do the following (can also be done with a terminal on the phone itself, then w/o the "adb shell" of course):

adb shell
su
rm /data/system/batterystats.bin
[/codebox]

- Complete another battery cycle.

That should recalibrate, probably. Not sure if it helps at all, tho.

Edited by NeidRider
Link to comment
Share on other sites

Can't find the original post right now. In a Swiss forum (pocketpc.ch) it's described as follows:

- Charge phone to 100% (wait for popup)

- Completely deplete battery, until the phones turns off on its own.

- Charge phone to 100% (again, wait for the popup that tells you to unplug the charger)

- Do the following (can also be done with a terminal on the phone itself, then w/o the "adb shell" of course):

adb shell
su
rm /data/system/batterystats.bin
[/codebox]

- Complete another battery cycle.

That should recalibrate, probably. Not sure if it helps at all, tho.

There's not a lot of point in doing a 100% charge, then depleting, the charging and THEN wiping the battery stats, since wiping the stats file at that point would wipe the data that the full charge/discharge cycle gathered.

Just wipe the battery stats in the first place after getting the battery to 100%. At that point you'll have a full battery and clean stats to work with. Let the phone run down to almost depleted, then recharge fully. Now you've got a fresh stats file with a full cycle on it much sooner.

Link to comment
Share on other sites

My guide on calibration

http://hemorrdroids.net/?p=437 :D

I was coming to post about my very poor battery life too. I lose 6-10% an hour at the moment. I've stripped it right down of apps and widgets but nothing seems to save me.

When I look in spare parts, the battery history shows 'running' as 42%, when screen on is only 14%? That's about 4 hours the phone has been 'running' when I'm not actually using it. That can't be right can it? I played podcasts for about an hour, but what about the other 3 hours?

Link to comment
Share on other sites

My guide on calibration

http://hemorrdroids.net/?p=437 :D

I was coming to post about my very poor battery life too. I lose 6-10% an hour at the moment. I've stripped it right down of apps and widgets but nothing seems to save me.

When I look in spare parts, the battery history shows 'running' as 42%, when screen on is only 14%? That's about 4 hours the phone has been 'running' when I'm not actually using it. That can't be right can it? I played podcasts for about an hour, but what about the other 3 hours?

Probably some errant app in the background...

Could this be an issue with FroYo you're running?

Funny, I don't seem to have Spare Parts any more. Hmmm. Still can check About menu, though.

I've got acceptable battery life with JG1 and the loop mount lag fix:

Display 69%

Cell stby 10%

Phone idle 6%

Bluetooth 4%

Camera 3%

Android Sys 3%

Speed Test 2%

Voice Calls 2%

Link to comment
Share on other sites

This is weird. I flashed with this ROM about a week ago and all was well, now today I've booted up and it is now asking for a SIM Network Unlock PIN. I can't understand how this could have happened - surely if the phone was locked, it would have been locked from Day 1? Tried doing a factory reset and it's still asking for it, about to try flashing back to a stock ROM before panicking.

Link to comment
Share on other sites

One more question. with JP3 are any apps missing from market? Does any market fix need to be enabled? I see a lot of my usual paid apps missing.

I gave JP2 w/Market Fix a go but soon realised it seems to have all the same issues as JP3 plus a slower browser. It did have the market fix though.

I've since flashed back to Paul's JP3, and amended the following lines in /system/build.prop (after a nandroid backup!) and now the protected apps show up again in the market

ro.build.description=GT-I9000-user 2.1-update1 ECLAIR XWJG1 release-keys

ro.build.fingerprint=Samsung/GT-I9000/GT-I9000/GT-I9000:2.1-update1/ECLAIR/XWJG1:user/release-keys

I guess you could also use the Eris Market fix from the market, but at least with this one it'll be the same hardware fingerprint.

(this build.prop thing reminds me of hours spent messing with config.sys on MSDOS twenty years ago ...)

Link to comment
Share on other sites

Hmm...so installed this on my Vibrant. Not getting Tmo 3g data even though the APN settings were added again. I'm assuming it's the radio? Then started reading about problems downgrading back to 2.1 - can anyone confirm that we can't get Tmo 3g with this rom, and 2, has anyone downgraded from Froyo back to 2.1?

Edit: To clarify - I am talking about no data. no 2g or 3g connection. I'm in a place where it's normally full 3g service. It DID go for one second to edge a minute ago and now it's back to full service with no data connection.

Edit 2: I can only get AT&T to show up for available networks. No T-Mobile to select...don't know what that means other than, um, yeah. So even if the radio worked for 2g for AT&T i should get 2g being on T-Mo with the APN set up...just no 3g if the radio installed for this doesn't work with 1700mhz. I'm lost lol and don't want to flash back without knowing more about the radio downgrade and brick potential...

Link to comment
Share on other sites

If you have the 900/1900 radio, you'll never get it to work on AWS with T-Mobile, it's a hardware limitation, not software.

I've seen a few claims of people bricking there i9000, but it seems awfully hard to do. If you're on a Captivate or Vibrant, I don't know.

Honestly, despite all the warnings of risks with the Nexus One on flashing the radio, I never heard of anyone actually doing it here or on xda, but I didn't ever specifically look for it, so I could have easily missed reports of it.

Can you at least get voice on T-Mo in your current configuration.

Hmm...so installed this on my Vibrant. Not getting Tmo 3g data even though the APN settings were added again. I'm assuming it's the radio? Then started reading about problems downgrading back to 2.1 - can anyone confirm that we can't get Tmo 3g with this rom, and 2, has anyone downgraded from Froyo back to 2.1?

Edit: To clarify - I am talking about no data. no 2g or 3g connection. I'm in a place where it's normally full 3g service. It DID go for one second to edge a minute ago and now it's back to full service with no data connection.

Edit 2: I can only get AT&T to show up for available networks. No T-Mobile to select...don't know what that means other than, um, yeah. So even if the radio worked for 2g for AT&T i should get 2g being on T-Mo with the APN set up...just no 3g if the radio installed for this doesn't work with 1700mhz. I'm lost lol and don't want to flash back without knowing more about the radio downgrade and brick potential...

Link to comment
Share on other sites

Hmm...so installed this on my Vibrant. Not getting Tmo 3g data even though the APN settings were added again. I'm assuming it's the radio? Then started reading about problems downgrading back to 2.1 - can anyone confirm that we can't get Tmo 3g with this rom, and 2, has anyone downgraded from Froyo back to 2.1?

Edit: To clarify - I am talking about no data. no 2g or 3g connection. I'm in a place where it's normally full 3g service. It DID go for one second to edge a minute ago and now it's back to full service with no data connection.

Edit 2: I can only get AT&T to show up for available networks. No T-Mobile to select...don't know what that means other than, um, yeah. So even if the radio worked for 2g for AT&T i should get 2g being on T-Mo with the APN set up...just no 3g if the radio installed for this doesn't work with 1700mhz. I'm lost lol and don't want to flash back without knowing more about the radio downgrade and brick potential...

what about flashing a vibrant radio?? or have you checked if you have wcdma only in networks?? you flashed a 900/1900/2100 radio... so theoretically only 2100 is working in your vibrant (in 3g), but 2g should be fine

Link to comment
Share on other sites

Flashed today.

Everything seems ok. Quadrant score was 999.

I tried RyanZAEXT2LAGFIX BETA 2-3. After installation, Quadrant score is 1665. Very fast.

Gmail work fine, same facebook, same Genie widget, same Youtube.

Only one issue: i can't surf Internet.

When i try to open a page, my phone vibrate two times, and the browser close.

Same issue with standard browser and with Dolphin browser.

Can someone help me ?

Anyway, great job. Many thanks Paul.

Link to comment
Share on other sites

i have problem with clockrecovery, when i go in recovery i have this error:

e: failed to verify whole-file signature

e:signature verification failed

why? please help me

Link to comment
Share on other sites

paul from your experience, do you suggest jp3 r2 or g5 mcr ?

looking for something stable... on all aspects :D

4 my experience g5 mcr is better....

Link to comment
Share on other sites

Science Paul doesn't have time to read all the PM's (and i don't blame him at all ! ) i'm posting here the pm that i send to him , maybe someone knows how.

" Before i installed your custom rom+root i had the I9000XXJF5 wich by the way is quite hard to find . I didn't rooted my phone before your easy version, but now i'm facing a new problem. So far i have no issues with the phone but if i'll eventualy have to send it to service, how can i unroot this version.

Do i have to : First reinstall the JF5 rom and then unroot . Or unroot while having the jp3 installled ? I'm asking cause the Android Terminal Emulator or the One Click Unroot are not wokring on me phone.

The way i tried was like this: Used again the Odin app, used a normal rom I9000XXJF5 (the rar file(173 MBs) that i found had the 3 files) , and i used the 513 pit file cause with the 512 Odin was not going on with the I9000XXJF5 installation.

With the One click unroot, on the phone screen, one line was missing( Reinstall Packages) but that is probably for rooting not for unrooting. Also a few lines bellow a line telling me that a file was not found ritten in red colour.

With the Android Terminal Emulator the superuser apk was not found.

Do i have to unroot while having your jp3 installed ? I'm waitng for a helping solution . Thank you ! "

PS: A Terminal Emulator worked only on the jp3 rom. Also how do i know if my phone is unrooted , where do i look?

Edited by Alexzander_Lexx
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.