Jump to content

New (very fast) lag fix using internal memory and playlogo1 hack


Guest portman0
 Share

Recommended Posts

Hi,

I think you have an error in userinit.sh. Second line is 'chmod 1000:1000 /data/data1' instead of chown.

Regards,

Ovidiu

This is copied from my post over on XDA dev. It makes the phone as smooth as butter. It's faster than any of the previous lag fixes plus it doesn't have any of the issues that the other ones had like not being able to remove the memory card, or running out of space on the new partition, etc. My SGS feels as smooth as an iPhone 4 now. My only contribution is that I made this into a complete guide. It was the hard work of others that discovered this fix.

Here are the instructions:

First copy the two files in the attached .zip to the root of your internal memory then run the following commands after enabling debugging mode. Make sure you have the latest busybox installed. The first command takes a while since it creates a 1 GB file on the internal memory. I also recommend starting in stock configuration (any firmware version is fine) I don't know what will happen if other fixes/kernels have been applied.

adb shell


su


busybox dd if=/dev/zero of=/data/dataimg bs=1024 count=1048576

busybox mknod /dev/loop0 b 7 0

busybox losetup /dev/loop0 /data/dataimg

busybox mkfs.ext2 /dev/loop0

mkdir /data/data1


busybox mount -o remount,rw -t rootfs /

mv /system/bin/playlogos1 /system/bin/playlogosnow

cp /sdcard/playlogos1 /system/bin/playlogos1

cp /sdcard/userinit.sh /system/bin/userinit.sh

chmod 755 /system/bin/playlogos1

chmod 755 /system/bin/userinit.sh

busybox mount -o remount,ro -t rootfs /


reboot

Link to comment
Share on other sites

Hello,

I'm new to all those fixes and all, and I got some questions

Can this method be reversed? How?

Does this fix removes all my applications and settings?

Link to comment
Share on other sites

Hi,

First thanks for your work.

I've started to apply the commands and get an error why executing mkfs.ext2. It seems that mkfs.ext2 is not existing on my system (JF5.MCR1 + busybox 1.16).

Would you please point me how I can get mkfs.ext2 on my android?

Regards,

Ovidiu

Hello guys,

Same thing here : "mkfs.ext2: applet not found" error.

I'm on Paul's r3 (JG5).

Help please

** Trying out the busybox update. while i was typing my post you've already posted answers ! you ROCK !!!

** the installation went through smoothly after updating the busybox app, but unfortunately I feel no improvement what so ever :) i get 864 in benchmark :D

What's wrong ?!?

Edited by Avi GNG
Link to comment
Share on other sites

I write:

adb shell

su

busybox dd if=/dev/zero of=/data/dataimg bs=1024 count=1048576

then I get:

Permission denied

$ dd: canĀ“t open '/data/dataimg': Permission denied

The system is rooted and have:

1. su+Superuser

2. busybox (/system/xbin/busybox)

Why wont it work?

Same problem here, my phone is rooted, I get the BusyBox app that say my phone is rooted and update busybox to latest (18).

But when I type :

adb shell

su

I get Permission Denied

Link to comment
Share on other sites

I've managed to follow all of the steps successfully, but now I'm getting a problem getting apps from the Market, I get "Download was unsuccessful" (with Google Maps and Layar).

Is anyone else getting this / can help?

TIA.

Link to comment
Share on other sites

Hi,

2143 score here.

Thanks again for your work.

Regards,

Ovidiu

Hi,

I think you have an error in userinit.sh. Second line is 'chmod 1000:1000 /data/data1' instead of chown.

Regards,

Ovidiu

Link to comment
Share on other sites

Hi,

yes, you should be able to reverse this. Just copy back playlogos1 file and remove userinit.sh.

fix is not removing any apps or settings.

Regards,

Ovidiu

Hello,

I'm new to all those fixes and all, and I got some questions

Can this method be reversed? How?

Does this fix removes all my applications and settings?

Link to comment
Share on other sites

Hi

just updated my Layar to a newer version. Everything runs fine here

Regards,

Ovidiu

I've managed to follow all of the steps successfully, but now I'm getting a problem getting apps from the Market, I get "Download was unsuccessful" (with Google Maps and Layar).

Is anyone else getting this / can help?

TIA.

Link to comment
Share on other sites

Same problem here, my phone is rooted, I get the BusyBox app that say my phone is rooted and update busybox to latest (18).

But when I type :

adb shell

su

I get Permission Denied

Got it working, forgot to allow i Superuser.

Link to comment
Share on other sites

Hello guys,

Same thing here : "mkfs.ext2: applet not found" error.

I got this error too, so I downgraded to 1.17.1 (was on 1.18 git) and got this:

# busybox mkfs.ext2 /dev/loop0

mkfs.ext2: image is too small

...anyone have any idea?

Edited by unfnknblvbl
Link to comment
Share on other sites

Would you check size of your dataimg? Probably you set the wrong arguments for dd.

Regards,

Ovidiu

I got this error too, so I downgraded to 1.17.1 (was on 1.18 git) and got this:

# busybox mkfs.ext2 /dev/loop0

mkfs.ext2: image is too small

...anyone have any idea?

Link to comment
Share on other sites

Okay so I tried this with ADB, but the moment I type in the first command after the su (busybox dd if=/dev/zero of=/data/dataimg bs=1024 count=1048576) it says "dd: can't open '/data/dataimg': Permission denied'.

What do I do now? I have root access, superuser installed and busybox 1.18.

Link to comment
Share on other sites

I am having a problem with busybox. According to the 1.18 installer, I have 1.15.3 installed. But the installer won't let me upgrade because 'the nand is not unlocked'. When I try the older version on page 2 of this thread, I suddenly have no busybox installed and have the same message with the failed instalation. What can I do....

Running jm5 with samset 1.9 (ext 3/4 fix not applied).

Link to comment
Share on other sites

I have the previous EXT4 lagfix installed. Should I undo the previous fix somehow before I attempt this fix?

No need to; it'll just copy all your data from the ext4 partition to the new image. (that's at least what I have running).

Only thing is, you'll still have that ext4 partition mounted, as you've flashed a kernel that does this automatically; I simply added "busybox umount /disk" at the end of the userinit.sh script to work around this.

Link to comment
Share on other sites

i get this fault no such file or directory when the cp /sdcard/userinit.sh /system/bin/userinit.sh and playlogos files are to be copied? any idea i can see them mounted in windows. in fact it says cant stat

busybox dd if=/dev/zero of=/data/dataimg bs=1024 count=1048576

busybox mknod /dev/loop0 b 7 0

busybox mknod /dev/loop0 b 7 0

busybox losetup /dev/loop0 /data/dataimg

busybox losetup /dev/loop0 /data/dataimg

busybox mkfs.ext2 /dev/loop0

busybox mkfs.ext2 /dev/loop0

mkdir /data/data1

mkdir /data/data1

busybox mount -o remount,rw -t rootfs /

busybox mount -o remount,rw -t rootfs /

mv /system/bin/playlogos1 /system/bin/playlogosnow

mv /system/bin/playlogos1 /system/bin/playlogosnow

cp /sdcard/playlogos1 /system/bin/playlogos1

cp /sdcard/playlogos1 /system/bin/playlogos1

1048576+0 records in

1048576+0 records out

1073741824 bytes (1.0GB) copied, 173.688520 seconds, 5.9MB/s

# # # Filesystem label=

OS type: Linux

Block size=4096 (log=2)

Fragment size=4096 (log=2)

65536 inodes, 262144 blocks

13107 blocks (5%) reserved for the super user

First data block=0

Maximum filesystem blocks=4194304

8 block groups

32768 blocks per group, 32768 fragments per group

8192 inodes per group

Superblock backups stored on blocks:

32768, 98304, 163840, 229376

# # # # cp: can't stat '/sdcard/playlogos1': No such file or directory

# cp /sdcard/playlogos1 /system/bin/playlogos1

cp /sdcard/playlogos1 /system/bin/playlogos1

cp: can't stat '/sdcard/playlogos1': No such file or directory

# cp /sdcard/userinit.sh /system/bin/userinit.sh

cp /sdcard/userinit.sh /system/bin/userinit.sh

cp: can't stat '/sdcard/userinit.sh': No such file or directory

# chmod 755 /system/bin/playlogos1

chmod 755 /system/bin/playlogos1

Unable to chmod /system/bin/playlogos1: No such file or directory

# cp /sdcard/userinit.sh /system/bin/userinit.sh

cp /sdcard/userinit.sh /system/bin/userinit.sh

cp: can't stat '/sdcard/userinit.sh': No such file or directory

#

thats as far as i can go, any help plz?

Edited by scumbag77
Link to comment
Share on other sites

Hey guys,

Would any of you please care to look at my screen shot (internal SD card and CMD window) and tell me where I am going wrong?

Looking forward to your replies.

Thanks in advance!

post-743804-1281361371_thumb.jpg

Link to comment
Share on other sites

A big thanks to everyone who has helped to create this fix! My galaxy S does feel snappier and I have got a Quadrant score of 2193!

Very happy this worked out so well (after reading a whole lot because I'm a n00b :)).. Also a thanks to tweakers.net forum for the help there.

Big thumbs up!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.