Jump to content

[ROM] FLB-Mod 2 (Based on Android 2.2 Froyo) TESTING


Guest Simon O

Recommended Posts

Guest Richard_Arkless
Any kinda release date of when a stable Froyo build will be released, Im dying to have it on my pulse!

Its not a question of when it will be stable as ive used it myself and its pretty stable and fast

The question is when will camera and stuff like that work, I doubt the people working on it will get much from it, the best bet is that they get camera working

of course we now got the kernel which has helped but I think some drivers will need recompiling which they cant do as the developers havent released the driver source as its most likely closed source

Link to post
Share on other sites
Its not a question of when it will be stable as ive used it myself and its pretty stable and fast

The question is when will camera and stuff like that work, I doubt the people working on it will get much from it, the best bet is that they get camera working

of course we now got the kernel which has helped but I think some drivers will need recompiling which they cant do as the developers havent released the driver source as its most likely closed source

Hmm true, Mybad.

I dont mind if like GPS and the other stuff isnt working, But i do need Camera & Video.

Hopefully not long untill we have a proper release :lol:

Link to post
Share on other sites
Hmm true, Mybad.

I dont mind if like GPS and the other stuff isnt working, But i do need Camera & Video.

Hopefully not long untill we have a proper release :lol:

video playback problem is not in the closed source part, I think it is fixable. for camera I dunno, almost never use it.

Link to post
Share on other sites
Guest DanWilson

Keeps looping this (In a logcat)

D/AndroidRuntime( 1501): 
D/AndroidRuntime( 1501): >>>>>>>>>>>>>> AndroidRuntime START <<<<<<<<<<<<<<
D/AndroidRuntime( 1501): CheckJNI is OFF
E/dalvikvm( 1501): Can't open dex cache '/data/dalvik-cache/[email protected]@[email protected]': No such file or directory
I/dalvikvm( 1501): Unable to open or create cache for /system/framework/core.jar (/data/dalvik-cache/[email protected]@[email protected])
D/dalvikvm( 1501): Unable to process classpath element '/system/framework/core.jar'
E/dalvikvm( 1501): Can't open dex cache '/data/dalvik-cache/[email protected]@[email protected]': No such file or directory
I/dalvikvm( 1501): Unable to open or create cache for /system/framework/ext.jar (/data/dalvik-cache/[email protected]@[email protected])
D/dalvikvm( 1501): Unable to process classpath element '/system/framework/ext.jar'
E/dalvikvm( 1501): Can't open dex cache '/data/dalvik-cache/[email protected]@[email protected]': No such file or directory
I/dalvikvm( 1501): Unable to open or create cache for /system/framework/framework.jar (/data/dalvik-cache/[email protected]@[email protected])
D/dalvikvm( 1501): Unable to process classpath element '/system/framework/framework.jar'
E/dalvikvm( 1501): Can't open dex cache '/data/dalvik-cache/[email protected]@[email protected]': No such file or directory
I/dalvikvm( 1501): Unable to open or create cache for /system/framework/android.policy.jar (/data/dalvik-cache/[email protected]@[email protected])
D/dalvikvm( 1501): Unable to process classpath element '/system/framework/android.policy.jar'
E/dalvikvm( 1501): Can't open dex cache '/data/dalvik-cache/[email protected]@[email protected]': No such file or directory
I/dalvikvm( 1501): Unable to open or create cache for /system/framework/services.jar (/data/dalvik-cache/[email protected]@[email protected])
D/dalvikvm( 1501): Unable to process classpath element '/system/framework/services.jar'
D/dalvikvm( 1501): Unable to stat classpath element '/system/framework/com.huawei.android.launcher.jar'
D/dalvikvm( 1501): Unable to stat classpath element '/system/framework/widget_multimedia.jar'
D/dalvikvm( 1501): Unable to stat classpath element '/system/framework/widget_info.jar'
E/dalvikvm( 1501): ERROR: no valid entries found in bootclasspath '/system/framework/core.jar:/system/framework/ext.jar:/system/framework/framework.jar:/system/framework/android.policy.jar:/system/framework/services.jar:/system/framework/com.huawei.android.launcher.jar:/system/framework/widget_multimedia.jar:/system/framework/widget_info.jar'
W/dalvikvm( 1501): JNI_CreateJavaVM failed
E/AndroidRuntime( 1501): JNI_CreateJavaVM failed
I/ServiceManager( 1201): service 'media.audio_flinger' died
I/ServiceManager( 1201): service 'media.player' died
I/ServiceManager( 1201): service 'media.camera' died
I/ServiceManager( 1201): service 'media.audio_policy' died
I/AudioHardwareMSM72XX( 1502): get_audpp_filter
I/AudioHardwareMSM72XX( 1502): open /system/etc/AudioFilter.csv success.
I/AudioHardwareMSM72XX( 1502): EQ flag = ffff.
E/AudioHardwareMSM72XX( 1502): audioeq library open failure
I/AudioHardwareMSM72XX( 1502): failed to set audpp parameters, exiting.
E/AudioHardwareMSM72XX( 1502): failed to open AUTO_VOLUME_CONTROL /system/etc/AutoVolumeControl.txt: No such file or directory (2)
D/AudioHardwareInterface( 1502): setMode(NORMAL)
I/AudioHardwareMSM72XX( 1502): Set master volume to 7.
I/CameraService( 1502): CameraService started: pid=1502
I/AudioFlinger( 1502): AudioFlinger's thread 0xb7b8 ready to run
I/AudioHardwareMSM72XX( 1502): Routing audio to Speakerphone
D/AudioHardwareMSM72XX( 1502): setVoiceVolume(1.000000)
I/AudioHardwareMSM72XX( 1502): Setting in-call volume to 7 (available range is 0 to 7)
[/codebox]

Link to post
Share on other sites
*edit* me dumb me *blush* :]

data service problem solved, altho i copied the VPN settings for my mms service (telenor hungary)

apn: mms

mmsc: http://mmsc.telenor.hu

mms proxy: 84.255.255.1

mms port: 8080

mcc: 216

mnc: 01

apn type: mms

these settings are from the factory ├ęclair 2.1 with the phone, just tested everything works on that rom

i install my 2.2 with rom manager, set up everything for web and mms, yet mms won't work.

i receive a text message, but unable to download any images.. even when i'm on my home wifi network, i get the 3g signal but nothing seems to happen when i try to dl O.o

+1, with T-Mobile HU, correctly set APNs

Link to post
Share on other sites
Guest DanWilson
Dan, what is this, what happened?

I think it's to do with my boot.img (OC one)

I flashed FLB because I wanted the clock from Home Screenshots.

Although I hope Flib has included the Market fix...

Link to post
Share on other sites
Guest AdamBaker
Does it work? (at least the camera part)

Depends what you mean by work. With the CM mods then we no longer get stuck in a boot loop if the camera is enabled at build time. Once you start the app their is a problem that may be related to the video playback issue that prevents actually testing the camera.

Link to post
Share on other sites
Depends what you mean by work. With the CM mods then we no longer get stuck in a boot loop if the camera is enabled at build time. Once you start the app their is a problem that may be related to the video playback issue that prevents actually testing the camera.

If you mean the blitter problem, I know about that..

Link to post
Share on other sites
Is it normal for 2.2 to drain my battery so quickly? Way faster than 2.1?

Really? I was getting much better battery life out of it that 2.1. I haven't used it off battery recently so maybe it is one of the more recent changes that has increased battery use. Try disabling JIT and swap and see if that impacts battery life.

Link to post
Share on other sites
Depends what you mean by work. With the CM mods then we no longer get stuck in a boot loop if the camera is enabled at build time. Once you start the app their is a problem that may be related to the video playback issue that prevents actually testing the camera.

I've been think rather than trying to port the bits of CM6 that we need into our code, it may be better to try to get all of CM6 running. I'll have a play with it after work, but I don't see why it wouldn't work, CM6 already runs on devices with similar hardware, and this way if we can get it working we should be able to take advantage of the larger dev community working on cyanogenmod. Hopefully using CM6 the camera and video will just work.

Link to post
Share on other sites
I've been think rather than trying to port the bits of CM6 that we need into our code, it may be better to try to get all of CM6 running. I'll have a play with it after work, but I don't see why it wouldn't work, CM6 already runs on devices with similar hardware, and this way if we can get it working we should be able to take advantage of the larger dev community working on cyanogenmod. Hopefully using CM6 the camera and video will just work.

That is actually a good idea.

Link to post
Share on other sites
Yesterday I built a kernel with the CM6 msm video driver. It didn't work, because it did not init framebuffer properly, but I would like to fix this too.

What kernel version was the video driver for? I believe CM6 uses .34 ?

Link to post
Share on other sites
Guest kallt_kaffe

Hi guys... Not having read the whole thread this may have been brought up erlier, if so then I apologize for my ignorance...

Seeing in the first post that camera and gps is not working, have you tried borrowing some libs from the U8150 ROM?

On my U8100 both camera and GPS works perfectly with the U8150 ROM and I believe the hardware between the U81xx series and the U82xx series shares a lot of hardware.

Link to post
Share on other sites
Guest Fusion0306
Hi guys... Not having read the whole thread this may have been brought up erlier, if so then I apologize for my ignorance...

Seeing in the first post that camera and gps is not working, have you tried borrowing some libs from the U8150 ROM?

On my U8100 both camera and GPS works perfectly with the U8150 ROM and I believe the hardware between the U81xx series and the U82xx series shares a lot of hardware.

Yes, it's been mentioned, but I don't think that it helps the devs

Link to post
Share on other sites
Hi guys... Not having read the whole thread this may have been brought up erlier, if so then I apologize for my ignorance...

Seeing in the first post that camera and gps is not working, have you tried borrowing some libs from the U8150 ROM?

On my U8100 both camera and GPS works perfectly with the U8150 ROM and I believe the hardware between the U81xx series and the U82xx series shares a lot of hardware.

We did try but they have been compiled to work with a .32 kernel and the U8150 kernel is too large to flash to our Pulses.

Link to post
Share on other sites
Guest goce.nakov
How do I install apps? There is no shortcut to Market and there is no login for a google account in settings. Only regular pop email.

did you installed flashable zip with google aps after install of Froyo?

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.