Jump to content

Gingerbread (2.3) for Pulse


Guest Tom G

Recommended Posts

Guest TJ Style

I want to know about porting the Gingerbread SDK to real device.

i try to porting to my device (commtiva z7i variant) but not susscess very well, so i need reference..

On pulse:

1. for files, what are keep, relpace and added from system.img from Gingerbread SDK?

2. for kernel, what config are used to? i see about VMSPLIT_3G and what again to be changed?

3. for init.rc and entire ramsidk, what to be changed or modify?

Thank you in advance..

Link to post
Share on other sites

As I saw on the presentation about the 2.3 and as I understand it says that every device that it's capable of running Froyo can run the Gingerbread without a problem and that in the apps that use the camera (like fring) for video calls or whatever by using the newest camera API, can now easily switch to the front camera.

So it would be great if the front camera is working for us with the 2.3 and if not... Well... I'm fine with that too. :)

Link to post
Share on other sites
As I saw on the presentation about the 2.3 and as I understand it says that every device that it's capable of running Froyo can run the Gingerbread without a problem and that in the apps that use the camera (like fring) for video calls or whatever by using the newest camera API, can now easily switch to the front camera.

So it would be great if the front camera is working for us with the 2.3 and if not... Well... I'm fine with that too. :)

Yeah, it would be nice to have the front camera working.

Link to post
Share on other sites
Guest al-xcartier
Guys, if I'm right this is an international forum, and because of this please use english language in comments, to make the others understand what your problem is. I'm not english, but I'm using english too in the topics. I respect the others with that I'm not talking hungarian, although it is my mothertongue. First, because more people can help you, if they understand what you are saying, second, mert kurvára nem értené senki, hogy mit ugatok, és idegesítené őket. :)

You're pretty right, Nova910! Just three things by the way: funnily enough, French is not mothertongue, I just wrote in French to help the guy out, secondly I'll ask a Hungarian colleague of mine to translate what you were writing and thirdly yesterday I just didn't have the time to write an English version of my post which follows now:

"Didn't work for me neither. Finally, I downloaded the *.zip, unpacked it into "Downloads", restarted the handset on holding "Vol-", "Hang up" and "Power" (Fastboot mode), connected it with the PC using the USB cable, downloaded Fastboot and copied "system.img" and "boot.img" unpacked from the *.zip to the handset:

fastboot -w flash boot boot.img <Enter>

fastboot -w flash system system.img <Enter>

Rebooted and everything worked fine. One should not choose "2G networks exclusively" for the handset will start de- and reconnecting with the network. WLAN worked fine, although the browser doesn't browse over WLAN (I don't have 3G subscribed).

Sorry for my bad French, Alex"

Link to post
Share on other sites
Guest Nova910
You're pretty right, Nova910! Just three things by the way: funnily enough, French is not mothertongue, I just wrote in French to help the guy out, secondly I'll ask a Hungarian colleague of mine to translate what you were writing and thirdly yesterday I just didn't have the time to write an English version of my post which follows now:

"Didn't work for me neither. Finally, I downloaded the *.zip, unpacked it into "Downloads", restarted the handset on holding "Vol-", "Hang up" and "Power" (Fastboot mode), connected it with the PC using the USB cable, downloaded Fastboot and copied "system.img" and "boot.img" unpacked from the *.zip to the handset:

fastboot -w flash boot boot.img <Enter>

fastboot -w flash system system.img <Enter>

Rebooted and everything worked fine. One should not choose "2G networks exclusively" for the handset will start de- and reconnecting with the network. WLAN worked fine, although the browser doesn't browse over WLAN (I don't have 3G subscribed).

Sorry for my bad French, Alex"

I'm sorry too, for the aggressive post, but I had a pretty bad day that day, so I was maybe a bit too aggressive. :) BTW, is it possible to make a Cyanogenlike custom rom from Gingerbread, after the official release, or it will stay buggy on the pulse like nowadays?

Link to post
Share on other sites
Guest UrbanRider
Here you go: Camera.apk

If you want another apk let me know and I'll upload it.

Does the dialer has smart t9 search? i ask this because the dialer from CM6 .4 does not search my contact's names wile i type a number and its a feature i would like to use wit a "standart" dialer

Link to post
Share on other sites
You're pretty right, Nova910! Just three things by the way: funnily enough, French is not mothertongue, I just wrote in French to help the guy out, secondly I'll ask a Hungarian colleague of mine to translate what you were writing and thirdly yesterday I just didn't have the time to write an English version of my post which follows now:

"Didn't work for me neither. Finally, I downloaded the *.zip, unpacked it into "Downloads", restarted the handset on holding "Vol-", "Hang up" and "Power" (Fastboot mode), connected it with the PC using the USB cable, downloaded Fastboot and copied "system.img" and "boot.img" unpacked from the *.zip to the handset:

fastboot -w flash boot boot.img <Enter>

fastboot -w flash system system.img <Enter>

Rebooted and everything worked fine. One should not choose "2G networks exclusively" for the handset will start de- and reconnecting with the network. WLAN worked fine, although the browser doesn't browse over WLAN (I don't have 3G subscribed).

Sorry for my bad French, Alex"

The browser worked fine with WLAN when I tested it. It may be that DHCP isn't setting DNS properly for WLAN (but will work if also using 3G as DNS will already be set). Try http://66.102.11.104 (IP for google.com), if it is a DNS problem that should work.

Edited by Tom G
Link to post
Share on other sites
The browser worked fine with WLAN when I tested it. It may be that DHCP isn't setting DNS properly for WLAN (but will work if also using 3G as DNS will already be set). Try http://66.102.11.104 (IP for google.com), if it is a DNS problem that should work.

I found the DHCP problem while setting up wifi on the Blade. As I thought it isn't configuring DNS. I will put up a fix for it.

I have PM'd the author of that list on xda-dev about my pulse and blade roms, but haven't heard anything yet.

Link to post
Share on other sites
PM'd the dude at XDA who made the Gingerbread news post.

Or who evers name was at the top...

I got a response from ElCondor. They won't include either of my roms on the list because they are from outside xda-dev. To call it a list of all phones running gingerbread hardly seems correct when they won't include anything developed outside of xda-dev.

Link to post
Share on other sites
Guest Simon O
I got a response from ElCondor. They won't include either of my roms on the list because they are from outside xda-dev. To call it a list of all phones running gingerbread hardly seems correct when they won't include anything developed outside of xda-dev.

It's their loss. XDA-Forum seems to dislike MoDaCo for some reason and they also seem to dislike any Android device that isn't from a big name manufacturer. They have consistently refused to provide a forum for Huawei devices and refuse to create a forum for the ZTE Blade citing privacy concerns (wtf). I like MoDaCo better because Paul runs it properly.

Link to post
Share on other sites
It's their loss. XDA-Forum seems to dislike MoDaCo for some reason and they also seem to dislike any Android device that isn't from a big name manufacturer. They have consistently refused to provide a forum for Huawei devices and refuse to create a forum for the ZTE Blade citing privacy concerns (wtf). I like MoDaCo better because Paul runs it properly.

Perhaps its for the best, having information exchange about the Pulse and the Blade over the two forums, would make it hard to keep up with new developements as not everthing revealed here would get repeated there and vice versa. We have enough experts here, creating enough ROMs to make it hard to keep up as it is! :)

Link to post
Share on other sites
Guest AntonioPT
It's their loss. XDA-Forum seems to dislike MoDaCo for some reason and they also seem to dislike any Android device that isn't from a big name manufacturer. They have consistently refused to provide a forum for Huawei devices and refuse to create a forum for the ZTE Blade citing privacy concerns (wtf). I like MoDaCo better because Paul runs it properly.

This is one of the reasons why I don't like XDA and why I love Modaco :)

Link to post
Share on other sites
Guest flip360
It's their loss. XDA-Forum seems to dislike MoDaCo for some reason and they also seem to dislike any Android device that isn't from a big name manufacturer. They have consistently refused to provide a forum for Huawei devices and refuse to create a forum for the ZTE Blade citing privacy concerns (wtf). I like MoDaCo better because Paul runs it properly.

their loss anyway, Bunch of Elitists.

We will have 2.3 on our phone sooner than their ohsopreciousalsoapieceofcrap G1 :)

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.