Jump to content

Gingerbread (2.3) for Pulse


Guest Tom G
 Share

Recommended Posts

Guest DanWilson
The audio driver (which wasn't from AOSP) broke so I've spent a bit of time fixing that. It looks like it works now (I just made a call and it worked) but for some reason there are no sounds in the rom. It looks like the entire media directory is missing.

It looks like wifi is working. 3g isn't at the moment, but that should be a 5 minute fix.

Once I get the sounds sorted out I will upload a rom. There will still be a lot not working, but it will have basic phone functionality.

Speed?

Also - are you going to perfect (or near enough) then move onto CM7?

Or are you just going to port CM7 as soon as it's out?

Link to comment
Share on other sites

Guest mikeb90

it's a bit OT, but i've heard that Honeycomb'll be a minor release of Android, ergo a 2.4 , than there's a possibility for us to have an android 2.4 terminal *-* (if the base-characteristic won't change)

Link to comment
Share on other sites

Guest DanWilson
it's a bit OT, but i've heard that Honeycomb'll be a minor release of Android, ergo a 2.4 , than there's a possibility for us to have an android 2.4 terminal *-* (if the base-characteristic won't change)

I thought Honeycomb was 3.0, and built for tablets. Like 2.3 but bigger.

Link to comment
Share on other sites

Speed?

Also - are you going to perfect (or near enough) then move onto CM7?

Or are you just going to port CM7 as soon as it's out?

I'll be moving to the next CM once there is some development.

The sound problem is bigger than I thought. Its very strange, sound works fine in calls so it is obviously working, but no other sound works. I have the same problem on the blade (which is no surprise since I use the same libaudio for both).

Link to comment
Share on other sites

Guest DanWilson
I'll be moving to the next CM once there is some development.

The sound problem is bigger than I thought. Its very strange, sound works fine in calls so it is obviously working, but no other sound works. I have the same problem on the blade (which is no surprise since I use the same libaudio for both).

Perhaps codecs are missing? Or perhaps Gingerbreads audio works differently to 2.2's.

Link to comment
Share on other sites

The first post has been updated with a new rom. Its uploading now.

Don't expect much. Its very early and may be worse than the SDK based roms. Sound should work in calls, but there is no other sound. Whenever something tries to play a sound mediaserver crashes, so that is slowing it down badly.

I will try to get further with the audio problems tomorrow. That is the top priority at the moment.

Link to comment
Share on other sites

Guest hungary
The first post has been updated with a new rom. Its uploading now.

Don't expect much. Its very early and may be worse than the SDK based roms. Sound should work in calls, but there is no other sound. Whenever something tries to play a sound mediaserver crashes, so that is slowing it down badly.

I will try to get further with the audio problems tomorrow. That is the top priority at the moment.

Thanks! Its working OK. Little slower than 2.2 AOSP and Cyan with the same applications.

Link to comment
Share on other sites

Guest mikeb90

in different forums has been reported the news about what i said, that honeycomb is goint to be a minor release.... it's not up to me contracticting you... but i read this news and decided to share with sll of you in this forum xD

Link to comment
Share on other sites

in different forums has been reported the news about what i said, that honeycomb is goint to be a minor release.... it's not up to me contracticting you... but i read this news and decided to share with sll of you in this forum xD

Honeycomb is android 3.0, so it it not a minor release it's gonna be HUMONGOUS !!!

And most of all, tablet oriented supporting resolutions up to 1280x720, and a new interface that excludes physical buttons...

So yea, it is possible that you read it somewhere wrong.

Link to comment
Share on other sites

A new rom is uploading. This one should be fairly usable if anyone want to try it. I haven't tried Gapps yet, but it should work. The market fingerprint will need to be changed to find anything.

It appears the microphone doesn't work in speaker phone. Do my other roms have that problem?

See first post for link and change log.

Edited by Tom G
Link to comment
Share on other sites

Guest nizarovich
A new rom is uploading. This one should be fairly usable if anyone want to try it. I haven't tried Gapps yet, but it should work. The market fingerprint will need to be changed to find anything.

It appears the microphone doesn't work in speaker phone. Do my other roms have that problem?

See first post for link and change log.

yep file not found ;D

Link to comment
Share on other sites

Guest Richard_Arkless

Wow well done tom, couple of questions before I try it, is this as fast as 2.2 port (both the vanilla and the cm), is it as stable and does root, dtapp2sd, etc work with it

oh and anyone uploaded any recent videos of the pulse running this

Edited by Richard_Arkless
Link to comment
Share on other sites

Guest hungary
A new rom is uploading. This one should be fairly usable if anyone want to try it. I haven't tried Gapps yet, but it should work. The market fingerprint will need to be changed to find anything.

It appears the microphone doesn't work in speaker phone. Do my other roms have that problem?

See first post for link and change log.

Thanks for the update. The latest mdpi gapps dont work :) Without the gapps its ok.

SDcard mount dont work :S (without or with ext partition)

Edited by hungary
Link to comment
Share on other sites

Guest fanyuxiao
Its slow, but it boots and so far is fairly stable.

Working

RIL

3G

Wifi

Audio

Bluetooth

Lights

SD card

Not working

Sensors

Camera

pulse-gingerbread-aosp-0.2.zip

Flash with fastboot. Wipe data/cache.

Change log

AOSP 02

Fixed audio

Fixed bluetooth

Fixed lights

Fixed SD card

AOSP 0.1

Audio partially working. It works in calls, but nothing else.

Pre AOSP source.

test2

Fixed 3G.

Enabled JIT. Feels a bit quicker.

Fixed Wifi.

Add EGL libs. Not sure if egl is working right.

After the test found that: talk is not normal, not into the system to restart, unless the re-winpe 2 items, the speed can not, sd card can not be used.

gingerbread-pulse-test1 this version of the dial panel but I do not know how to extract.

Thank you very much TOM @ G's work

Tribute

by Ronstorm

Link to comment
Share on other sites

Guest dimben1

Bonjour

Besoin d'aide j'aurrais Vraiment, mon «U8230» Étais en "CM6, béta 0.4" probleme il Arriver m'ai des Nations Unies et J'Ai formater mon PC lun. téléphone depui.

DEPUIS Tout avais disparu et JE me Retrouvé en 2.1 et impossible de changeur, JE Vais sur 3ROM MANAGER "et CELA me dit

«Doit etre Votre téléphone Roote verser Manager ROM utiliser». Impossible de TROUVER DANS super utilisateur "system / bin / su" ou "" / system / xbin / su ""

Bonjour

J'ai vraiment besoin d'aide, mon «U8230" accessoires "CM6, beta 0.4" est un problème moi-même atteint et je format mon téléphone depui mon PC.

Depuis tout avait disparu et je me suis retrouvé en 2.1 et ne peut pas changer, je vais sur le gestionnaire de 3ROM "et il me dit

"Votre téléphone doit être root pour utiliser le Gestionnaire de ROM. Impossible de trouver une grande utilité dans" système / bin / su "ou" "/ system / xbin / su" "

aider moi s'il vous plaît

Mod Note: Please use English in these forums. There are specific forums for your language on the site.

Cheers

Phill

Mod Note: S'il vous plaît utiliser l'anglais dans ces forums. Il existe des forums spécifiques à votre langue sur le site.

Vive

Phill

Link to comment
Share on other sites

Guest Hubert FONGARNAND

It works on my U8230.

Problems :

-Slow interface (it seems the HW/Composition is not active)

-3G is not working automaticaly (i think we have to manually enter Bouygues parameters)

-SDcard is not working at boot... but it works if i remove and re-insert the sd card

- Music is not working (crash in logcat for

F/OMXMaster( 2044): frameworks/base/media/libstagefright/omx/OMXMaster.cpp:90 err != OMX_ErrorNoMore

SYSTEM_TOMBSTONE)

E/MediaPlayer( 2019): Unable to to create media player

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.