Jump to content

Basic CM61-Pulse0.40 ROM installation with modifications


Guest twrock
 Share

Recommended Posts

telefonumda 2.1 android yüklü ve facebook uygulamasından facebook video izliyorum. ama sizin rom izleyemiyorum .rom içine gömülü video codec değiştirin.çünkü codec çok kötü

2.1 installed on my phone and facebook application, facebook android watch video. but I can not watch your rum. rom change into the embedded video codec. codec is very bad

Edited by romea
Link to comment
Share on other sites

Hello . I have problems do install any aplications on this version . I had try to install aplications from android market , and from the sdcard . The result is the same, when he try to start the installation , reboot .

My Huawei is 8230, and if i try other verions everything is ok .

I have format SDCARD complete, create new partitions,sd-ext, swp , install the new firmware .

Is any one with same problem ??

All the best

Padrao .

Link to comment
Share on other sites

The result is the same, when he try to start the installation , reboot .

I have the exact same problem.

Are you installing with DTapps2sd? ... I am (coz I want it) but when I run 'a2sd check' it complains about a not mounted ext2 partition.

I guess this is the root of the problem,.. apps2sd not working properly, so when I try to install apps the phone reboots!

So I think apps2sd's problem is somehow related to how I partitioned my SD card?... I have a 2GB card, with the following partitions (I can't remember exactly and I don't have my phone on me)

partition1 - fat32 (lba) - 1.4GB

partition2 - ext2 - 560MB

partition3 - swap - 34MB

I wanted to get the 2nd and 3rd parititions to 512MB and 32MB respectively, but I my version of GParted seems to always rounds things up/down so I could not get it to be exactly as I wanted (not sure if that is even a problem thou)

Not sure how to proceed, clearly this rom does work fine as others have got it working fine but I just can't seem to get it going.

I have run through the following steps.

1. install 2.1 T-mobile UK rom

2. install clockwork recovery (via fastboot)

3. install CM6 rom... then dtapps2sd ... then gapps..

All seems ok, except the problem this post is about??

Link to comment
Share on other sites

I have this same problem when I install the aio v5 version, and the solution was to do a wipe of the cache. but if you are installing the latest version of twrock should not have that problem because it makes the automatic wipe. anyway try to do the wipe if that solves the problem.

Link to comment
Share on other sites

Hi i have create all partitions with clockwork 3.05, it´s very easy to configure .

After this i have install clockwork 2.05, because wit 3 version i can´t install any rom , i get error regarding phone version, 8220 and mine is 8230 .

All the firmware runs ok, i had install first the cm rom, dtapps2sd and then gapps .

maybe the problem is regading the clockwork version . . . .

All the Best

Padrao

I have the exact same problem.

Are you installing with DTapps2sd? ... I am (coz I want it) but when I run 'a2sd check' it complains about a not mounted ext2 partition.

I guess this is the root of the problem,.. apps2sd not working properly, so when I try to install apps the phone reboots!

So I think apps2sd's problem is somehow related to how I partitioned my SD card?... I have a 2GB card, with the following partitions (I can't remember exactly and I don't have my phone on me)

partition1 - fat32 (lba) - 1.4GB

partition2 - ext2 - 560MB

partition3 - swap - 34MB

I wanted to get the 2nd and 3rd parititions to 512MB and 32MB respectively, but I my version of GParted seems to always rounds things up/down so I could not get it to be exactly as I wanted (not sure if that is even a problem thou)

Not sure how to proceed, clearly this rom does work fine as others have got it working fine but I just can't seem to get it going.

I have run through the following steps.

1. install 2.1 T-mobile UK rom

2. install clockwork recovery (via fastboot)

3. install CM6 rom... then dtapps2sd ... then gapps..

All seems ok, except the problem this post is about??

Link to comment
Share on other sites

Hi i have create all partitions with clockwork 3.05, it´s very easy to configure .

After this i have install clockwork 2.05, because wit 3 version i can´t install any rom , i get error regarding phone version, 8220 and mine is 8230 .

All the firmware runs ok, i had install first the cm rom, dtapps2sd and then gapps .

maybe the problem is regading the clockwork version . . . .

All the Best

Padrao

I have not had good things happen when using CW Recovery 3.x. I currently use CW Recovery 2.5.0.7 to do all my installations.

Link to comment
Share on other sites

I have not had good things happen when using CW Recovery 3.x. I currently use CW Recovery 2.5.0.7 to do all my installations.

Am I right in saying you can't do the partitioning with CWR 2.5 ?? ...

I use 2.5.x and the flashing etc. works fine but I can't see anywhere to do the correct SDCard partitioning .. hence I have tried both fdisk and GParted. This leaves me thinking perhaps I have done something wrong with the sizes/formats/positions of the partitions and therefore DTapps2sd does not work :huh:

Link to comment
Share on other sites

Am I right in saying you can't do the partitioning with CWR 2.5 ?? ...

I use 2.5.x and the flashing etc. works fine but I can't see anywhere to do the correct SDCard partitioning .. hence I have tried both fdisk and GParted. This leaves me thinking perhaps I have done something wrong with the sizes/formats/positions of the partitions and therefore DTapps2sd does not work :huh:

No, I don't partition my SD card with CWRecovery. I use Gparted in Linux for that. But I install the roms using CWR 2.5.0.7.

Link to comment
Share on other sites

Twrock there is a new version of the uk 2.1 version which fixes some bugs, maybe you can open it and find out some things to make your rom even better than it is right now!

http://support.t-mobile.co.uk/help-and-sup...FTWAREDOWNLOADS

DO NOT USE WITH Twrock'S ROM YET THERE ARE MUCH BUGS USING BOTH

Edited by sasukekun67
Link to comment
Share on other sites

No, I don't partition my SD card with CWRecovery. I use Gparted in Linux for that. But I install the roms using CWR 2.5.0.7.

twrock you can tell me where I can find a good tutorial to partition the sd with windows or linux. if you have a tutorial itself better.

Edited by dark8899
Link to comment
Share on other sites

Problem solved ! ! ! !

I have installed recovery-clockwork-2.5.0.7

The problem was caused becaused i had recovery-clockwork-2.5.0.5 .

Thanks for all support, and its a great rom .

I have this same problem when I install the aio v5 version, and the solution was to do a wipe of the cache. but if you are installing the latest version of twrock should not have that problem because it makes the automatic wipe. anyway try to do the wipe if that solves the problem.
Link to comment
Share on other sites

I also have reboots after installing app from market or SD, downloading goes fine

than it says installing.... locks up and reboots.

I did install clockwork 2.5.0.7

I wiped everything before

and after i wiped /cache /dalvik-cache

bat stats

how to solve this?

Link to comment
Share on other sites

a question to the OP,

err are you adding your "fixes" to the git hub for the CM6 project encase someone down the line wants to build it from that source?

it would be a good thing if you are. if you are not, would it not seem like a good idea?

it is merely a request as i may want to build from that source in summer holidays and put some life back into the pulse which i got for my sister.

cheers

Link to comment
Share on other sites

a question to the OP,

err are you adding your "fixes" to the git hub for the CM6 project encase someone down the line wants to build it from that source?

it would be a good thing if you are. if you are not, would it not seem like a good idea?

it is merely a request as i may want to build from that source in summer holidays and put some life back into the pulse which i got for my sister.

cheers

No. I know nothing of the existence of a CM6 project git hub. I am not a developer. I do not even begin to understand how that kind of thing works.

What I do is so simple that anyone with a simple understand who looks at my changelog could do it themselves. I don't work with the source code. I merely repackaged the rom that Tom made, adding to it a number of "fixes" that amount to nothing more than copying or replacing a few files and editing a few lines of text in a few other files. Anyone can open up the zip files and see exactly what is there. So I think the real question is whether or not people have access to Tom's source.

So if you want to work on this rom yourself, all you need to do is unzip it and have a look. Other than that, I don't know what has been done at the code level to get things working. You might be assuming I know more than I do. :huh: But I'm serious when I say that I don't have any special knowledge or computer skills.

Link to comment
Share on other sites

twrock you can tell me where I can find a good tutorial to partition the sd with windows or linux. if you have a tutorial itself better.

First, here's a link to a Windows partitioning tool that someone suggested. I've not used it myself.

http://www.partitionwizard.com/free-partition-manager.html

Here's a link directly to a post I did some time ago detailing how to use Gparted with screenshots. You can find a bootable Gparted CD iso image online if you don't have a Linux box to work with. Just download the CD iso, burn the image to a CD, and boot into Linux temporarily. Hope that helps.

Oh, and you can use a card reader for you micro SD care or just use you phone in USB drive mode.

Link to comment
Share on other sites

I also have reboots after installing app from market or SD, downloading goes fine

than it says installing.... locks up and reboots.

I did install clockwork 2.5.0.7

I wiped everything before

and after i wiped /cache /dalvik-cache

bat stats

how to solve this?

I have no other idea to tell you to do other than what you say you already did. I don't know why this has happened for a few people.

You can try again to do a full system wipe and format /system, but I believe the newest version of the rom should be formating both /system and /cache. (Disclaimer: although I believe I typed the correct command into the install script to format /cache, I can not guarantee I got it right; I do know that /system is being formated correctly.)

Link to comment
Share on other sites

Twrock there is a new version of the uk 2.1 version which fixes some bugs, maybe you can open it and find out some things to make your rom even better than it is right now!

http://support.t-mobile.co.uk/help-and-sup...FTWAREDOWNLOADS

DO NOT USE WITH Twrock'S ROM YET THERE ARE MUCH BUGS USING BOTH

I played around with both the new UK rom and the German rom last night. They are similar in look, but the German one has a number of Touchpal languages included that are taking up a lot of space in /system. I'm only guessing, but /system partition might be especially large in the German rom to accomodate those files. I used to use the Tre rom for modding since it too had a larger /system partition. But lately, I've moved on to CM and so I just do my best to get things to fit into the smaller UK rom's /system partition.

I have no idea is there is anything useful in those roms to add to the CM rom. I saw no specific apps I wanted. And I have no idea about the value of the underlying code. (That's definitely beyond my understanding.) We seriously need some real developers around here. :huh:

OT: One thing that has always puzzled me was the horrid default wallpaper in the UK roms. What is with a picture of a lake that is tilted so the water looks like it should run out? Couldn't T-Mobile UK come up with something a little better than that? Sheesh, I take better pictures than that with my cellphone! :)

Link to comment
Share on other sites

I played around with both the new UK rom and the German rom last night. They are similar in look, but the German one has a number of Touchpal languages included that are taking up a lot of space in /system. I'm only guessing, but /system partition might be especially large in the German rom to accomodate those files. I used to use the Tre rom for modding since it too had a larger /system partition. But lately, I've moved on to CM and so I just do my best to get things to fit into the smaller UK rom's /system partition.

I have no idea is there is anything useful in those roms to add to the CM rom. I saw no specific apps I wanted. And I have no idea about the value of the underlying code. (That's definitely beyond my understanding.) We seriously need some real developers around here. :huh:

OT: One thing that has always puzzled me was the horrid default wallpaper in the UK roms. What is with a picture of a lake that is tilted so the water looks like it should run out? Couldn't T-Mobile UK come up with something a little better than that? Sheesh, I take better pictures than that with my cellphone! :)

Twrock,could you plz share your explanation about compacache,swappy and vmheap?I googled them and have been awared of their orignal meanings but still cant figure out what's the real sense they can make to pulse.If I have a speedy sd card(c6) with a large partion of swap(96mb) and a little stronger desire for multitask than smothness and care less about battery,what's the best setting of swappy,compcache and vmheap?

Thx in advance!

Regards

Edited by CarpetDiem
Link to comment
Share on other sites

Twrock there is a new version of the uk 2.1 version which fixes some bugs, maybe you can open it and find out some things to make your rom even better than it is right now!

http://support.t-mobile.co.uk/help-and-sup...FTWAREDOWNLOADS

DO NOT USE WITH Twrock'S ROM YET THERE ARE MUCH BUGS USING BOTH

I just flashed twrock's latest room upon the uk update,until now everything works ok.I think the problems you got were probably due to the decrease of the system partition.Just delect sth you may not use in the system patrion of twrocks zip(like bootamination ringtones etc) and resign it,then nothing could be better in flashing.

What's more ,if you are going to flash google apps,it's strongly recommended that you remove the setupwizard app inside,which can cause fcs at startup

Regards

Edited by CarpetDiem
Link to comment
Share on other sites

Twrock,could you plz share your explanation about compacache,swappy and vmheap?I googled them and have been awared of their orignal meanings but still cant figure out what's the real sense they can make to pulse.If I have a speedy sd card(c6) with a large partion of swap(96mb) and a little stronger desire for multitask than smothness and care less about battery,what's the best setting of swappy,compcache and vmheap?

Thx in advance!

Regards

I know very little, and I'm sure of even less. :P I have asked these same questions myself, and not heard any definitive answers. So what I say here is only what I "feel" is true, with no proof whatsoever that it is true. I hope someone who can tell us in simple language will also reply.

It seems to me that if you have swap enabled, compcache is a waste. It seems to be a duplicate function, and I disable it. So that way the system can use all my available ram, and then use the swap partition for caching of running apps.

But when you disable compcache in this rom, swappiness jumps up to 60 (something that happens in the rom and I have no idea how to change that default behavior). But swappy60 has always made my phone lag terribly no matter what size swap partition I had. So I set swappy30 all the time. (You can check swappiness with "cat /proc/sys/vm/swappiness" in terminal.)

I previously had a 64mb swap partition. It seemed to be nothing but a waste to have it that large. In order to avoid lag, I had to use swappy15. So what's the point? I reduced swap to 32mb and I use swappy30. That "feels" good. Others have explained that the swappiness number has to do with how much of the swap partition can be used. But I don't understand that. Otherwise, why not just have a 10mb swap partition and set swappy90? I really don't know, and I really don't understand.

So as you can see, most of what I believe is simply through trial and error. I've tried to read what other more knowledgeable people have written, but there seems to be somewhat contradictory information about all of this. Additionally, the lowmem killer numbers seem to have a significant influence as well. But everything seems to effect everything else. So it is kind of like a witch's brew; if you can get the exact right amounts of everything, it is very powerful. :huh:

So all of that should make it obvious to all that I really am just guessing most of the time. :)

Link to comment
Share on other sites

Sadly I still get camera application FC after only taking two or three pictures :huh:

Until this is resolved in any 2.2 rom I won't switch over because I refuse to give up an important feature like that

Link to comment
Share on other sites

Sadly I still get camera application FC after only taking two or three pictures :huh:

Until this is resolved in any 2.2 rom I won't switch over because I refuse to give up an important feature like that

You can use the paid app Vignette.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.