Jump to content

29 Jun: 4.0.0.5 - ClockworkMod Recovery for the LG Optimus 2X


Guest PaulOBrien
 Share

Recommended Posts

Just to be sure (as this happened to me once also): You need to release both buttons once the orange "A N D R O I D" letters show up.

About reversing CWM: Paul has posted a stock recovery image which can (ironically) applied via CWM to revert to stock recovery. Just search this forum and you'll find it.

Cheers

aMpeX

About reversing CWM: Ok, I had a hunch that what you said would help me – so I was right about that. :)

Now CWM itself: If I reboot normally, I don't even get the "Android" letters. They only appear after a factory reset. So that's another strange thing :/

/edit: Does the CWM installation work with Win Vista (32bit) – since tomorrow I will have the possibilty to get my hands on a Win Vista device.

Edited by deeotee
Link to comment
Share on other sites

About reversing CWM: Ok, I had a hunch that what you said would help me – so I was right about that. :)

Now CWM itself: If I reboot normally, I don't even get the "Android" letters. They only appear after a factory reset. So that's another strange thing :/

/edit: Does the CWM installation work with Win Vista (32bit) – since tomorrow I will have the possibilty to get my hands on a Win Vista device.

Do you mean a hardware (button induced) or software induced Factory Reset?

If I want to enter CWM on mine I turn it off, then start pressing The Power Button + Vol Down button until the "Android" appear, then I release both buttons and the phone boots to CWM

Link to comment
Share on other sites

Do you mean a hardware (button induced) or software induced Factory Reset?

If I want to enter CWM on mine I turn it off, then start pressing The Power Button + Vol Down button until the "Android" appear, then I release both buttons and the phone boots to CWM

Nevermind, I got it to work. Thanks a lot though. :)

Link to comment
Share on other sites

When do you know that you have flashed CWM? I tried like 10 times, but every time my cellphone went back to factory mode, upon trying to reboot with vol. down and power button...

Open command prompt and go to the folder you uncompressed (Windows 7 is easy, open folder, shift-right click in empty space, Open Command Window Here) and run it from there (type install-clockworkmod-windows.bat). Then you see the errors.

If all works then power off your phone. Hold vol-down and then hold power. Wait till logo comes up on the screen and then release both buttons.

Link to comment
Share on other sites

Okay, I've followed the instructions in the first post, and I get the following error:

XXX$ ./install-clockworkmod-mac.sh

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

error: device not found

error: device not found

Any ideas?

EDIT; Yes debugging is on. Yes it's plugged in.

EDIT2; Okay, not sure what happened, just tried again and it worked. I tired on a windows laptop, put it back into the mac and TADA, clockworkmod :)

Edited by Deoxyribonucleic_Acid
Link to comment
Share on other sites

I having problem restoring to my stock nandroid backup.

The restore finishes fine (no errors) but the device gets stuck on the LG logo. i assume the issue is with stock only supporting ETX3 while Paul's MCR converts the system to EXT4.

I am running the latest recovery so i assume it would support both.

Here is what i did in details, maybe someone can help:

- Installed the latest recovery image from this thread.

- Did a nandroid backup of my stock firmware.

- wiped and flashed fr7 MCR. the device booted just fine.

- Did a a nandroid backup of fr7

- wiped and tried to restore back to stock. getting stuck at the LG logo.

Any idea?

Use the EXT3 revert package posted in this forum.

P

Hello, I have the same problem as IBTECH.

The EXT3 revert package is the forum of the NVFlash way of flashing? if no, where I can find the ext revert package? I looking on several post and I dont find it or realize what it is!!

Anyone could please help me? thank you!

Link to comment
Share on other sites

I'm pleased to let everyone know that my 99p '2X Recovery Boot' app will now flash ClockworkMod for you the first time you run it and flash new versions as they come available.

Of course, you can still flash it the old way, but this just makes it easier for some people.

Enjoy! :)

P

Link to comment
Share on other sites

MD5 checksum error if backup folder is renamed, the original folder name is "2011-04-07.13.17.56", I renamed it to "2011-04-07.13.17.56 (Stock Rom)" for easier reading. It show MD5 checksum error when I try restore it.

Link to comment
Share on other sites

First time I installed your App and then tried to install CWM it didn't do anything at all until I did a reboot. Then after that when I tried the app it asked for SU-permission, not the first time :S

Now it rebooted right away but the only thing I can see is a box with orange arrow and a little green Andy, but nothing more! Just like it freezed there!

Edit 1:

When pressing homebutton I see that it just sits and waits on "Formatting MISC:..." !

Edit 2:

It's the Android Recovery-mode I'm in, and you can't press the power-button on any option!

Edited by ElecTricX
Link to comment
Share on other sites

You have the stock recovery, not clockworkmod installed...

P

I got the update of your app today and ever since I rebooted into recovery from the new version (after it updated the recovery), I can't perform a backup (says something like "couldn't find /sdcard"). I have to shut down and boot up the recovery using the key combo in order for it to mount my SD :)

Link to comment
Share on other sites

You have the stock recovery, not clockworkmod installed...

P

But wasn't your app 2X Recovery + Flash (bought in market) suppose to flash in CWM? That was a new feature right? Or have I totaly missunderstood the app?

Link to comment
Share on other sites

DO NOT RUN THIS ON THE G2X! The partition layout is different, doing so will do bad things to your device. I will release a G2X compatible version when I am back online in a week's time!

Link to comment
Share on other sites

help!! i just received my O2X this morning!

charged it to full battery

and wanted to install CWM

i installed LG mobile tool and PC suite (because when i plug my phone in, it said 'cannot find driver, install unsucessful' - something like that

download 3.0.1.4 r1, extracted

then connect usb, and put on debug mode

and double click 'install-clockworkmod-windows.bat'

and it just stopped at the same screen for more than 30minutes!!

post-865458-1302910612_thumb.png

i am using windows 7

i've tried closing it, reopening, reinstall drivers, restarting comp/phone, taking phone battery out. nothing worked

i tried typing in C:\>adb-windows push clockworkmod.img /data/local/ on CMD, but it wont even let me put in a letter!

i dont know what im missing! help!

--- its been fixed! it was Android Platform Sooner Single ADB Interface error... download the driver from different sites and reinstalled a few times and it worked!! :)

Edited by netz
Link to comment
Share on other sites

I'm having trouble, I get this on Win Vista when running install-clockworkmod-windows.bat:

C:\Users\Administrator\Desktop\LG-Optimus-2X - CustomROM\clockworkmod\3.0.1.4-r1

-2x-clockworkmod-modaco>adb-windows push psneuter /data/local/psneuter

adb server is out of date. killing...

ADB server didn't ACK

* failed to start daemon *

error:

C:\Users\Administrator\Desktop\LG-Optimus-2X - CustomROM\clockworkmod\3.0.1.4-r1

-2x-clockworkmod-modaco>adb-windows shell chmod 4755 /data/local/psneuter

adb server is out of date. killing...

* daemon started successfully *

C:\Users\Administrator\Desktop\LG-Optimus-2X - CustomROM\clockworkmod\3.0.1.4-r1

-2x-clockworkmod-modaco>adb-windows shell /data/local/psneuter

adb server is out of date. killing...

* daemon started successfully *

mmap() failed. Operation not permitted

C:\Users\Administrator\Desktop\LG-Optimus-2X - CustomROM\clockworkmod\3.0.1.4-r1

-2x-clockworkmod-modaco>adb-windows wait-for-device

adb server is out of date. killing...

ADB server didn't ACK

* failed to start daemon *

error:

C:\Users\Administrator\Desktop\LG-Optimus-2X - CustomROM\clockworkmod\3.0.1.4-r1

-2x-clockworkmod-modaco>adb-windows push clockworkmod.img /data/local/

adb server is out of date. killing...

* daemon started successfully *

1942 KB/s (4651008 bytes in 2.337s)

C:\Users\Administrator\Desktop\LG-Optimus-2X - CustomROM\clockworkmod\3.0.1.4-r1

-2x-clockworkmod-modaco>adb-windows shell dd if=/data/local/clockworkmod.img of=

/dev/block/mmcblk0p7

adb server is out of date. killing...

* daemon started successfully *

Any suggestions?

Edit: Ahh, it seemed it worked anyway. - Please ignore my entire post.

Edited by castab
Link to comment
Share on other sites

Hi

I want to return my O2X but I need to remove the clockworkmod and unroot before I do. I see everywhere how to install it but not how to remove it. Anyone who can help please?

Thanks in advance.

Edited by shoulim
Link to comment
Share on other sites

Hi everybody,

could it be that ROM Manager is not compatible with the LGO2x? I tried to boot into Recovery out of ROM Manager but the phone simply reboots?

Any suggestions?

Thanks in advance

Link to comment
Share on other sites

WTF Paul. I just bought and installed '2X Recovery Boot' and wanted to boot in Recovery and nothing more happens. The Phone does not boot anymore. The LG-Logo pops up for a second and then black screen. Help?

It is not possible to boot in recovery.

Dangerous piece of software. The phone seems completely broken.

/EDiT: I rescued my phone with NVFlash Stock ROM. Everything fine again. But I will never use your App. Any chance to get my money back?

Edited by xfighter11
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.