Jump to content

[ROM] Corvus5 (newbe5 and Corvus teamed ROM)


Guest the_corvus
 Share

Recommended Posts

Guest ptbw

For everyone using the USB Host feature of this excellent ROM, I have produced a Grid "Special Edition" version of the Host Mode Indicator.

Thanks to newbe5 for the graphics and simonta for the original idea.

Note if you really want to change the graphics for some of your own you can by putting images on your SD card as follows:

For the small widget

/sdcard/data/vegausbindicator/susbs.png

/sdcard/data/vegausbindicator/susbh.png
For the large widget
/sdcard/data/vegausbindicator/usbs.png

/sdcard/data/vegausbindicator/usbh.png

The apk can be found here:

http://code.google.com/p/ptbw-codespace/do...deindicator.apk

Thanks to newbe5 and Corvus for such a good ROM.

post-798666-1304537661_thumb.jpg

Link to comment
Share on other sites

Guest newbe5
For everyone using the USB Host feature of this excellent ROM, I have produced a Grid "Special Edition" version of the Host Mode Indicator.

Thanks to newbe5 for the graphics and simonta for the original idea.

Note if you really want to change the graphics for some of your own you can by putting images on your SD card as follows:

For the small widget

/sdcard/data/vegausbindicator/susbs.png
/sdcard/data/vegausbindicator/susbh.png[/code] For the large widget
[code]/sdcard/data/vegausbindicator/usbs.png
/sdcard/data/vegausbindicator/usbh.png

The apk can be found here:

http://code.google.com/p/ptbw-codespace/do...deindicator.apk

Thanks to newbe5 and Corvus for such a good ROM.

Lovely! nice work mate! This will be integrated into the next update of Corvus5 :mellow:

Link to comment
Share on other sites

Guest duvee

can you also include the usb-mode app? (the one from m8 rom)

I'm using the m8 rom now, because I wanted to go in host mode with this switcher with the corvus rom, but my tablet crashed in every reboot. With the m8 rom it won't crash, using the same app.

I really like your rom! can you also explain how to apply the Grid files? (see post above)

Link to comment
Share on other sites

Guest Ste_B

Just got round to installing this.

Big thanks for the ROM guys only played about with it for half an hour or so but really pleased so far.

Actually gonna update it to the newer release now.

Keep up the great work, much appreciated :mellow:

Link to comment
Share on other sites

Guest simonta
Just got round to installing this.

Big thanks for the ROM guys only played about with it for half an hour or so but really pleased so far.

Actually gonna update it to the newer release now.

Keep up the great work, much appreciated :o

OK, I'll bite. :mellow:

What newer release?

Link to comment
Share on other sites

Guest Ste_B
OK, I'll bite. :mellow:

What newer release?

Forgive my wording, but isn't corvus5kernal0.2 newer?

Suppose it isn't a release but a tweak?

Link to comment
Share on other sites

Guest ptbw
can you also include the usb-mode app? (the one from m8 rom)

I'm using the m8 rom now, because I wanted to go in host mode with this switcher with the corvus rom, but my tablet crashed in every reboot. With the m8 rom it won't crash, using the same app.

I really like your rom! can you also explain how to apply the Grid files? (see post above)

The mode switcher app will not work with this or most(all?) new roms. these roms use the trick of holding the back button during booting. Using the switcher app is a quick way to stopping your vega booting and forcing you to flash it back to stock.

HTH

Edited by ptbw
Link to comment
Share on other sites

Guest newbe5
Forgive my wording, but isn't corvus5kernal0.2 newer?

Suppose it isn't a release but a tweak?

Yup, it is a newer version of the Kernel than comes packaged with this ROM. There are also a couple of other fixes that are posted around this forum (and some more that myself, Corvus and ptbw are working on). Once we are happy with this collection of fixes, updates and tweaks, we will release a "Service Pack" for Corvus5 that updates you to the newest version of everything in one flash, without having to pick up all the pieces from everywhere.

This is still in the works, and won't be released until it has all been properly tested to the best of our abilities! But just so you all know, we are definitely still here and working to give you the best experience Corvus5 can offer :mellow:

newbe5

Link to comment
Share on other sites

Guest newbe5

Added the awesome Host Mode Indicator Widget app by ptbw to my main post. Thanks a lot for your work (and to simonta as well!)!

newbe5

Edited by newbe5
Link to comment
Share on other sites

Guest tdmanutd

Hi There, this is my first post in the forum :mellow:

So im using Vega in Indonesia (rebrand as Zyrex OnePad in here) and the model have 3g slot in it.

I've flashed my vega with this ROM and i like every bit of it.

The only problem there aren't any option to in settings to enable the 3g. I have flashed the ROM with 3gfiles.zip too hoping the options will appear, but it doesn't.

Is there any solution to my problem? or the ROM just support the non-3g model only?

I've read everything about vega in this forum and at the XDA and can't find the solution. :D

in the meantime i'm using Gambaro ROM which is support the 3g model, but i prefer to use corvus5 ROM :o

Thanks in advance

Link to comment
Share on other sites

Guest beegee1962
Hi There, this is my first post in the forum :o

So im using Vega in Indonesia (rebrand as Zyrex OnePad in here) and the model have 3g slot in it.

I've flashed my vega with this ROM and i like every bit of it.

The only problem there aren't any option to in settings to enable the 3g. I have flashed the ROM with 3gfiles.zip too hoping the options will appear, but it doesn't.

Is there any solution to my problem? or the ROM just support the non-3g model only?

I've read everything about vega in this forum and at the XDA and can't find the solution. :D

in the meantime i'm using Gambaro ROM which is support the 3g model, but i prefer to use corvus5 ROM :D

Thanks in advance

Go Settings->Accounts&Sync

Push Add account

Select Google

Push Menu and press "Wireless settings" that appear at the bottom of the screen

Then you see the Mobile Network Settings.

Hope your 3G modem works with CorvusROM, as my Huawei 3G does not. :mellow:

Link to comment
Share on other sites

Guest beegee1962
For everyone using the USB Host feature of this excellent ROM, I have produced a Grid "Special Edition" version of the Host Mode Indicator.

Thanks to newbe5 for the graphics and simonta for the original idea.

Note if you really want to change the graphics for some of your own you can by putting images on your SD card as follows:

For the small widget

/sdcard/data/vegausbindicator/susbs.png

/sdcard/data/vegausbindicator/susbh.png
For the large widget
/sdcard/data/vegausbindicator/usbs.png

/sdcard/data/vegausbindicator/usbh.png

The apk can be found here:

http://code.google.com/p/ptbw-codespace/do...deindicator.apk

Thanks to newbe5 and Corvus for such a good ROM.

Thank you very much for this!

Works great on my Ganbarou V0.3 ROM with the CorvusKernel 0.2!

Is it ok if I integrate it into the next version of my ROM?

Link to comment
Share on other sites

Guest HunteronX
For everyone using the USB Host feature of this excellent ROM, I have produced a Grid "Special Edition" version of the Host Mode Indicator.

Thanks to newbe5 for the graphics and simonta for the original idea.

Note if you really want to change the graphics for some of your own you can by putting images on your SD card as follows:

For the small widget

/sdcard/data/vegausbindicator/susbs.png

/sdcard/data/vegausbindicator/susbh.png
For the large widget
/sdcard/data/vegausbindicator/usbs.png

/sdcard/data/vegausbindicator/usbh.png

The apk can be found here:

http://code.google.com/p/ptbw-codespace/do...deindicator.apk

Thanks to newbe5 and Corvus for such a good ROM.

Thanks for this!

Link to comment
Share on other sites

Guest tdmanutd
Go Settings->Accounts&Sync

Push Add account

Select Google

Push Menu and press "Wireless settings" that appear at the bottom of the screen

Then you see the Mobile Network Settings.

Hope your 3G modem works with CorvusROM, as my Huawei 3G does not. :mellow:

OMG! Works like a charm! Thanks a lot!

and the silly thing is it's so easy and I never find the solution before :o

Link to comment
Share on other sites

Guest newbe5

OK so quick update and a request to all users to please remind me of issues that need fixing! The current state of SP1 is as follows:

Kernel updated to latest by Corvus (including 1.5ghz overclock and no need for setcpu txt file any more)

Blue Camera LED Fixed (thanks to new kernel)

50% volume issue fixed, volume now increases all the way to 100%

USB Mode check widget added to /data/app as standard

Titanium Backup added to /data/app as standard (as requested by some users)

This is what is confirmed so far, there is some other (nice) stuff in the works too, but I will hold off on that until I am sure it will work. Can anyone please suggest fixes that need attending to? NOTE: "I Can't install this ROM, because of problem a/b/c or USB issue bleh..." is not what I mean.... am asking for actual BUGS or issues people have found?

newbe5

Link to comment
Share on other sites

Guest phoenix40uk
So you check you are in host mode, with this memory stick and doesnt mount in /mnt/usbdisk ? It works for me...

Once you have connected the stick, enter connectbot and exec:

su

mount

and you must see some mount points un /mnt

I suppose you had tested stick in a pc... :mellow:

Corvus.

Hi: I am having the same issue - bit when i run mount in connectbot, I get:

rootfs /rootfs ro,relatime 0 0

tmpfs /dev tmpfs rw,relatime,mode=755 0 0

devpts /dev/pts devpts rw,relatime,mode=600 0 0

proc /proc proc rw,relatime 0 0

sysfs /sys sysfs rw,relatime 0 0

none /acct cgroup rw relatime,cpuacct 0 0

tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0

none /dev/cpuct1 cgroup rw,relatime,cpu 0 0

/dev/block/mntdblock3 /system yaffs2 rw,relatime 0 0

/dev/block/mntdblock6 /data yaffs2 rw,nosuid,nodev,relatime 0 0

/dev/block/mntdblock4 /cache yaffs2 rw,nosuid,nodev,relatime 0 0

/dev/block/vold/179:25 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,

llow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

/dev/block/vold/179:25 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,

llow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

tmpfs /mnt/sdcard/.android_secure tmpfs ro,relatime,size=0k,mode=0000 0 0

/dev/block/dm-1 /mnt/asec/com.rovio.angrybirds-1 vfat ro,dirsync,nosuid,nodev,noexec,relatime,uid=1000,fmask=0222,dmask=0222,codepage=

p437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

/dev/block/dm-1 /mnt/asec/com.derekentringer.bigfartbutton-1 vfat ro,dirsync,nosuid,nodev,noexec,relatime,uid=1000,fmask=0222,dmask=0222,codepage=

p437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

Device has been tested on a pc, is visible using Modaco R8 (FAT32 format). Can anyone help?

Thanks

Link to comment
Share on other sites

Guest phoenix40uk
Hi: I am having the same issue - bit when i run mount in connectbot, I get:

rootfs /rootfs ro,relatime 0 0

tmpfs /dev tmpfs rw,relatime,mode=755 0 0

devpts /dev/pts devpts rw,relatime,mode=600 0 0

proc /proc proc rw,relatime 0 0

sysfs /sys sysfs rw,relatime 0 0

none /acct cgroup rw relatime,cpuacct 0 0

tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0

none /dev/cpuct1 cgroup rw,relatime,cpu 0 0

/dev/block/mntdblock3 /system yaffs2 rw,relatime 0 0

/dev/block/mntdblock6 /data yaffs2 rw,nosuid,nodev,relatime 0 0

/dev/block/mntdblock4 /cache yaffs2 rw,nosuid,nodev,relatime 0 0

/dev/block/vold/179:25 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,

llow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

/dev/block/vold/179:25 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,

llow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

tmpfs /mnt/sdcard/.android_secure tmpfs ro,relatime,size=0k,mode=0000 0 0

/dev/block/dm-1 /mnt/asec/com.rovio.angrybirds-1 vfat ro,dirsync,nosuid,nodev,noexec,relatime,uid=1000,fmask=0222,dmask=0222,codepage=

p437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

/dev/block/dm-1 /mnt/asec/com.derekentringer.bigfartbutton-1 vfat ro,dirsync,nosuid,nodev,noexec,relatime,uid=1000,fmask=0222,dmask=0222,codepage=

p437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0

Device has been tested on a pc, is visible using Modaco R8 (FAT32 format). Can anyone help?

Thanks

Please ignore this. I am speaking to Corvus on another thread.

Link to comment
Share on other sites

Guest andrewdolphin
OK so quick update and a request to all users to please remind me of issues that need fixing! The current state of SP1 is as follows:

Kernel updated to latest by Corvus (including 1.5ghz overclock and no need for setcpu txt file any more)

Blue Camera LED Fixed (thanks to new kernel)

50% volume issue fixed, volume now increases all the way to 100%

USB Mode check widget added to /data/app as standard

Titanium Backup added to /data/app as standard (as requested by some users)

This is what is confirmed so far, there is some other (nice) stuff in the works too, but I will hold off on that until I am sure it will work. Can anyone please suggest fixes that need attending to? NOTE: "I Can't install this ROM, because of problem a/b/c or USB issue bleh..." is not what I mean.... am asking for actual BUGS or issues people have found?

newbe5

For me, other than the screen viewing angles which obviously can't be resolved in a ROM (if only!) my only other real gripe is the sound quality. Now there's no certainty it's a software/kernel issue but if someone more skilled than I could look into the audio parts of the kernel to see if there are any improvements that can be made that would be fanatastic.

http://android.modaco.com/content/advent-v...-at-any-volume/

Link to comment
Share on other sites

Guest newbe5
For me, other than the screen viewing angles which obviously can't be resolved in a ROM (if only!) my only other real gripe is the sound quality. Now there's no certainty it's a software/kernel issue but if someone more skilled than I could look into the audio parts of the kernel to see if there are any improvements that can be made that would be fanatastic.

http://android.modaco.com/content/advent-v...-at-any-volume/

Audio is something I am working on today, but my hearing is not great, so I cannot really tell where there is distortion when I am testing :/ Are there any ROM's that have this working? CM7 for example? Usually a good way to test if something is a software issue is to try other ROMS. If one of them works, then it is software, if NONE of them work, then maybe it is a hardware issue?

I can't say I notice much distortion on my Vega, but then I don't know? It's usually loud enough for me to watch movies etc with headphones in (depending on the audio level of the movie) and I don't notice bad quality (but I'm definitely not an audiophile! :mellow:).

newbe5

Link to comment
Share on other sites

Guest Panayioti
Audio is something I am working on today, but my hearing is not great, so I cannot really tell where there is distortion when I am testing :/ Are there any ROM's that have this working? CM7 for example? Usually a good way to test if something is a software issue is to try other ROMS. If one of them works, then it is software, if NONE of them work, then maybe it is a hardware issue?

I can't say I notice much distortion on my Vega, but then I don't know? It's usually loud enough for me to watch movies etc with headphones in (depending on the audio level of the movie) and I don't notice bad quality (but I'm definitely not an audiophile! :mellow:).

newbe5

I cant hear any distortion but the problem with sound is that it doesn't increases after 50% it just stays the same.

Link to comment
Share on other sites

Guest newbe5
I cant hear any distortion but the problem with sound is that it doesn't increases after 50% it just stays the same.

This is fixed and will be patched in SP1.

Link to comment
Share on other sites

Guest Littleun
OK so quick update and a request to all users to please remind me of issues that need fixing! The current state of SP1 is as follows:

Kernel updated to latest by Corvus (including 1.5ghz overclock and no need for setcpu txt file any more)

Blue Camera LED Fixed (thanks to new kernel)

50% volume issue fixed, volume now increases all the way to 100%

USB Mode check widget added to /data/app as standard

Titanium Backup added to /data/app as standard (as requested by some users)

This is what is confirmed so far, there is some other (nice) stuff in the works too, but I will hold off on that until I am sure it will work. Can anyone please suggest fixes that need attending to? NOTE: "I Can't install this ROM, because of problem a/b/c or USB issue bleh..." is not what I mean.... am asking for actual BUGS or issues people have found?

newbe5

Hi Newbe5,

Big thanks to you and Corvus for the excellent work so far. A couple of things that could make your ROM even better (only my opinion of course :mellow: ) : -

1. Working accelerometer (for games) without the need of the toggle switch - This is something that has been achieved in both Fuji-Vega v0.7 (alphaola) and mad-murdocks CM7 nightlies, so not sure if those guys could help you out.

2. Bluetooth & Wifi working together. At the moment if you have Bluetooth on then wifi either stutters badly or doesn't work at all, they both work independantly perfectly well, but not together. It has been suggested (although not confirmed) that this might be hardware related so not sure what you could achieve from a software/kernel perpective but if it could be sorted then great.

Since I have bluetooth speakers it would be good to be able to stream music from Grooveshark and play them over BT on my speakers. Hopefully somehting others would benefit from as well :o

Thanks again guys for the great ROM and good to know that you're still on the case

Link to comment
Share on other sites

Guest newbe5
Hi Newbe5,

Big thanks to you and Corvus for the excellent work so far. A couple of things that could make your ROM even better (only my opinion of course :mellow: ) : -

1. Working accelerometer (for games) without the need of the toggle switch - This is something that has been achieved in both Fuji-Vega v0.7 (alphaola) and mad-murdocks CM7 nightlies, so not sure if those guys could help you out.

2. Bluetooth & Wifi working together. At the moment if you have Bluetooth on then wifi either stutters badly or doesn't work at all, they both work independantly perfectly well, but not together. It has been suggested (although not confirmed) that this might be hardware related so not sure what you could achieve from a software/kernel perpective but if it could be sorted then great.

Since I have bluetooth speakers it would be good to be able to stream music from Grooveshark and play them over BT on my speakers. Hopefully somehting others would benefit from as well :o

Thanks again guys for the great ROM and good to know that you're still on the case

I will look into the BT thing (I don't use BT, so I haven't come across this myself). The Accelerometer thing, unfortunately this is the way it has to be. Are you 100% positive that it works correctly in Fuji? And if it does, can you use a Mouse when in host mode? This is the issue we face to make both work. Some people want accelerometer, some people want mouse. We need a switch to make them both work.

The Toggle widget is due to a fault with the stock ROM, where rotating the screen while playing games causes the accelerometer axis to rotate by 90 degrees outside of the app, causing the game to spazz out and you crash if you are racing or something. Turning OFF the toggle widget disables out-of-game screen rotation, and resolves this issue. The widget is there so you can easily turn this on and off depending on what you want to do (if you are reading and want to switch to portrait, you can turn it back on for example). I don't foresee this changing any time soon, as it took me quite a while to get it to this stage, although I will experiment with the Fuji ROM to see if what you say is true (honestly, it would surprise me if it doesn't have the same issue, but I have been wrong before!).

newbe5

Link to comment
Share on other sites

Guest the_corvus
1. Working accelerometer (for games) without the need of the toggle switch - This is something that has been achieved in both Fuji-Vega v0.7 (alphaola) and mad-murdocks CM7 nightlies, so not sure if those guys could help you out.

Like newbe had said this has 2 parts, one is the needed files to use mouse or accelerometer and the other one is that during a game the accelerometer try to autorotate launcher (if you have a launcher with autorotation, like vtl in Corvus5). So if you dont wanna use mouse, you can delete some files and deactivate autorotation (the widget is a shortcut) or use a launcher like stock one, this is the way that Fuji does.

2. Bluetooth & Wifi working together. At the moment if you have Bluetooth on then wifi either stutters badly or doesn't work at all, they both work independantly perfectly well, but not together. It has been suggested (although not confirmed) that this might be hardware related so not sure what you could achieve from a software/kernel perpective but if it could be sorted then great.

I really dont tested it, and now i dont have my vega, but will test asap.

Corvus.

Link to comment
Share on other sites

Guest Littleun
I will look into the BT thing (I don't use BT, so I haven't come across this myself). The Accelerometer thing, unfortunately this is the way it has to be. Are you 100% positive that it works correctly in Fuji? And if it does, can you use a Mouse when in host mode? This is the issue we face to make both work. Some people want accelerometer, some people want mouse. We need a switch to make them both work.

The Toggle widget is due to a fault with the stock ROM, where rotating the screen while playing games causes the accelerometer axis to rotate by 90 degrees outside of the app, causing the game to spazz out and you crash if you are racing or something. Turning OFF the toggle widget disables out-of-game screen rotation, and resolves this issue. The widget is there so you can easily turn this on and off depending on what you want to do (if you are reading and want to switch to portrait, you can turn it back on for example). I don't foresee this changing any time soon, as it took me quite a while to get it to this stage, although I will experiment with the Fuji ROM to see if what you say is true (honestly, it would surprise me if it doesn't have the same issue, but I have been wrong before!).

newbe5

I'll check the accelerometer tonight on Fuji-Vega v0.7, when I last tried it with Crazy Snowboard and SpeedX it seemed to work as well as it does on Corvus5. Never tried using a mouse with the Vega so not sure if alphaola's got it working to the detriment of this, from what you've said I'm guessing the mouse won't work though :D

Now I know more about what the specific issues are I can do some more thorough testing on the accelerometer. If I try rotating the vega through 90 degrees as well as connecting a mouse in host mode then I should be able to confirm whether it suffers the same issues :mellow:

Is it worth doing the same tests on CM7? Guessing that because it's on Gingerbread that won't be too much use to you? :D

In relation to the BT/Wifi issue there's a thread already discussing it but nothing conclusive at the moment : -

http://android.modaco.com/content/advent-v...tooth-speakers/

It looks as though maxiP is looking into this so might be worth seeing where he's got to.

Thanks again

Hi Corvus,

Just seen your reply, thanks for getting back to me so soon. I'll also make sure that I test with VTL installed and autrotation enabled, but from what you've said I'm going to experience problems.

Not a major issue as the work-around you've applied covers all circumstances and it's not difficult to press the widget :D

Be good if you could look into the BT issue though :o

Cheers guys.

Edited by Littleun
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.