Jump to content

Superboot - Galaxy Nexus root solution

Guest PaulOBrien

Recommended Posts

Guest causa sui

Thanks Dave90 for the guide you pasted (a few posts above mine). I have the boot loop problem and I can report that using your method it seems I have successfully installed ClockworkMod recovery on the phone. Two problems remain:

1) I still have the boot loop.

2) CWM cannot mount the sdcard, so I cannot restore the default ROM.

I am very worried about this and would appreciate any additional advice.

Edit: Turns out I just had a bad USB port. I swapped to another port, re-locked using fastboot, unlocked, reflashed, and now I'm in business! Thanks for the great tool.

Edited by causa sui
Link to comment
Share on other sites


Kthx for the superboot! It worked w/o problems on my GNex running 4.0.1. A few questions if I may. Will root still be working after an OTA to 4.0.2 which should be rolling out here in Europe afaik. If not can I use superboot r3 to gain root again? If not, will there be another version of superboot?

Anyway, thanks a lot again. Superboot made my life so much easier.


Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
Guest InsaneNutter

Updated to r4, separate LTE and GSM versions.


Any chance this can be updated to support 4.0.4? :) I appear to have lost root after upgrading. I restored root with Voodoo OTA root keeper however no apps can get root.

Tried to re root with Superboot and it gets stuck on the screen with the unlocked padlock now.

Link to comment
Share on other sites

Guest hsmade

+1 here as well


Ah but wait.. just do a fastboot flash recovery with the clockworkmod rec. , upload su.zip and install via recovery... presto ;)

Edited by hsmade
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
Guest deedend

Same for me... tried to install via fastboot and it gets stuck on the screen with the unlocked padlock. Galaxy Nexus 4.0.4 IMM76I.

I haved seen the automated method but I prefer use fastboot to root my device.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...
Guest gianton

Great tool, thanks!

The following part I managed to do it as per this thread.

Note: If you are using a retail Galaxy Nexus, you may need to unlock the bootloader first, using './fastboot-windows oem unlock' (or the appropriate version for your machine). Note that the OEM unlock sequence wipes your device.
Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...

Updated to the latest release!

What has been updated?

SuperUser doesn't work with 4.2 and upwards unless you use a patched version. SuperSU does work from version 0.98, but is closed source.

adb-windows.exe in the package is old (1.0.25). 1.0.31 and later is needed to support adb sideload.

Would be great to see a changelog, and also please update the adb and fastboot binaries to their latest versions. Here is a link to the platform-tools_r16 for all platforms: http://www.hariadi.o...platform-tools/

Edited by oGr3
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.