Jump to content

[U8800] [How To] Root, Install ClockworkMod + Remove Bundled Apps from Official 2.3.5

Guest That-Guy

Recommended Posts

Guest lovetide

I used RootExplorer, turns out they were mounted, but for some reason ES File Explorer still couldn't delete them. RootExplorer on the other hand deleted them with ease.

Thank you.

There's root setting in ES File Explorer, maybe you can enable it and "enable mount / and /system as rw" option and try again.

Link to comment
Share on other sites

I tried to downgrade like it says in the 1st post and it wo'nt go through. it always says update failed.

I think your missing a step. cause we are not suposed to be able to downgrade so it has to be some trick to it, and whats explained its just too straight forward I think.

Link to comment
Share on other sites

It fails but you should be able to boot into recovery and reset to factory defaults to get it to boot :)

no no,

nothing happens, it just says unpacking but the pink bar doesn't move and sometimes it just says update failed right off the bat with a yellow warning sign.

just so I can recreate your environment, wich boot and recovery do you use when downgrading? stock 2.3.5 from 28/12?

Link to comment
Share on other sites



Could you please write a mini-review of the official 2.3.5 U8800?

How are the camera/ video camera (does it include improved Adreno 205 drivers), overclocking (is it possible), locked bootloader (is that a real problem for the future) and so on. Your notes of using official 2.3.5 for couple of weeks.

I am currently running Geno CM 7.1-u8800, but I am considering upgrading to official 2.3.5 per your instructions.

Link to comment
Share on other sites

  • 3 weeks later...
Guest Cursed Chico

There's root setting in ES File Explorer, maybe you can enable it and "enable mount / and /system as rw" option and try again.

Thank you so much:)

Link to comment
Share on other sites

Guest SadMummy

I would like to give the official 2.3.5 ROM a shot.

However, I got this device with MIUI installed.

In order to install the official ROM, I should first downgrade to 2.2.2 and then start with the Rooting step at the beginning of the tutorial?

About step 2 of the downgrade proces (Extract the "dload" folder and copy it (along with its contents) to the ROOT of the SD Card), should I extract it to the internal or external SD card?

Link to comment
Share on other sites

Can anybody re-upload/mirror SuperOneClick v2.3.3 please...? Multiupload doesn't work, and I just upgraded to official Gingerbread. Nice guide there, mate. :D

Edit: Mediafire link will be much appreciated. Thanks in advance. :)

Edited by Xann
Link to comment
Share on other sites

  • 2 weeks later...
Guest ootyposoo

I cant root, I followed instructions step by step, still SuperOneClick crushes everytime I try to root! It stops working please help! PLEASE

Link to comment
Share on other sites

  • 2 weeks later...
Guest ThaPhool

Hi guys,

waiting for the new links for cust.img

please update the new links as these are not working any more.

Since the modified cust.img was no longer available I created my own. My instructions as below. hope it helps.

Copy /cust_backup/image/cust.img off your rooted phone using the appropriate tools remount/ES File Explorer/File Exper etc

Download some form of Linux Live CD.. I used Slitaz Linux 3.0 which worked a treat

Create a Linux VM on your chosen virtual host.. I used Virtual Box

Mount the live CD iso on your VM CD drive and set it to boot from CD

Boot it up

Open terminal and become root ie use the command su etc (default root pass on slitaz is root)

To get the cust.img file onto the linux distro I put it on a share and mounted it as below fron the terminal

Install smb [tazpkg get-install smbfs]

Create a folder to mount your share to [mkdir /mnt/share]

Mount your share depending on how its setup.. for me it was [mount.cifs //ip/share /mnt/share -o User=UserName]

Copy the file to your home folder [cp /mnt/share/cust.img /home]

The you just mount the img file to a folder you create

mkdir tmp

mount cust.img /home/tmp

Open the mout point

cd /home/tmp/hw/default/app

Delete apk files what you don't want and unmount the file

eg rm SomeCrap.apk

unmount tmp

Copy the file back to your share/phone and reboot your phone

Link to comment
Share on other sites

  • 4 months later...
  • 2 months later...

Huawei Ideos X5 and have an I tried to put modaco CWM 5.0.4 After the tutorial

I entered cut_backup or something with root browse, and from there we replaced his original recovery.img from CWM recovery 5.0.4.

I died, and gave him to enter CWM. nothing

Now I can only open it in fastboot, and when USB stick PC can get into folderu `What you boot recovery, I tried to stick another recovery.img but in vain.

What can he do? recovery if you stick to the original one go? You can get the device's recovery & boot img?, And I can attach them to bag them in phone to solve the problem?

how can I rewrite them soft?

Link to comment
Share on other sites

  • 2 months later...
Guest leripe

I'm trying to root my gf's u8800 pro, but it gets stuck on waiting for device when trying to use superoneclick and also tried superboot, didn't work (back to original boot.img now).

The phone is on:

android 2.3.5

baseband 404020


program versio U8800PV100R001C00B535

custom version CUSTNORC306D002

Edit: Got it rooted by first upgrading it to huawei's 'official' ics.

Edited by leripe
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.