Jump to content

[ICS] [CM9] [4.0.4] CyanogenMod 9 for the ZTE Crescent [ROM] [Last updated: 13/07]


Recommended Posts

I added Ganster's HQ video fix by doing a cheap WinZip job and just replacing the libstagefright and lib omx files in our build with the ones from his gansterkang build for the blade i am uploading it right now. Please don't give me credit for it, I just replaced some files, give Ganster and Daz the credits, they deserve it way more !

Edited by gbosh
Link to post
Share on other sites
  • Replies 2.7k
  • Created
  • Last Reply

Popular Posts

Congratulations man. Really cool to see your effort finally paying off. I'll have a look at the WiFi issue.

Hey Daz, when you're not busy, can you tech us how to do this? Or release a build of this? It's so awesome I really wanna know how to do it :P How do you figure things like this out anyways? xD Pur

Me not, maybe someone else, because libstagefright on jellybean is very different EDIT: Here's the SF 2 version http://www.mediafire...-p736vHQFIX.zip Here's the TMV version http://www.mediafire

Posted Images

Well it fixes all hq video playback issues,nothing else. Video recording works, like before, thumbmails don't generate, but videos play back

Like on the blade I think

Edited by gbosh
Link to post
Share on other sites
Guest CurtisAndroidSF2

Any chance of applying the modified libstagefright to CM10, it'd be excellent if you could get video recording working on it (HQ YouTube & camera flash would be amazing). I'm sure Ganster mentioned applying the fix to Jelly Bean ROMs on the XDA thread.

And is it possible to get the camera flash working on ICS now or is it out the question?

Thank you

Link to post
Share on other sites

Hey guys, I just noticed that applying gansters fix doesn't work perfectly right of te bat,very few Videos play with Strange colors

But all hq videos make the device reboot after like 7 or 8 minutes Fixed it by doing a simple wipe.I am going to post a logcat of that happening.Hopefully Daz or ganster can solve the problem :(

Edited by gbosh
Link to post
Share on other sites
Guest AmbushReality
Hey guys, I just noticed that applying gansters fix doesn't work perfectly right of Thema bat,very few Videos play with Strange colors

But all hq videos make the device reboot after like 7 or 8 minutes.I am going to post a logcat of that happening.Hopefully Daz or ganster can solve the problem :(

I don't get this problem at all, I recently watched 10 20Min YouTube videos without any crashes
Link to post
Share on other sites

Strange, maybe I will just have to wipe. Crashes on long videos seem to be fixed after wiping.

Still I am trying to do a build from Ganster's and Daz's sources, just for gaining some experience, even tho I can't really write code (yet, I will start learning it over the course of like the next year)

Edited by gbosh
Link to post
Share on other sites

CM9 is great rom but still it demands a more polishing like buttons dont alwayse glow in dark and autobacklight fix..Also camera flesh whoud be nice too.Is that even possible ? And what really did this new driver brings us except youtube HQ ?

Link to post
Share on other sites
Guest ruyzalim

Me not, maybe someone else, because libstagefright on jellybean is very different

EDIT: Here's the SF 2 version http://www.mediafire...-p736vHQFIX.zip

Here's the TMV version http://www.mediafire...-p736eHQFIX.zip

hello i want to update my vivacity with the rom from the first post , for what is the tmv version , how to apply it is it necessary? thank you very much

edit: ouuu i understand now its the same rom but fixed ;) thanks

Edited by ruyzalim
Link to post
Share on other sites
Guest CurtisAndroidSF2

Hello,

Just wondering if any progress has been made with Gansters modified libstagefright- Is it possible to use that to get the camera flash working or not? It's just nice to have the flash working and it's the only thing that annoys me. Although I'll be purchasing a Ascend G300 at the end of January so hopefully there's a few fully working ROMs for that!

Thank you for reading and for your hard work in developing for the Crescent.

Link to post
Share on other sites
Guest Liamness

Flashed the new version with the libstagefright fix that gbosh, not totally sure if it's working right. Still a lot of stuttering in youtube videos, only goes away when switching off HQ. I remember when using FnC it could play 480p videos using MX Player easily enough, going to test it using that as a benchmark.

*edit*

Almost forgot, cheers for the build gbosh! Also thanks to this 'ganster' chap whoever he may be.

Edited by Liamness
Link to post
Share on other sites
Guest Liamness

Nah that wouldn't fix anything, as the app would have to find drivers for the radio which aren't in the ROM.

MX player can't play videos with HW acceleration it seems, which would explain youtube being choppy. I'm surprised how well it does just in software, but still not really all that watchable. Wondering what I did wrong and how to fix it. Going to wipe user data and cache, see if that clears anything up. I stress that I already did that when installing this version of the ROM with the new patch, just trying to avoid a full reinstall.

*edit*

That'll be why it didn't work, I didn't even install the version with the patch. Flashing rymate's handy zip now.

Edited by Liamness
Link to post
Share on other sites

@Mind sometimes it just happend and you cant do anythig about it untill you flash again same ROM (it worked for me - about 7 times i flashed cm9 and that same bugg happened 2 times)...

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.