Jump to content

[ICS] [CM9] [4.0.4] CyanogenMod 9 for the ZTE Crescent [ROM] [Last updated: 13/07]


Recommended Posts

  • Replies 2.7k
  • Created
  • Last Reply

Popular Posts

Congratulations man. Really cool to see your effort finally paying off. I'll have a look at the WiFi issue.

Hey Daz, when you're not busy, can you tech us how to do this? Or release a build of this? It's so awesome I really wanna know how to do it :P How do you figure things like this out anyways? xD Pur

Me not, maybe someone else, because libstagefright on jellybean is very different EDIT: Here's the SF 2 version http://www.mediafire...-p736vHQFIX.zip Here's the TMV version http://www.mediafire

Posted Images

Guest Dazzozo

http://developer.android.com/guide/developing/tools/adb.html#commandsummary

There's all the commands on the Android Dev.

If you see anything that might work, post it and I'll give it a go tomorrow :)

-Ninjeh.

Wouldn't have a clue as I don't have a phone, but my best guess is the command wouldn't be too different from the one I gave you, probably just aimed at a different /dev/ device. Honestly though, I have no idea.

Link to post
Share on other sites
Guest Dazzozo

Here's what I get from catlog. None of it means a word to me but seems dalvikvm is only at between 3% and 9% free when I was watching it, could this be a problem or am I talking crap? Seemed to be quite a few failures and errors also. Hope it means something to you!

http://pastebin.com/bWXsGc6M

I've got a couple of ideas from it. Do you have any ideas how I can reproduce it reliably?

Link to post
Share on other sites
Guest RedZombie

I've got a couple of ideas from it. Do you have any ideas how I can reproduce it reliably?

That log was just from boot, I have still to get the blank screen/widget issues to happen since installing catlog so right now, the answer is no unfortunately. I did a full format and reflash this morning too to see if that would solve it but alas, no :/

Link to post
Share on other sites
Guest Dazzozo

That log was just from boot, I have still to get the blank screen/widget issues to happen since installing catlog so right now, the answer is no unfortunately. I did a full format and reflash this morning too to see if that would solve it but alas, no :/

Blank widgets is very very strange. More so than blank apps. I think I'll drop a widget on my home screen and run it for tomorrow.

Link to post
Share on other sites
Guest RedZombie

Blank widgets is very very strange. More so than blank apps. I think I'll drop a widget on my home screen and run it for tomorrow.

I suppose blank is probably not completely accurate... the widget header is still there but the contents disappear...

Link to post
Share on other sites
Guest Dazzozo

Done, thanks a lot :)

Got it. I'll try and thrash this email widget tomorrow to try and get it to bug out. I don't think I'm going to be able to debug this at 1am so I'm off to bed. :P

Link to post
Share on other sites
Guest RedZombie

Got it. I'll try and thrash this email widget tomorrow to try and get it to bug out. I don't think I'm going to be able to debug this at 1am so I'm off to bed. :P

Fair comment :P sleep well dude, look forward to tomorrow!

Link to post
Share on other sites
Guest beavis77

Okay so the problem was that the vivacity keys don't seem to fire up any events in /dev/input/event1. If I remove that filter I get loads of information on event2 and event0...

I haven't installed CM9 yet, but this is what I found out under GingerBread:

Looks to me like the soft keys are just registered as regular touch screen events in /dev/input/event0

horizontal position under 0003 0035

vertical position under 0003 0036

origin is top left

home button horizontal position is between about 0003 0035 00000080 and 0003 0035 000000e0 (probably actually 120 - 240px)

vertical position of soft buttons starts at 800px and extend to about 840px (0003 0036 00000321 - 0003 0036 00000348)

HTH!

Link to post
Share on other sites
Guest BenTheHuman

Hey guys.

Great job with the whole cm9 thingy cant wait til youve figured out the camera problem etc.

Anyway ive installed everything so far including the small update you just did.

and my wifi mac address has changed to now being 11:22:33:44:55:66.

Therfore i cannot access the wifi and more importantly i cant sign into google because this requires wifi.

I cannot therfore sign into the play store to download anything which may help.

What do i do to fix this?

Link to post
Share on other sites
Guest Dazzozo

Hey guys.

Great job with the whole cm9 thingy cant wait til youve figured out the camera problem etc.

Anyway ive installed everything so far including the small update you just did.

and my wifi mac address has changed to now being 11:22:33:44:55:66.

Therfore i cannot access the wifi and more importantly i cant sign into google because this requires wifi.

I cannot therfore sign into the play store to download anything which may help.

What do i do to fix this?

You unlocked your phone and didn't back up the MAC address with a QCN file.

Link to post
Share on other sites
Guest PsYcHoKiLLa

Well, hopefully you used QPST to backup your details first, before installing anything, as that's what every tutorial here tells you to do. If you have then great, just fire up the software download program in QPST and use the restore along with the file you saved and that will restore your mac address for you. If you didn't, then did you at least take a note of the mac address before starting? If not then you're gonna have some hex editing to do and you should slap your forehead, jus' sayin.

Link to post
Share on other sites
Guest BenTheHuman

Well, hopefully you used QPST to backup your details first, before installing anything, as that's what every tutorial here tells you to do. If you have then great, just fire up the software download program in QPST and use the restore along with the file you saved and that will restore your mac address for you. If you didn't, then did you at least take a note of the mac address before starting? If not then you're gonna have some hex editing to do and you should slap your forehead, jus' sayin.

Umm dunno bout the saved file in QPST so hopefully imma have a look a return with a grin.

If its a frown though. Yes i did take a note of the wifi mac address beforehand

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.